Thread Tools
Old Jan 21, 2012, 09:19 PM
ecworks is offline
Find More Posts by ecworks
Registered User
Discussion

Eagletree "OSD not connected" error


My EagleTree Pro came in and I have some problems with it,
The E-Logger works fine and is blinking as it should (3 blinks, then repeat) and is recognized by the computer and the E-Logger software and will accept the firmware updates but the software will not recognize the new Eagletree Pro that you just sent me.

I keep getting the message: “OSD not connected”. (see below)

I get the same message when I attempt using my laptop or my desktop computer. By the way the Eagletree Pro is connected properly to the E-logger with no other sensors plugged in.

Any ideas on what this might be?
Sign up now
to remove ads between posts
Old Jan 27, 2012, 01:47 PM
billpa is offline
Find More Posts by billpa
billpa's Avatar
Hi, first, I am assuming you have an OSD Pro. Is there any chance that the OSD Pro's 4 pin cable is not correctly connected the eLogger? Note that the polarity and port have to be correct. The top port is for the GPS, and the bottom port is for the OSD, and the red wire should be at the edge of the eLogger.
Site Sponsor
Old Mar 27, 2012, 04:11 AM
frere75 is offline
Find More Posts by frere75
Registered User

Same problem


I have exactly the same problem. I have also a GPS connected to the E-logger and the led does not blink or light. I have checked several times connexion, but all seems OK.
Do you have any idea ?? What is the risk of polarity inversion ?? is there any polarity protection ?
Old Mar 30, 2012, 02:51 PM
billpa is offline
Find More Posts by billpa
billpa's Avatar
frere75, if the eLogger does not blink when the OSD is connected, but does blink when the OSD is disconnected, something has been damaged either with the OSD or the eLogger. This is normally caused by a broken OSD cable or high voltage reaching the OSD's digital ports, but could be due to something else. If the cable looks good, if you could open a ticket with us at http://ticket.eagletreesystems.com we can get the two pieces in house to troubleshoot.
Site Sponsor


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion OSD pro V3 "Not connected" savage 40 Eagle Tree Systems 2 Jan 21, 2012 09:59 PM
Help! Osd graphical error and internal error glambert Eagle Tree Systems 13 Jan 01, 2012 02:58 AM
Discussion Lanyu Radio Transmitter Antenna Not Connected FeiJi Beginner Training Area (Aircraft-Electric) 4 Sep 10, 2011 09:33 AM
Help! Eagletree OSD Pro throttle? Taiping FPV Talk 3 Mar 21, 2011 12:46 AM
Discussion EagleTree OSD - Failsafe not engaging Cralis FPV Talk 7 Nov 07, 2009 06:04 PM