Fy-31ap - Page 91 - RC Groups
Thread Tools
Oct 21, 2012, 10:14 AM
saabguyspg's Avatar
good stuff, I would highly recommend getting data modems (just xbee pro will work fine from DIY drones cause they are already paired for you)

getting the modems is great cause you can monitor the planes position, add waypoints, and do click and fly which is really cool.

Sign up now
to remove ads between posts
Oct 21, 2012, 03:41 PM
Registered User
I managed to upload the way points!!!
It was easy thanks to Steve who made me to download the GCS 4.0
Since then all of it works.
The only problem I have is that the com port disconnects from the GCS from time to time. I need to reconnect by closing and opening again the application.
Other than this it is OK.
Steve can you post a link to the data modems? I was looking for them on the DIY drones web but could not locate them. Thanks a lot for your help.
Oct 21, 2012, 05:05 PM
Registered User
Hey I am selling a pair of fy602 data radios. Here's the link. Any decent offer will be accepted
Oct 21, 2012, 11:25 PM
Registered User
Use the 3DR radios. A pair cost less then $40 and have a longer range than xbee and are well supported.
Oct 22, 2012, 01:11 AM
Registered User
I use dragon link for Rc - 433Mhz
Video link 900 Mhz
For the data radio I need some other frequenci.
I have a range of 6 miles using the above mentioned fr combination. The data radio should have a range of at least 11 miles.
3DR radios work at 433 or 900 Mhz - 100 mw That means I can not use them.
Oct 22, 2012, 12:17 PM
saabguyspg's Avatar
Right on! Glad it's finally working for you, hopefully the program is more stable for you as well!

PistaJ sorry you can't use the xbee pro then either as it runs on 900mhz

you will need a 2.4ghz modem.
Oct 22, 2012, 01:37 PM
Registered User
Yes I know.
By the way all went wrong. I can use the gcs 4.0 with the unit but when I went to fly the waypoints suddenly I realised I do not control the unit by my TX. I have no idea when it actually happened.
My rudder, aileron and throttle output stopped replying. Only the
elevator output is alive. I can see the elevator bar is moving in the gcs.
Not the other outputs. If I join servos, they go to max positions as they all output 0.9ms. Only the elevator output works as a reply to the FY movement. Not to the EL Ch movement on the TX. I am not able to activate the RC button in the GCS.
If I move the channels on the TX, nothing happens in the GCS. Did the GCS
4.0 destroy my unit?
I checked the fy31 AP, initiated the gyros and once more uploaded the software 2.0

All successful but the unit is dead (partly - as it stil communicates with the osd and GCS). It does not react to RC commands. The servos outputs stay at 0.95 ms.

When the unit is set for delta wing the elevator outputs servo commands only when I move the unit, but does not do anything as a respond to the RC TX commands.

The read diode is working as there is no error with the unit.

What do you think I should do?
Why is the NAV mode change feature missing in the 4.0

.....hell will I ever get to flying waypoints?
Oct 22, 2012, 01:49 PM
saabguyspg's Avatar
[QUOTE=PistaJ;23070203]Did the GCS
4.0 destroy my unit?

how would that be possible? It's just a GCS...

Let me re-read your post and give it some thought... but it may be beyond my ability to help.. sorry.

Oct 23, 2012, 12:40 AM
When a hobby gets a passion
Originally Posted by saabguyspg
that is a huge S.... a small s is over correction and usually means too large P value... usually... the big S needs side offset damp increased... usually.... hahah... nothing is written in stone with this stuff.

Autpilots take time to learn belive me I have been flying many different ones for 7 years now... and trust me this one is the easiest... you will get it!

Well, the wobbeling was back after the successful flight. I guess it was just a "good luck day". Anyway, I wanted to get to the bottom of it. Because I remembered in the beginning, my plane did not have this problem. So I decided to start from scratch:

1. Perfectly balance the plane and make sure the CG was in the correct place
2. Wait for a day with no wind (last Saturday) and trim the plane without autopilot and stabilizer. (switched off)
3. Record neutral value during flight (DIP switch number 4)

After all these steps, the problem has been solved !!!

I noticed during step 2, I needed to trim aileron to make it fly straight. So my assumption now is due to not having straight flight due to being un-trimmed, it was flying in a “slow right turn”. The autopilot corrects this error by turning left. When it reaches the path, autopilot levels and the plane flies again in a “slow right turn”. This may help others who have the same problem like me. It is very important the plane is well trimmed BEFORE using the FY31AP in any way.

I also found another manual on Feiyu website (http://www.feiyu-tech.com/product-en...3&id=26&step=3) which explains much better the PID settings, the effect of the settings and the explanation of the values. The manual is the “Panda Manual 1.12”. From page 31 onwards, it explains all the settings, shows the default settings and is very helpful for understanding this operation. I mentioned this to Feiyu Tech support and they replied "But on the manual has some mistake. We need rewrite it again. And for the PID setting we will write a manual about it."
Oct 23, 2012, 06:16 AM
Registered User
Appears I have fixed my FY-31ap after the gyro problem. Turns out I was not resetting the gyro. The section of the manual was not too clear. I was shorting the GPS rx/tx pins. However, it is the uart rx/tx pins that need to be shorted. When this happens there is a lot more blinking of both the red and blue LEDs and this goes for quite a few seconds.

Now the red led does not blink when the plane is stationary and the artificial horizon is correct after doing my best to shake and spin it as before.
Oct 23, 2012, 09:51 AM
Registered User
I see the TXT file in the Firmware 2.0 firmware download says it can only be applied to the newer version of the fy31ap which has a better variometer.
Anybody tried it with an old one? I assume mine is old, Bought in January 2012
Oct 23, 2012, 10:18 PM
When a hobby gets a passion
Originally Posted by GTiDonavan
I see the TXT file in the Firmware 2.0 firmware download says it can only be applied to the newer version of the fy31ap which has a better variometer.
Anybody tried it with an old one? I assume mine is old, Bought in January 2012
I also bought mine around that time, put on the new release 2.0 and works fine for me. The TXT file says it ALSO works for older versions.
Oct 24, 2012, 03:04 AM
biggles uk's Avatar
does anyone know whats changed on the new version of the firmware?
Oct 24, 2012, 10:50 AM
Registered User
Originally Posted by biggles uk
does anyone know whats changed on the new version of the firmware?
Good luck with that one. They carnt even update there own website withthe latest fw thats been released.
Oct 25, 2012, 05:52 AM
Registered User
Does connecting the tx from the hornet OSD to the fy-31ap enable voltage and current info to be read in the computer software when using a modem? Thanks

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product FY thread: FY20A/FY21AP/FY3ZT/FY31AP/FY90Q/FY91Q/FY-Frame/FY-GCS/FY-OSD/FY-Dataradio yiny0730 FPV Talk 316 Sep 19, 2011 02:30 PM
Discussion Question: KK board and FY-20 or FY-90q Hamanu Multirotor Drone Talk 2 Feb 08, 2011 05:10 PM
AXI'fy your CORONA...NIB 2820/10 iflych52 Aircraft - Electric - Helis (FS/W) 0 Jul 26, 2004 09:24 AM
Fy or Die ? a newbie poll Demolisher Foamies (Kits) 29 Mar 08, 2003 03:31 AM