Fy-31ap - Page 25 - RC Groups
Thread Tools
Mar 22, 2012, 08:09 AM
Registered User
btw I just figured out that the "Deactive RTL" button is disabled and locked for 31AP. THey have done it purposely or else no one will buy their Panda or the 3ZT... LOL
Sign up now
to remove ads between posts
Mar 22, 2012, 10:53 AM
saabguyspg's Avatar
will it not work if you set your receiver failsafe to path navigation?

or does the RTL kick in when you lose the modem even if you still have receiver?

Mar 22, 2012, 03:48 PM
biggles uk's Avatar
Hi everyone
Does anyone know where I can get the software to use the 8 waypoint feature of my fy31ap I have tried the fyetech website and the link for the software just says forbidden. Can anyone help me!
Mar 22, 2012, 03:52 PM
saabguyspg's Avatar
I am pretty sure I have the link for it on page one... unless there is a more recent version someone can point out to me.

Mar 22, 2012, 04:47 PM
biggles uk's Avatar
Thanks Steve thats worked
Forgive my stupidity but I am quite new to this, I have the fy31ap installed in my plane and all the functions work great (it is an amazing piece of kit!), I am now trying to work out the waypoint function. I'm not doing fpv so there is no video or OSD set up. My question is how do I down load the waypoints on to the auto pilot. I saw on your setup video you had a data modem, I don't have one of those and don't even know what they do, do I need one to make the waypoint feature work? once again forgive my stupid questions
Mar 22, 2012, 04:56 PM
saabguyspg's Avatar
Biggles, no question stupid so long as we are all having fun!!! it's negative people that annoy me

welcome to the world of fpv and uav's!

ok so if you want to load waypoints without a data modem yes it is doable.

did your unit come with a usb cable? it would have a usb end on one "end" and on the other end it will have a four pin plug. Of which one is ground, one is 5v and the other two are TX (trasmit) and RX (receive)

if so you are in great shape! you then plug this cable into the 31AP where the data modem goes (see manual) ensuring you plug it in the right way (look at the 31AP it will telll you what wire is ground or black and that will help you put it in correct)

Then you connect just like in my video, upload waypoints etc and save to autopilot.. you now have waypoints programmed in.

Modems are just communicators they let your plane talk to the laptop and vice versa. They are very usefull and FY has a nice lineup of them. you can also use Xbee modems but being that you are new I would stick to the plug and play FY modems ensuring you do not buy one on the same frequency as your transmitter.

If you don't have a USB cable you can make one or buy one from FY.

Hope this helps.

Mar 22, 2012, 05:15 PM
biggles uk's Avatar
Aha I do indeed have a usb cable. That all kind of makes sense now thanks very much, I will give it a go an see how i get on
Mar 22, 2012, 05:55 PM
biggles uk's Avatar
I have plugged the usb cable in to my laptop and the servos just start to go mental, any suggestions? does the plane have to be powered up with the battery aswell
Mar 22, 2012, 06:41 PM
saabguyspg's Avatar
the plane should not theoretically need to be powered but because you have your servo's plugged in it will draw too much power for your USB port so you should power the plane for this yes.

edit sorry I should have told you this.... don't do it again or you can burn out your USB ports power supply

Mar 23, 2012, 12:36 AM
Registered User
@ Biggles

Please disconnect any servos from the 31AP before connecting to USB. the power from USB is common with all servos and receiver.

If you do not wish to remove the servos (i understand it may be very difficult and bugging all the time), then just remove the RED cable from the usb wire. Do not connect the RED wire. With this you will have to power the 31AP through normal flight pack or BEC.
Last edited by aeromodellers; Mar 23, 2012 at 03:37 AM. Reason: grammar
Mar 23, 2012, 02:16 AM
Gravity Test in Progress
I just picked up a SBEC made by JETI that has a output of 12A and two leads on the output side. 5-8v selectable output and 6-42v input. They have a loyal following over here in Europe.

JETI model s.r.o.
Mar 23, 2012, 03:37 AM
biggles uk's Avatar
I will try disconnecting the servos and let you know how itgoes
Mar 23, 2012, 08:51 AM
biggles uk's Avatar
Right I'm getting there slowly. I think the gcs software Ive down loaded doesn't quite work right. This is where I have got to now
I have unplugged the servos and powered up the plane with the battery then when its located the satellites I have plugged it into my laptop with the usb cable. I can locate the plane on the screen but there seems to be some of the screen missing on the right and when I click on theicons I get this message
Mar 23, 2012, 09:37 AM
saabguyspg's Avatar
are you running windows 7 or xp?

if running win7 uninstall the application and re-install as an administrator... then make sure you run the progarm as an administrator..

if you run xp someone else has to help sorry my old xp machine never ran it properly

ps yes please remove the red wire from the usb thanks aero!!! so many options!!!

Mar 23, 2012, 09:50 AM
Registered User
I have had this issue. Login into administrator and try.
Open the program as administrator by right clicking and choosing "Run as Administrator"
Finally Reboot your PC, it should resolve your issue.

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product FY thread: FY20A/FY21AP/FY3ZT/FY31AP/FY90Q/FY91Q/FY-Frame/FY-GCS/FY-OSD/FY-Dataradio yiny0730 FPV Talk 316 Sep 19, 2011 02:30 PM
Discussion Question: KK board and FY-20 or FY-90q Hamanu Multirotor Drone Talk 2 Feb 08, 2011 05:10 PM
AXI'fy your CORONA...NIB 2820/10 iflych52 Aircraft - Electric - Helis (FS/W) 0 Jul 26, 2004 09:24 AM
Fy or Die ? a newbie poll Demolisher Foamies (Kits) 29 Mar 08, 2003 03:31 AM