Lumenier RB2205C-12 2400KV SKITZO Ceramic Bearing Motor
Thread Tools
Old Jul 02, 2012, 12:06 PM
Joncreid is offline
Find More Posts by Joncreid
Registered User
Joncreid's Avatar
Quote:
Originally Posted by OrbitalGolem View Post
Is the main motor running at full speed independent of throttle stick position? If so, then the FET is likely bad. That's the problem with mine and I've ordered replacement FETs from DigiKey.
No the main motor is functioning properly.
Everything works fine except tail
Can't be devo settings because works fine with genius
Why would my mini cp just spin like a top
Sign up now
to remove ads between posts
Old Jul 02, 2012, 12:17 PM
magic_marty is online now
Find More Posts by magic_marty
<Marty>
wonder if the wires are soldered to the tail motor backwards? check and make sure the tail motor is spinning in the correct direction by comparing it to the Genius that is working properly..
Old Jul 02, 2012, 01:12 PM
Joncreid is offline
Find More Posts by Joncreid
Registered User
Joncreid's Avatar
Quote:
Originally Posted by magic_marty View Post
wonder if the wires are soldered to the tail motor backwards? check and make sure the tail motor is spinning in the correct direction by comparing it to the Genius that is working properly..
Compared with genius,
They both spin ccw when face on to tail blades
Old Jul 02, 2012, 04:56 PM
Jon.M.Barter is offline
Find More Posts by Jon.M.Barter
Team Armattan
Jon.M.Barter's Avatar
Quote:
Originally Posted by Joncreid View Post
Compared with genius,
They both spin ccw when face on to tail blades
check to make sure your gyro is actualy on on the tx, and rudder trim is correct.
also, check that your main blades are going clockwise. thats my best guess, good luck
Old Jul 04, 2012, 11:13 AM
Joncreid is offline
Find More Posts by Joncreid
Registered User
Joncreid's Avatar
Where do I turn gyro on?
I have gyro sensor on automatic at 82% in normal mode


Just a update to my spinning problem

I have devo 8
Mix switch is set to 0
I tried putting in fresh settings but didn't help

I can take off but heli just spins uncontrollably

Why has my tail motor suddenly got a mind of its own ?

It was perfect before
I've ruled out transmitter
I compared which way both blades are spinning to my genius and they're same
Help
Old Jul 04, 2012, 11:29 AM
dreamz123 is offline
Find More Posts by dreamz123
Registered User
Could be your rx. Mine span like that once , but turned out to be my fin stopping the rotor
Old Jul 04, 2012, 11:36 AM
fishfiend is offline
Find More Posts by fishfiend
Registered User
Could the hole in the tail rotor have enlarged slightly, allowing the tail motor shaft to skip?
Old Jul 04, 2012, 11:46 AM
Joncreid is offline
Find More Posts by Joncreid
Registered User
Joncreid's Avatar
Hope it's not rx

Don't think it's tail assembly as i just put on new set

I've noticed there is some play where the boom attaches to main frame but don't think that would cause this
Old Jul 04, 2012, 09:36 PM
OnceAFly is offline
Find More Posts by OnceAFly
Registered User
OnceAFly's Avatar
Quote:
Originally Posted by Joncreid View Post
Where do I turn gyro on?
I have gyro sensor on automatic at 82% in normal mode


Just a update to my spinning problem

I have devo 8
Mix switch is set to 0
I tried putting in fresh settings but didn't help

I can take off but heli just spins uncontrollably

Why has my tail motor suddenly got a mind of its own ?

It was perfect before
I've ruled out transmitter
I compared which way both blades are spinning to my genius and they're same
Help
Can you get a video of the problem? So we can see what when wrong.
Old Jul 04, 2012, 09:38 PM
magic_marty is online now
Find More Posts by magic_marty
<Marty>
What was it doing before you replaced the tail assembly? Was it spinning like it is now?
Old Jul 05, 2012, 09:17 AM
Joncreid is offline
Find More Posts by Joncreid
Registered User
Joncreid's Avatar
Yes was spinning just like now, I replaced tail as boom was split and thought it was causing my problem

I'll try upload video now
Old Jul 05, 2012, 10:14 AM
i812 is offline
Find More Posts by i812
Registered User
i812's Avatar
If the Mini spins CCW when the Main Blades spin CW, then that indicates the Tail Rotor isn't producing enough counter torque, and possible reasons are:

Not enough Tail Blade pitch
Tail Blade slipping on Tail Motor shaft
Tail Motor not producing enough torque-rpm
Tail Motor wiring problem
  • Open - Tail Motor doesn't rotate
  • Reverse Polarized - Tail Motor rotating in reverse
RX

Have you verified the Tail Rotor increases and decreases rpm as the TX RUD stick is moved right and left?
Old Jul 05, 2012, 11:27 AM
Joncreid is offline
Find More Posts by Joncreid
Registered User
Joncreid's Avatar
Mini cp tail issues 2 (0 min 31 sec)
Old Jul 05, 2012, 11:30 AM
Joncreid is offline
Find More Posts by Joncreid
Registered User
Joncreid's Avatar
It seems like the gyro is not working
The tail doesn't hold
If I move stick right the blades spin up but they lock at full speed


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Cool World Smallest Lightest Indestructible 3D helicopter :Genius CP!! DLY Micro Helis 9889 May 18, 2016 01:17 PM
Discussion Walkera Genius CP-the smallest 3d flybarless heli in the world! @ oomodel oomodel.com Hot Online Deals 17 Sep 28, 2015 11:48 AM
Careful! World Smallest Lightest Indestructible 3D helicopter Genius CP "More Junk" Iceblade1A Micro Helis 91 Sep 25, 2011 12:38 PM
For Sale Walkera 52 CP 3S MICRO heli(smaller than a Gaui)$75 DELIVERED Z06 Tony Aircraft - Electric - Helis (FS/W) 0 Aug 16, 2009 08:38 PM
Question Whatís Better than a Blade CP and Smaller than a Trex? HavingFun2002 Micro Helis 74 Mar 05, 2006 06:07 PM