Thread Tools
Mar 15, 2012, 05:17 PM
Registered User
Tobie,

I think that A Monell is asking about the latest version of the PC software, not the latest version of the firmware.

Cheers,
Mike.
Sign up now
to remove ads between posts
Mar 15, 2012, 06:26 PM
as much as I can
beenflying's Avatar
Quote:
Originally Posted by Tobiemanser View Post
From my understanding if you upgrade the firmware the unit becomes a tarot zyx and only works with the zyx programming box. I think this is the case with the cx but not to sure that eny body has even tried upgrading ether the 3gys or the helicox but I'd imagine it would be the same
I don't recommend crossflashing the ALZRC 3GYS or the Helicox TG1 to the Tarot ZYX firmware.

Only the the CX-3X1000 and the Tarot ZYX have the same circuit board and components.
Mar 15, 2012, 06:30 PM
as much as I can
beenflying's Avatar
Quote:
Originally Posted by John_NZ View Post
Added a parameter comparison dialog to the new version of FBL.
Probably should change the order of the parameters into a better order.
May also investigate highlighting lines that differ.
Excellent, John. I could have done with that last night.

Is cyclic compensation missing for some reason?
Mar 15, 2012, 06:33 PM
as much as I can
beenflying's Avatar
Quote:
Originally Posted by keris View Post
Hi all after being assist by john i finally can upgrade firmware for my tarot but strange thing happen in the middle upgrade first on pc screen show time out when i click button ok sunddenly the gyro go crazy servo run itself and all 3 gryo light when on i did try to restart the gyro but no respon...
what when wrong ?

thank john and to all who willing help me
Does the red led still flash when you power it up holding the set button?

If so, John can probably help you to flash it again, using his new unreleased version.
Mar 15, 2012, 07:49 PM
Registered User
Quote:
Originally Posted by beenflying View Post
Excellent, John. I could have done with that last night.

Is cyclic compensation missing for some reason?
Yep, it was missing. It was in the code, but I hadn't added enough lines to the grid for it to turn up.
Well spotted!
Mar 15, 2012, 08:02 PM
Registered User
keris's Avatar
Quote:
Originally Posted by beenflying View Post
Does the red led still flash when you power it up holding the set button?

If so, John can probably help you to flash it again, using his new unreleased version.
thank beenflying for fast respond i will try to restart with hold set button and see how...will update later

thank beenflying

cheers
Mar 15, 2012, 08:05 PM
Registered User
Quote:
Originally Posted by keris View Post
thank beenflying for fast respond i will try to restart with hold set button and see how...will update later

thank beenflying

cheers
I will get this information to you later today.
Mar 15, 2012, 08:07 PM
Registered User
After moaning that my bluetooth adapters had not turned up, they arrived in the post this afternoon

Quite cute little devices. Hooked one up to my Android phone, works a treat.

Pity my iPad wants nothing to do with it. Thanks Steve Jobs
Oh, well it will have to be the Wifi module for the iPad connectivity then.
Mar 15, 2012, 11:01 PM
Mallcopterist
2Doggs's Avatar
Quote:
Originally Posted by John_NZ View Post
Added a parameter comparison dialog to the new version of FBL.
Probably should change the order of the parameters into a better order.
May also investigate highlighting lines that differ.
Looks good! Can you change the width of the columns by dragging them?

Would it be possible to add a dividing blank line to break up the parameters into,say, three logical groups? You might have basic setup items, such as installation direction, gyro sense, servo trim etc in one, cyclic and tail in the other two.
Mar 16, 2012, 01:56 AM
Registered User
keris's Avatar
Quote:
Originally Posted by beenflying View Post
Does the red led still flash when you power it up holding the set button?

If so, John can probably help you to flash it again, using his new unreleased version.
Beenflying i did like you told and yes red led still flashing...thank beenflying for the info you give
thank john for your concern in my issue
Mar 16, 2012, 04:51 AM
as much as I can
beenflying's Avatar
No problem, keris. The red flashing led is a promising sign that it can be restored, thanks to John's work. I'll let him contact you now re the flashing side of it.
Mar 16, 2012, 06:48 AM
Registered User
Hi guys,

Can anyone assist with a small setup issue?

I have tried with John's software and also the CopterX software and get the same problems.

Under the setup process, specifically the Monitor page, I am meant to use servo reversing on the TX to get the movement of the red and green bars on screen to match the stick direction movements.

When I use the TX servo reversing until I get this bit right, my swash moves the wrong way........up stick moves swash dowen, down stick moves swash up, despite getting the bars on screen to move in the correct direction.

Later on in the software setup, you have the opportunity to reverse the 3 swash channels via the software, but no matter what I try, I can't get the correct direction and movements, despite having everything right to start with via the Monitor screen instructions.

Hope you follow.

Can anyone assist with what I am doing wrong?

Cheers,

Steve
Mar 16, 2012, 07:01 AM
Texas NewB
Black_heart's Avatar
just set the swash travel to a negative number and all well be good
Mar 16, 2012, 07:16 AM
Mallcopterist
2Doggs's Avatar
Hi Steve, the important thing is that your controls move the right way - I wouldn't worry too much about whether left shows as left and so on. I use a negative collective range value in my setup to get the swash to rise with up colective.

You can also set everything up with a mixture of normal and reversed servos in your TX, or do all the servo reversing in the controller. I do the latter, which means I can fly two different helis from the same TX model memory, with all the differences stored in the controllers.

What you can do in the monitor screen is adjust your TX sub trim and ATV values so that the monitor shows zero at centre stick - there are usually a few percentage points of difference with most radios - and also full stick deflection gives you -100 or +100.
Mar 16, 2012, 08:00 AM
Registered User
Thanks guys,

I thought as long as the swash movements are ok, the monitor direction would be irrelevant, but thought I should check.

Cheers,

Steve


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Sold Darthdrk Drone CX Body for coax helis like the Blade CX etc. Twmaster Aircraft - Electric - Helis (FS/W) 0 Oct 08, 2011 07:31 PM
Multiplex mc V2 servo programming PC software Thomas B Radios 3 Jul 23, 2006 09:49 AM