PC Software for Setup/Programming the CX-3X1000, 3GYS, TG-1, ZYX etc. - Page 18 - RC Groups
Shop our Airplanes Products Drone Products Sales
Thread Tools
Feb 02, 2012, 07:49 PM
Registered User
Originally Posted by nieves50
Since you know how the protocol works, here's a quick question...

Is it possible to lengthen the wires without messing anything up? My USB works fine but the cable has just enough reach!
The easiest way is probably to simply use a USB extension cable and extend it that side. You can extend that up to 5m total.
On the TTL side, running a few metres shouldn't be an issue.
Sign up now
to remove ads between posts
Feb 03, 2012, 07:47 PM
Registered User
I have a Tarot ZYX and can't get the USB to connect through the software. The dongle seems to work. Red light on when connected to PC, when I click connect the USB Flashes blue several times when not connected to the Gyro.

When I connect to the Gyro and click connect nothing happens (Not Connected). I have tried Tarots Software and the software here http://fbl.net.nz/ with the same results.

I programmed it with my radio no problem and want to tweak it now.
I have flown it (450) without issue. I am just having a connection problem to the pc.

Any help would be much appreciated

Feb 03, 2012, 08:05 PM
Texas NewB
Black_heart's Avatar
Did you select the Rite com port for the dongle?
Is the Heli and radio powered up?
Feb 03, 2012, 08:29 PM
Registered User
Which Com ports can you use ? I have tried 1, 2, 7, 8, and 9

Yes the RX and Gyro are powered up and initialized.
Feb 03, 2012, 08:46 PM
Registered User
What is the name of the driver used ? Prolific USB - Serial Comm Port Driver was installed automatically. The instructions say to open the driver first restart your computer and run the program which I did.

Feb 03, 2012, 09:01 PM
Texas NewB
Black_heart's Avatar
to start using program
1. Plug in your dongle
2. Turn on TX and RX/Gyro
3. Start the program
4. Connect Dongle to the Gyro
5. Select what Com port your Dongle is on
6. Click on the Connect Button.
to find out what port your Prolific USB to Serial Comm Port is on go to Device manager.
you dont have to start anything for the dongle only plug it in.
Feb 03, 2012, 09:47 PM
Registered User

I tried that sequence but with the same results unfortunately.

I disconnected the dongle from the Gyro and now the red light is on constant like before but now the blue light flashes every second also if this means anything.When I plug back into the Gyro the blue light stops flashing but won't connect.
My bat is charged ZYX works fine, programmable with the radio no problem, Flies good but for some silly reason I can't get it to communicate with my PC yet. I am running Windows 7.

Stumped for now !
Feb 03, 2012, 10:53 PM
as much as I can
beenflying's Avatar
Hi kel1. Try this:
1/ Remove the USB link
2/ Run John's application
3/ Note the available COM's ports in the list
4/ Close the application
5/ Plug in the USB link
6/ Run John's application
7/ Select the new COM's port in the list
8/ Turn on the Tx and Rx
9/ Make sure the servos move with the Tx sticks
10/ Connect the data cable (make sure you can see the gold pins in the plug (facing up) at the USB link end)
11/ Press the connect button in John's application

Let us know how you get on?
Feb 04, 2012, 12:01 AM
Registered User
Hey BF,

I tried the steps you explained still with no luck. I uninstalled everything and re-installed, followed your steps everything loaded fine, turned on TX powered RX, initiated fine, all servos working fine, Gyro working fine, USB Link found Prolific USB - Serial Comm Port Driver and was installed automatically.< (Is this driver correct?) I went into device manager and checked to make sure it was working and saw it was on Com 7. When I launched the program I had Com 7 to choose from so I did but when I press the connect button, it is still not connecting. If I disconnect the serial link from the Gyro the USB Link the red light stays on and the blue light flashes every second until I reconnect then the blue light goes off again.

I went back in to see if I could program it manually and it works fine.
Its probably something silly
Still Confused
Last edited by kel1; Feb 04, 2012 at 02:45 PM.
Feb 04, 2012, 12:08 AM
Texas NewB
Black_heart's Avatar
dose the dongle stay red or dose it turn blue?
try rebinding the TX and RX
Feb 04, 2012, 02:36 AM
Registered User
Got it Working !!

When you plug the USB Link in it stays red. When I plug it in to my Gyro it wont connect but if I unplug the serial cable from the USB Link the red light stays on and the blue light flashes every second. I didn't know what that meant but I just happened to plug the serial end of the cable coming from the Gyro into the USB Link VERY SLOWLY and for some odd reason it connected without even telling it to so I don't know whats up with that but I was just lucky I tried plugging it in slowly. If I do it fast it wont connect. ? ? ?

So it seems to work fine for now as long as I plug it in slowly!


Thanks all for your help

Last edited by kel1; Feb 04, 2012 at 02:43 AM.
Feb 04, 2012, 03:24 AM
Registered User
I think I spoke to soon. It will connect and it loaded my file no problem. I saved it.
I went into setup and moving sticks did nothing.
Then I noticed that my servos aren't moving any more.
Powered down and tried again without USB and when it initializes you hear the servos move but when it is finished there is no servo movement with the sticks.
My File seems to load fine but I have no movement now.

Any Ideas ?


Feb 04, 2012, 01:34 PM
Registered User
I have a problem with the Tarot ZYX. I have hard coded tail servo 960us digital. After you turn on gyro does not work the tail to one side, starts to work after connection via USB to the software. And AVCS Mode works as in Normal Mode, return to the Center. Do you know where to get the Firmware?
Feb 04, 2012, 02:37 PM
Registered User
Originally Posted by Black_heart
dose the dongle stay red or dose it turn blue?
try rebinding the TX and RX
The dongle stays red when plugged into the computer. When I plug into the Gyro and push connect nothing happens. If I disconnect from the serial side of the dongle the red light stays on and the blue light flashes every second.
I reconnect the serial cable very slowly and it will connect. I was able to save my settings and then went into setup where you move your sticks and nothing happens. Now I cant load the ini file back to the gyro either. It has also changed all of my gyro settings. The sliders are all at the bottom and I have no servo movement anymore but they are locked up when I power the gyro up, just no movement. I hope this dosen't sound too confusing cause I am pretty confused right now.

Any help much appreciated !
Feb 04, 2012, 02:43 PM
Texas NewB
Black_heart's Avatar
Did You rebind the radio to the receaver?
do you have your throttle all the way down with 0 trim?
If you plug in your heli what color led is let on the Gyro?

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Sold Darthdrk Drone CX Body for coax helis like the Blade CX etc. Twmaster Aircraft - Electric - Helis (FS/W) 0 Oct 08, 2011 08:31 PM
Multiplex mc V2 servo programming PC software Thomas B Radios 3 Jul 23, 2006 10:49 AM