Thread Tools
Old Jan 04, 2012, 05:54 PM
_Hammer_ is offline
Find More Posts by _Hammer_
Registered User
Discussion

Dragon Boats, Shark Mono 1 ep won't work when battery is connected


All that happens is the motor beeps and stutter-bumps when there's a new batt in it, and nothing happens when you try servo or throttle, the radio works just fine, 3s lipo, any ideas? Thanks,
_Hammer_
Sign up now
to remove ads between posts
Old Jan 05, 2012, 03:51 AM
pompebled is offline
Find More Posts by pompebled
Boaters are nice people.
Hi Hammer,

I assume the boat is brandnew?
It's your first boat?

Did you program the ESC?

Does the ESC have BEC?

From what you're telling it sounds like there's no power for the receiver, so either the ESC doesn't provide power for the receiver and servo, or it has BEC which is defective.

Some pictures and a list of the components (with links to the manufacturers) would be nice.

Regards, Jan.
Old Jan 05, 2012, 05:53 AM
Scubaman is offline
Find More Posts by Scubaman
Registered User
Hammer,

I have the same boat and I don't have exactly the problem you have. I don't know which version you buy, they have 2 which is 50mAh or 70mAh ESC version. Other than this, it is identical.

However, you need to program your ESC for the first time when you put battery in. Please try to do the following to see if this works :

1. Hold your TH to 100% (full TH) and then connect the battery.

You should hear few beeps after few seconds. Then release the TH.

2. Disconnect your battery and put it back on.

Now you should have your motor running.

If not, I believe either the ESC is defect or it do not find out the 100%TH point.

What is the tramisstor you are using ?
Old Jan 05, 2012, 02:45 PM
richardknox is offline
Find More Posts by richardknox
Registered User
Hi Hammer

The Shark has a 4122kv motor it's 2s only so you can't use your 3s battery anyway
Last edited by richardknox; Jan 08, 2012 at 06:01 PM.
Old Jan 06, 2012, 05:13 PM
_Hammer_ is offline
Find More Posts by _Hammer_
Registered User
It is a 75A esc, the only problem I am having now is that the receiver won't light up, and the boat incessantly beeps no matter what, I have used 3 diff transmitter receiver combos that have worked in all my trucks, I am setting up with a flysky fs-gt3b 2.4ghz transmitter receiver combo, the esc maker isn't specified, but it is a model XB-75A-SW, and battery is gens ace 55c 2600mAh.
Thanks,
_Hammer_
Old Jan 06, 2012, 05:38 PM
_Hammer_ is offline
Find More Posts by _Hammer_
Registered User
Coorection, the receiver is now receiving power, but still not interacting with the boat.
Old Jan 06, 2012, 05:38 PM
pompebled is offline
Find More Posts by pompebled
Boaters are nice people.
Hi Hammer,

If the receiver doesn't get power, you'll never be able to do the initial set-up required.
Use a separate receiverpack to see if the receiver will turn on.

Not relevant to the set-up, but 2600mAh isn't a lot for this boat, I'm running 3300mAh and more in this size hulls.

Regards, Jan.
Old Jan 06, 2012, 11:06 PM
wparsons is offline
Find More Posts by wparsons
Registered User
wparsons's Avatar
Is the receiver bound correctly to the transmitter?
Old Jan 06, 2012, 11:42 PM
Scubaman is offline
Find More Posts by Scubaman
Registered User
RichardKnox : The first version of the boat is a 2S boat. The current version they are selling is a 3S one which the motor is a 2881KV motor.

Hammer : There maybe 2 reason for the ESC doesn't work. Just like Scropion said, if the ESC has no power, it won't work. If the receiver is not bind, it won't work. I believe you may need to make sure it is working by connecting the battery to receiver with a servo and see if it can turn. Also make sure the central position is correct. If the central position is not correct for channel for the ESC, it will not going to find out the TH and it doesn't work as well.

Hope this help.
Old Jan 07, 2012, 05:27 PM
_Hammer_ is offline
Find More Posts by _Hammer_
Registered User
Thank all of you for your help! I have been able to run this boat, and by god does it RUN! It was a problem with the binding, I rebound twice more, and the boat works great!
Regards,
_Hammer_
Old Jan 07, 2012, 05:32 PM
pompebled is offline
Find More Posts by pompebled
Boaters are nice people.
Good to hear you got everything working!

Please make some pictures and show them here!
A video would be nice too...

Regards, Jan.
Old Jan 10, 2012, 05:24 PM
richardknox is offline
Find More Posts by richardknox
Registered User
scubaman...thats odd mine arrived today and it's got a 4228kv...are you in the UK ?
Old Jan 11, 2012, 03:56 AM
Scubaman is offline
Find More Posts by Scubaman
Registered User
RichardKnox : I'm not in UK. I'm in HK. This is odd that they send a 4228KV motor this time. What I have done when I order with Dragon, I told them I want to run on 3S and I believe they replace the motor for me.

For the boat you've got, I believe you can only run in 2S. 3S will burn the motor !!!
Old Jan 11, 2012, 05:58 PM
richardknox is offline
Find More Posts by richardknox
Registered User
Hi scubaman...J perkins import them into the UK, and they must have spec'd it with 2s...I would preferred the 2881 motor, and I have got one from Horracing to fit..soon as it's running I'll post a video up

regards
Old Jan 11, 2012, 11:44 PM
Scubaman is offline
Find More Posts by Scubaman
Registered User
RichardKnox : Good to hear that you have a 2881 motor. At this moment, I have upgrade mine with a Lepoard 2860 3400KV running 36mm 2 blade prop. It is fast and could run about 6 minutes with 3S 4500mAh 20C battery.

Wish you luck. Hope to see your video soon.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! FMS Simulator Won't Work! DJO Simulators 7 Nov 21, 2011 05:40 PM
Help! AR8000 won't work without satellite justindh Radios 10 Nov 10, 2011 11:12 AM
Discussion When two plus two won't equal seven, darnit MtnGoat Life, The Universe, and Politics 1 Oct 05, 2011 07:11 PM
Discussion fuel won't move through the fuel line even when priming tallicadude Nitro and Glow Power Cars 2 May 30, 2011 09:37 PM
Help! non-zero RPM readings when the motor is not turning or when connected to battery hp88 Eagle Tree Systems 19 Mar 24, 2009 09:56 PM