blinking board lite on dh 9101 - RC Groups
Thread Tools
Dec 17, 2011, 02:51 PM
Registered User
Discussion

blinking board lite on dh 9101


Hi to all. I am new to rc flying although i have wanted to since i was a kid. I was given a Double Horse 9101 as a gift. Due to the weather and daylight i have been testing in the house. I took it outside yesterday and while i was able to get in the air and make turns, it did not want to go forward. After about 5 minutes it got a little too far away so i set it down. I tried to take off again and when I pushed the lever the blades would start to turn and then stop. I could see the board lite flashing so i figured the battery was dead. I charged it up and tried again today with the same results. I have checked the batteries in the controller and they test fine. Any ideas.
Last edited by npd136; Dec 17, 2011 at 06:03 PM.
Sign up now
to remove ads between posts
Dec 18, 2011, 11:33 AM
Registered User
I replaced the batteries in the controller with Enegizer Lithium thinking the batteries were bad but no change. I switch on the controller first, then the copter. The red board light flashes once and then stays solid red. I push the throttle lever forward and the blades start and then quit and the board light is flashing. As soon as I pull the throttle lever back the board light goes solid red again. Do I need an new battery in the copter or what? Thanks in advance.
Dec 18, 2011, 11:40 AM
Registered User
Center the trims before turning anything on.
Dec 18, 2011, 11:49 AM
Registered User
I centered all the trim dials with the same result.
Dec 18, 2011, 11:54 AM
To Soar Like An Eagle!
frieslander's Avatar
Have you set the throttle all the way down before turning on the Tx? The other stick must be centered.
Dec 18, 2011, 11:58 AM
Registered User
Yes, I centered the right stick and pulled the throttle stick to the lower stop.
Dec 18, 2011, 11:59 PM
Against Helicopter Cruelty
Heli Pad's Avatar
I know you said that you charged your helicopter, but everything you said sounds like a battery problem to me. If you have a voltmeter, it's best to check the battery of your helicopter. Perhaps it is a dud and it's not holding charge or the internal resistance has become too high. Your fully charged battery should read about 4.2v. Otherwise, you have a bad battery and a replacement is in order.

Edit: Should say 8.4v for a 2s Lipo. Thanks, DoubleTap.
Last edited by Heli Pad; Dec 19, 2011 at 01:17 AM.
Dec 19, 2011, 01:03 AM
Si Vis Pacem Para Bellum!
Doubletap's Avatar
Quote:
Originally Posted by Heli Pad
I know you said that you charged your helicopter, but everything you said sounds like a battery problem to me. If you have a voltmeter, it's best to check the battery of your helicopter. Perhaps it is a dud and it's not holding charge or the internal resistance has become too high. Your fully charged battery should read about 4.2v. Otherwise, you have a bad battery and a replacement is in order.
Actually, his battery should read 8.4V when fully charged, because Double Horse 9101 uses a 2S lipo, not a single cell like smaller toy helis.
Dec 19, 2011, 07:24 PM
Registered User
The reading with the meter set on 20 is 1320, which I would assume to be 13.2 v, which would explain why it is shutting down.
Dec 19, 2011, 09:02 PM
Registered User
Just ordered a new battery from Xenonproject.com. Best price and lowest shipping I could find. I hope this fixes it.
Dec 19, 2011, 11:32 PM
Si Vis Pacem Para Bellum!
Doubletap's Avatar

Safe disposal of damaged Lipo batteries


FYI, here is the safe way to dispose of old or damaged Lipo battery packs.


http://www.rccoh.com/rc.how-to/lipo.....disposal.html
Dec 20, 2011, 06:16 PM
Registered User
I have seen other helis with the same results. i also have seen the blinking board. I decided to get new motors for the SYMA S032G. I'm still waiting for them in the mail. one of the motors that i took out of it had an intermittent bind in it. i will let you know if its the motors.
Dec 20, 2011, 07:07 PM
Registered User
I finally sent an email to the manufacturer. Below is the reply.
Hi Sir.
I think the problem would be the screws that fix the inner shaft, you can try to tighten the screws first.
if it does not work again, so the problem would be the circuit boad, it can not receive the signals from the controller.
I hope this can help you.
Thanks


Best regards
Andrew
http://www.shuang-ma.com

I will post the results of the new battery install. If that does not fix it a new board will be ordered the same day.
Dec 20, 2011, 07:18 PM
Registered User
what a load of tripe! The loose screws on the inner or the outer shaft will not allow the heli to fly but it will not make the led light flash! true it could be the circuit board or the battery. i would like to hear more.
Dec 20, 2011, 07:38 PM
Registered User
The red light on the board will blink if the heli is turned on and not the transmitter. Could be either the trans or receiver but I dont know how to find out which one.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion MWC MultiWii Lite lightweight version 4-axis flight control board Erknie Multirotor Drone Talk 0 Dec 05, 2011 07:58 PM
Help! Double Horse 9101-cog not engaged on shaft and... 5ammy Coaxial Helicopters 1 Nov 30, 2011 11:07 PM
Discussion Man you guys are scaring me. Positive BH experience board. stevercunivers Banana Hobby 65 Feb 21, 2010 11:42 AM
Discussion A bomb? An IED? A blinking board? mmm hysteria Kurpal Life, The Universe, and Politics 48 Feb 11, 2007 09:12 PM
Question blinking PH10 w/ mixer/gyro board? aerohawk1 Castle Creations 1 Jan 12, 2005 01:29 PM