Thread Tools
This thread is privately moderated by Tim Marks, who may elect to delete unwanted replies.
May 06, 2016, 08:05 PM
Registered User
Thanks Gregor, seems to work fine now

Bob, no new updates I am aware of. Just hadn't updated in awhile and needed the HV pre-sets for some new lipos.
Sign up now
to remove ads between posts
May 07, 2016, 05:06 AM
Registered User
bob_nj's Avatar
Thanks buddy!
Aug 06, 2017, 11:10 AM
Registered User
Just tried to update the firmware on PL-8 on the Revolectric.com site and get 404 error.
Currently on 3.3 firmware and trying to go to 3.6.
Any Ideas???
Aug 06, 2017, 02:30 PM
President, FMA, Inc.
Tim Marks's Avatar
Thread OP
Quote:
Originally Posted by JIM CALDWELLA
Just tried to update the firmware on PL-8 on the Revolectric.com site and get 404 error.
Currently on 3.3 firmware and trying to go to 3.6.
Any Ideas???
Hi Jim:

That's odd. I just tested on Win 10 using Google Chrome browser and it worked fine for me. By the way, the latest firmware for the PL8 is v3.33; there is no v3.6.

Tim Marks
President
FMA, Inc.
Revolectrix Partner
Aug 07, 2017, 10:56 AM
Registered User
Thanks Tim!
Dec 15, 2018, 10:05 PM
Registered User

Multi4


Just tried to update my multi to vs1.67 (I went to vs1.70 but that was a bad idea).
Did a vs 1.67 which loaded but memory 6-10 and 22-25 are empty (no Ni-Zn to be found).
Trying to access the library on memory 6+ it shows as 'locked'. memory 22+ does access the library.
There is also no setting for li-ion at all, why?
This done on a Win7 generic computer with all current updates. Initial scan show CRC errors but non are found in the
error list. When clicking on version 1.67 it does install.
What am I doing wrong?
Zwever39
Dec 19, 2018, 08:54 AM
Sindland MC SAA
Howard Matos's Avatar
Quote:
Originally Posted by zwever39
Just tried to update my multi to vs1.67 (I went to vs1.70 but that was a bad idea).
Did a vs 1.67 which loaded but memory 6-10 and 22-25 are empty (no Ni-Zn to be found).
Trying to access the library on memory 6+ it shows as 'locked'. memory 22+ does access the library.
There is also no setting for li-ion at all, why?
This done on a Win7 generic computer with all current updates. Initial scan show CRC errors but non are found in the
error list. When clicking on version 1.67 it does install.
What am I doing wrong?
Zwever39
Good Day,

The firmware update has no effect on your presets. Try doing a factory restore on the charger using the CCS. It sounds like some of the presets were cleared and locked. Let me know how you make out. You can also reach me direct @ howard@revolectrix.com
Dec 19, 2018, 08:59 AM
Registered User
bob_nj's Avatar
Great customer service.
I have two PL8's, tow Multi 4's, and two 4S chargers and love them.
The node only feature is priceless!

Have a good Holiday Season!
Bob


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Question Futaba Software updates / Manuals grenflyer Radios 3 Nov 10, 2011 07:33 AM
Question Solder or use bullet connectors when making my ESC wires longer justy g Power Systems 4 Sep 29, 2011 08:02 PM
Discussion MY Favorite Horizon Will NO LONGER SHIP TO ME pulsery2k1 Vendor Talk 4 Sep 22, 2011 03:22 PM
Found DX 7, Dx6i, or Futaba7c. Reasonable no longer need skillyl Aircraft - General - Radio Equipment (FS/W) 4 Jul 24, 2011 01:46 PM
Discussion Log veiw no longer valid on my I-charger? Heliwrecker Batteries and Chargers 1 Apr 25, 2011 03:55 AM