New Products Flash Sale
Thread Tools
Old Dec 22, 2011, 03:56 PM
JUERGEN_ is offline
Find More Posts by JUERGEN_
xxxxxxxxxxxxx
JUERGEN_'s Avatar
Quote:
Originally Posted by scousethief View Post
...,
it will need soldering i know
are rarely needed,
all pins.

Sign up now
to remove ads between posts
Old Dec 22, 2011, 04:57 PM
Gazzas_86 is offline
Find More Posts by Gazzas_86
Registered User
Evening folks, As mentioned a few days ago, i've ordered a MWC MultiWii SE Standard Edition 4-axis FCB However as its a failr new board, and theres not many build threads (that ive seen) around, and as this is my first build, are there any wiring diagrams for said board, as when it all arrives im going to be like...ok what goes where......
Appologies for the noobish question,
Kind Regards
Old Dec 22, 2011, 05:01 PM
WiseDuck is offline
Find More Posts by WiseDuck
Mmmmmmm!
WiseDuck's Avatar
Just check out the guide posted earlier in the topic. It's really not difficult at all. You'll figure it out in no time I'm sure.
Old Dec 22, 2011, 05:15 PM
Gazzas_86 is offline
Find More Posts by Gazzas_86
Registered User
Quote:
Originally Posted by WiseDuck View Post
Just check out the guide posted earlier in the topic. It's really not difficult at all. You'll figure it out in no time I'm sure.
thankyou sir
Old Dec 22, 2011, 06:33 PM
Bmr4life is offline
Find More Posts by Bmr4life
30 RC's and counting
Bmr4life's Avatar
Quote:
Originally Posted by erazotropa View Post
Its nothing else then other boards. except sensors + uC are all on 1 board.

There is no magic pcb used or whatsoever
Thanks, just trying so see if this is direct competition for the DJI.
Old Dec 22, 2011, 06:56 PM
oddcopter is offline
Find More Posts by oddcopter
Quadcopter Addict
Quote:
Originally Posted by Gadget-Geek View Post
just got mine today too. I bought mine from rc-hobby-part on e-bay and it came in hex6 config, I wanted hex6-x config so I tried re-flashing it and got the same issue with the mag as oddcopter. Facing north, It reads west, I did notice in the sensors tab it says you have thirty seconds to move the board in all directions but that didn't do anything either. Also tried re-cal in GUI, Turning the board in circles... Nothing. Is there a way to pull the original firmware off this thing using avrdude and the 6 pin ISP? since it doesn't seem this can be done with arduino sketch. Also oddcopter, The debug1 is your alt from your baro, Look at the ALT on the left side of the GUI and debug1, They read the same and change together accordingly. Just changing the config from hex6 to hex6-x and setting the sensors in config.h shouldn't render this thing useless, There's gotta be something I'm missing.
Gadget,

I haven't been able to mess with it for a few days, but if you figure out the MAG calibration problem, please post. I agree it would be VERY helpful to know what if any changes were made to the code loaded on the boards initially. Someone said it was plain vanilla, but it seems strange that we both have the same MAG problem.
Old Dec 23, 2011, 12:05 AM
n3m1s1s is offline
Find More Posts by n3m1s1s
Suspended Account
Quote:
Originally Posted by oddcopter View Post
Gadget,

I haven't been able to mess with it for a few days, but if you figure out the MAG calibration problem, please post. I agree it would be VERY helpful to know what if any changes were made to the code loaded on the boards initially. Someone said it was plain vanilla, but it seems strange that we both have the same MAG problem.
computers have magnets in them yea? and generate magnetic interference? so if your close to a pc calibrating mag wonder what would happen?
Old Dec 23, 2011, 02:44 AM
WiseDuck is offline
Find More Posts by WiseDuck
Mmmmmmm!
WiseDuck's Avatar
My magnetic sensor was acting a bit weird too. The arrow moved from north to west to south smoothly but would then jump from south to northwest all of a sudden. I'm guessing it has something to do with my computer. I was sitting close to it and my speakers. The Mag calibration worked for me, and by worked I mean after I spun the board 360 on all three axis the LED flashed and the calibration stopped. But it still misbehaved a bit, I'm gonna test it again later away from the computer.

I honestly don't care that much about the Mag though, I don't know what I'd use it for. But I'll try to make it work later, I just received a new frame, motors and ESCs for a proper quad I intend to use a lot from now on.
Old Dec 23, 2011, 03:21 AM
erazotropa is offline
Find More Posts by erazotropa
MyFlyDream
erazotropa's Avatar
Quote:
Originally Posted by bignose13 View Post
Worked it out
Elevator down, throttle down and right, hold for 3 seconds and the LCD works
Maybe this should go in the Setup PDF
Simon
Quote:
Originally Posted by Atx_Heli View Post
it was.....see the stick guide at the end of the first section...
Then the picture in the manual is not correct, doesnt match with Bignose

Old Dec 23, 2011, 06:07 AM
erazotropa is offline
Find More Posts by erazotropa
MyFlyDream
erazotropa's Avatar
about the Compass IC, i think its position is not defined by us in de sketch..

When goodluck or volcano or forcehobby sends them out they are defined..

look at the following posts, regarding the MAG sensor defines in the sketch:

Read from this post:

https://www.rcgroups.com/forums/show...ostcount=23058

https://www.rcgroups.com/forums/show...ostcount=23067
Old Dec 23, 2011, 07:53 AM
Atx_Heli is online now
Find More Posts by Atx_Heli
Registered User
Quote:
Originally Posted by erazotropa View Post
Well i dont know how you guys do it..

1. I turn on my quad, its disarmed
2. I pull back elevator and togheter yaw right. while throttle is down too.
3. Blue led starts to blink, and stay blue (like armed)
4. Then nothing comes on my lcd...
......
"Down" elevator is pushing the stick FORWARD

look at the stick card in the guide for positions...hold for 3 seconds like for arming....

okay now?
Old Dec 23, 2011, 02:03 PM
erazotropa is offline
Find More Posts by erazotropa
MyFlyDream
erazotropa's Avatar
Quote:
Originally Posted by Atx_Heli View Post
"Down" elevator is pushing the stick FORWARD

look at the stick card in the guide for positions...hold for 3 seconds like for arming....

okay now?
Aha

Well maybe talk in stick terms then, it will be more understandable


But............ Still not working..

I will make a video next sunday..
Old Dec 23, 2011, 04:04 PM
WiseDuck is offline
Find More Posts by WiseDuck
Mmmmmmm!
WiseDuck's Avatar
Well, I've moved the Crius board to another frame. Should be able to test it real soon I hope.

Old Dec 23, 2011, 08:41 PM
RoboSerg is offline
Find More Posts by RoboSerg
Registered User
RoboSerg's Avatar
Quote:
Originally Posted by JUERGEN_ View Post
.
MultiWii,
now also in Europe.




- > http://www.drotek.fr/shop/en/22-flight-controller


Too expensive, goodluckbuy has free shipping worldwide. Thats where I bought the light version.
Old Dec 24, 2011, 12:20 AM
Gadget-Geek is offline
Find More Posts by Gadget-Geek
Build,Fly,Crash,Repeat
Well I think I fried mine!, I tried connecting it to my computer using a longer cable and it pushed one of the mini USB pins in on the FTDI board (I didn't notice) and now it wont recognise the board. I have two more on order, one quad-X and one hex-X, I will try to pull the .hex from the board using avrdude and the six pin ISP header. This is my first arduino board so I don't know what I should save the file as, binary?, hex?, Or what?. The way I figure is it's an Atmel chip so it should be able to be programmed with the ISP header or else why would it be there?. I don't know if arduino sketch will recognise a hex file though. I can rule out the computer being a calibration issue though. before trying the other cable, I tried calibrating it in different positions around my computer with the shorter cable and if the computer was the issue then I should have got mixed results but no matter where I calibrated it relative to my computer, North reads west. Besides, If electronics or processors are going to throw off the calibration then I guess I'll have to remove the ATMEGA328P from the board before calibrating it!!!.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product Full Foxtech AIO Glasses Review Guizmo12 FPV Equipment 1362 Dec 13, 2014 08:08 PM
Sold Arduino / MultiWii / Megapirates Boards 3rdeyepro Aircraft - Electric - Multirotor (FS/W) 3 Dec 03, 2011 09:43 PM
Wanted MSR 5in1 boards and MCPX 3in boards beachflyer Aircraft - Electric - Helis (FS/W) 3 Nov 22, 2011 10:14 PM
Discussion Foxtech AIO goggles RX? Teamsherman FPV Talk 2 Oct 02, 2011 11:06 AM
Sold 3 x PCB boards for multiwii copter for $28 madushan2008 Aircraft - Electric - Multirotor (FS/W) 1 Sep 06, 2011 07:53 AM