Thread Tools
Sep 20, 2012, 03:46 PM
Flying mostly micro's
BlueHavoc's Avatar
Loving my new Yellow juchion v911, it flies fantastic! it is very noisy however compared to my other WL v911's but I just don't care! It flies beautifully!
Sign up now
to remove ads between posts
Sep 20, 2012, 04:20 PM
Jake From Planet Mascoutah, IL
Jake8131's Avatar
Flying my yellow whatever it is, v911, in my living room.

http://youtu.be/TAZTmPTv3NM?hd=1
Sep 20, 2012, 04:33 PM
Registered User
Where I can buy the original landing skid for the yellow v911?
Sep 20, 2012, 06:32 PM
Sir Crashalot
stonecutter's Avatar
Quote:
Originally Posted by BlueHavoc
Loving my new Yellow juchion v911, it flies fantastic! it is very noisy however compared to my other WL v911's but I just don't care! It flies beautifully!
It is extraordinarily quiet with the canopy off. You'll be surprised. I fly that way in the office (to be discrete).
Sep 20, 2012, 07:11 PM
Registered User
GLHS592's Avatar
Well, my yellow V911 was spinning clockwise (looking from above), so I assume my tail motor is going out. Now, if I give it anything above 1/4 throttle, both motors just quit. I hope it just the tail motor. Will a regular WL Toys V911 tailmotor work on the yellow one?

At least I was able to get my blue/white V911 going. It sure is noticeable how much less stable it is.
Sep 20, 2012, 07:20 PM
Flying mostly micro's
BlueHavoc's Avatar
Quote:
Originally Posted by stonecutter
It is extraordinarily quiet with the canopy off. You'll be surprised. I fly that way in the office (to be discrete).
Nice tip!
Sep 20, 2012, 07:25 PM
Safety : practice & promote!
RoboHeli's Avatar
Quote:
Originally Posted by stonecutter
It is extraordinarily quiet with the canopy off. You'll be surprised. I fly that way in the office (to be discrete).
So if that's the case then is the canopy rattling against the posts or are the vibrations carrying into the canopy? Maybe mounting the canopy on some rubber grommets like the Blade MSRX canopy or something could help cut down the noise?
Sep 20, 2012, 07:32 PM
Flying mostly micro's
BlueHavoc's Avatar
my noise seems to be a noisy motor, don't know...
Sep 20, 2012, 07:37 PM
Team WarpSquad
Daryoon's Avatar
The Solo Pro has rubber grommet, yet I find it's noisy as well. Could never really track down the source.
Sep 20, 2012, 07:54 PM
Yo R Wee Too Lo

next step for wl toys


since wl toys is dragging their feet over putting out a 120 size 6 channel cp. or a micro 6 channel cp , I feel we should all gather outside the wl headquarters and stage a peacful demonstration demanding a new heli before winter.

I can see the sign out side the building saying billions and billions sold just like McDonalds.
let's do it.
Sep 20, 2012, 07:59 PM
Yo R Wee Too Lo
Quote:
Originally Posted by JCMorgan
Crashed my v911 into pavement from 30 up and no damage.
thats quite normal , tell that to roboheli you'll need a new driveway before a neww 911 or parts for that matter. I have a scad of skids blades motors tail sets and they are collecting dust. and I fly 3 v911s
Sep 20, 2012, 08:02 PM
Yo R Wee Too Lo

thanks for the info


thanks to you guys for helping me get my 9x and v911 working.
I AM HAPPIER THEN A PIG IN MUD, OR A V911 SHREDDING THE LEAVES OFF OF A NEIGHBORHOOD TREE.

I love this heli.
Sep 20, 2012, 08:41 PM
Registered User
Yeah!! I got the little bugger trimmed! I took the servos off as suggested but found that they would be slight up or slightly down no matter what, but I reset everything and started over with a fresh mind (and batteries ). I went a little over just to make sure I was seeing it correctly and then one half step back. Perfection. I even managed a very rudimentary nose in funnel! Now back to the basics... And to ordering spare batteries.
Sep 20, 2012, 09:14 PM
Registered User
Quote:
Originally Posted by GLHS592
Well, my yellow V911 was spinning clockwise (looking from above), so I assume my tail motor is going out. Now, if I give it anything above 1/4 throttle, both motors just quit. I hope it just the tail motor. Will a regular WL Toys V911 tailmotor work on the yellow one?

At least I was able to get my blue/white V911 going. It sure is noticeable how much less stable it is.
Clockwise would be too much tail rotor.

It's probably the main that's gone bad.

Hold it in your hand and spin it up.
Rotate it left/right. The tail should speed up/slow down.
If not, might be the gyro.

If you give it 1/4 throttle and everything dies, one of the motors (I bet main) is probably getting warm as it kills things.
Check the temperature.
Sep 20, 2012, 09:50 PM
Registered User
GLHS592's Avatar
Quote:
Originally Posted by RicksterRC
Clockwise would be too much tail rotor.

It's probably the main that's gone bad.

Hold it in your hand and spin it up.
Rotate it left/right. The tail should speed up/slow down.
If not, might be the gyro.

If you give it 1/4 throttle and everything dies, one of the motors (I bet main) is probably getting warm as it kills things.
Check the temperature.
Hmm. I guess this yellow one is a dud. It was smoking the last time I put a battery in it. It was some transistor or something on the back side of the board from the red battery wire. I really liked it at first. I haven't had it a week. I wish I'd have bought another WL V911 BNF instead.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product Jiuchon 9C002, a Solo Pro clone? SoloProFan Micro Helis 103 Feb 29, 2012 02:24 PM
Discussion Interesting Solo Pro? Clone gordonzo Micro Helis 46 Nov 30, 2011 03:15 AM
Question Which 100 sized heli after Solo Pro? Tuc Micro Helis 16 Jun 13, 2011 01:52 PM
Sold $100 !NEW ARF Storm 250 (Trex Clone) With Align Upgrades, Tons of Extras! $100!! RChelisrule Aircraft - Electric - Helis (FS/W) 1 May 31, 2011 12:26 AM