Servos doesn´t work when they get cold? Then start working at room temp again. - RC Groups
Thread Tools
Nov 17, 2011, 09:39 AM
Registered User
Discussion

Servos doesn´t work when they get cold? Then start working at room temp again.


I was going out and flying, but one servo didnt work when I tried to start up the plane. I walked for 5 min from my home to the field, and in that time, they have gotten to cold and dont work. When I take the plane inside again, they start working again.. I have a hacker 55 esc.. Anybody had the same problems?
Sign up now
to remove ads between posts
Nov 17, 2011, 09:43 AM
Registered User
ashdec87's Avatar
how cold? The grease inside might be gumming up
Nov 17, 2011, 10:35 AM
Registered User
Its 0-3 C here in Norway now.. I just did a test, had the plane inside for 1 hour, then all servos worked. Took it out for 15 min, then the servos didnt work. They have got warmed up again now, and work again. Maybe they dont "start" in cold? I will try to "start" them inside, take the plane out for 15 min, and see if they stop working..
Nov 17, 2011, 10:48 AM
Registered User
interesting... what kind of servos are these?
Nov 17, 2011, 10:53 AM
Registered User
ashdec87's Avatar
I wonder if there's a loose solder joint that's breaking the connection when it gets cold..
Nov 17, 2011, 12:51 PM
Registered User
I bought them from Klique. Standard servos. Can It be the esc BEC that doesnt work in the "cold"? Hmm, strange.. I havent lost servo control in the air. It seems to be just when I start up in the cold. They dont "activate"..
Nov 17, 2011, 01:08 PM
Future-proof EVERYTHING
DarkHeli's Avatar
I wouldnt get back in the air with that problem! fix it first before you have to fix it all.
Nov 17, 2011, 03:49 PM
Registered User
I dont quite understand what to fix, haha. It can be the ESC or the servos..
Nov 18, 2011, 08:58 AM
Registered User
Quote:
Originally Posted by Voguna
I dont quite understand what to fix, haha. It can be the ESC or the servos..
...or simply the battery
Nov 18, 2011, 09:04 AM
Registered User
Try to remove the grease of the gears. it can become solid at low temperatures. However this will dramatically reduce the live of your servos.
Nov 18, 2011, 09:10 AM
Registered User
pda4you's Avatar
I have flown in 20 below zero with no servo issues.

Mike
Nov 18, 2011, 11:00 AM
Registered User
ashdec87's Avatar
me too, which is why I'm thinking solder. Try swapping out components to see what's giving you issues.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Servo doesn't work when plugged into elevator channel komodomoe 3D Electric Heli Flying 0 Sep 22, 2011 05:00 PM
Discussion IL-2 Sturmovik...joystick didn't work, then worked, then stopped working. T.D. Simulators 1 Jun 11, 2011 11:50 AM
Discussion High stiffness epoxies for wet layup at room temp. smed Composites Fabrication 4 Apr 30, 2011 10:10 PM
Blue bird servo doesn't work in cold temp rocstar Foamies (Kits) 0 Nov 30, 2004 11:55 PM