FPV Crash - caused by Eagletree/guardian lockout? - Page 3 - RC Groups
Shop our Airplanes Products Drone Products Sales
Thread Tools
Oct 09, 2012, 03:26 PM
Registered User
Thanks billpa, I really appreciate your help with this. This is a case were the FDR and CVR (V standing for video) are not available..

I am pretty sure it did go into RTH when I turned off the TX on the bench tests, but I will have to confirm when I get back home because I have not tried that after the incident. Also I was thinking that I have seen a delay from the time RTH is activated and then the msg comes up on the screen… may be we just did not see the msg because the glitch was too fast.

I am kinda concluding that the GPS might be a prime suspect for not keeping altitude. But why do you think I was unable to turn the RTH off?

Another thing I really don’t feel comfortable with is the firmware update messages I get when I plug in the hardware (eLogger, GPS, Guardian, eagle eyes). Roughly 1 out of 5 times when I connect the USB it tells me that I need to update firmware (when I already have). Like I commented before, the buttons are always available to update in the software. Aren’t they supposed to go away once you have updated? I think I read that somewhere.
Sign up now
to remove ads between posts
Oct 10, 2012, 01:18 AM
Registered User
Billpa, I just tested activating RTH by turning off the transmitter; It worked perfectly. Worked fine with the switch as well. Now it did take 3 seconds for RTH to come active once I turned the Tx off. This delay could explain why I did not see the RTH message on screen with the glitches.
Oct 11, 2012, 02:52 PM
billpa's Avatar
Hi, glad to help.

Re the USB firmware update message, I think I know what is going on there. If the OSD is started without the Rx sending pulses (they typically don't start until the Tx is turned on) the OSD will take longer to initialize, and that could sometimes cause the software to put up that message incorrectly.

Our beta software 10.43 on the support page of our website should remedy this (but it's benign).

The buttons on the firmware control page will not go away if the device is connected. But, they will list the same firmware version as the text above the button, letting you know you don't need to update.
May 11, 2013, 12:29 PM
Registered User

Not sure i want to fly ths as it is !!

I have just bought two Gaurdan units, one for my Angel s 30 and the other for a foamy in the park.
I have reset them to factory settings and updated to latest firmware via usb / PC.
I have removed the floppy plastic case from one as it gave various readings when moved with a very small pressure so it is now secure and via the PC I can see it is stable re flight line.
The LED shows the 2D and 3D mode and goes off when the three pos switch is centered. I have a gain slider on the left hand side of my Futaba 12FG whic I use for the overall gain. Here is the problem:
When I turn the gain off and the switch is centered the left aileron moves full throw BUT the right aileron (into AUX ch) moves about 25 % of the way and is much slower ! I have treid another servo in this channel and it does the same.
I have swopped the two Gaurdian units and it does the same. If I flew it like this it would simply roll into oblivion.
If I turn up the overall gain the response gets better but not flyable. I have double checked all ATV 's are 100 % and there is no expo (as I understand from my experience with GY 153 Futaba gyro that expo should not be used with gyros).
This gyro works beautifully but costs lots in the process as it is used on a H/Hunter turbine).
So what is going on with this set up as I am not flying it like this ?
Any help welcome.


May 13, 2013, 10:21 PM
billpa's Avatar
Hi David,

Sorry to hear about your issue. You should definitely not fly it if the servos are not moving correctly. I am not sure what could be causing it, but my first suspicion is that it's a mixing or throw related issue. Could you please open a ticket with us at http://ticket.eagletreesystems.com and we'll work with you to resolve it.

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Eagletree Guardian gain problem Oscar J FPV Talk 2 Nov 01, 2011 11:37 AM
Help! T-28 RX cut out caused crash pow-wow Micro Ready-to-Fly 19 Oct 19, 2011 11:32 AM
Sold Complete EagleTree OSD Pro and guardian. bakchos FPV Equipment (FS/W) 9 Oct 05, 2011 12:40 AM
Sold EagleTree Guardian Dan777 FPV Equipment (FS/W) 2 Sep 19, 2011 10:05 AM
Discussion Fy-20a vs eagletree guardian? g3f0rc3 FPV Talk 6 Sep 05, 2011 09:09 PM