Shop our Airplanes Products Drone Products Sales
Thread Tools
Old Jan 25, 2013, 06:38 PM
Tim Marks is offline
Find More Posts by Tim Marks
President, FMA, Inc.
Tim Marks's Avatar
Quote:
Originally Posted by JimHSoars View Post
Tim:

Does the above happen with the PowerLab 8 as well?

I am working on doing the charging again. I'll provide graphs and other information when I post them.


As far as the power supply is concerned:
  • Input current limit = 9 amps. PS is rated at 10 amps.
  • Supply low voltage = 10 volts. PS is rated at 12 volts.
- Jim
Hi:

As far as Auto modes go, PL6 and PL8 will likely behave identically.

Your PSU is pretty skimpy for powering a PowerLab product, but as long as you have the input current limit and input low voltage set the way you say, it shouldn't present operational issues; other than you won't be able to charge at high currents; probably above 8A or so. I see from the graphs you poste you are running the CCS application. You should double-check the Options in the Options tab and make sure the feature "Choose Power Source at Startup" is checked. If it's not, check the box and Update the PL. Then always choose Power Supply when prompted on the LCD when you power up the PL.

Tim Marks
Sign up now
to remove ads between posts
Old Jan 25, 2013, 09:12 PM
JimHSoars is offline
Find More Posts by JimHSoars
Registered User
Quote:
Originally Posted by Tim Marks View Post
Hi:

Your PSU is pretty skimpy for powering a PowerLab product, but as long as you have the input current limit and input low voltage set the way you say, it shouldn't present operational issues;

Tim Marks
Yup, it's a little one, but good quality. It's a Samlex Regulated PS. I bought it from Peak Electronics a couple of years ago. I thought it was a 40 amp model, oh well.

I am looking into a 24+ volt, 40+ amp PS.

- Jim
Old Jan 25, 2013, 09:42 PM
Gregor99 is offline
Find More Posts by Gregor99
Revolectrix Ambassador
If you aren't going with server supplies, try to get a supply that can be adjusted up to 27v-28v. That way if start charging 6s packs, you'll be at or near the chargers maximum output.
Last edited by Gregor99; Jan 25, 2013 at 10:00 PM.
Old Jan 25, 2013, 09:47 PM
JimHSoars is offline
Find More Posts by JimHSoars
Registered User
I dream of a 32v +0-1 volt, 45 amp power supply.
Old Mar 12, 2013, 01:43 PM
Remote_Pilot is offline
Find More Posts by Remote_Pilot
Champagne Supernova
Remote_Pilot's Avatar
What exactly does the monitor function do ?

Is there just a balance mode I can set so the PL6 will just balance the cells ?
Old Mar 12, 2013, 02:17 PM
Gregor99 is offline
Find More Posts by Gregor99
Revolectrix Ambassador
Monitor reports the individual cell voltages. Useful if you want check the voltages on your packs. There is no "balance only" mode. I do not see the value in such a mode. Not sure where this would be more useful than the existing modes.

If you have pack that is way out of balance, you can always set the charge rate to 1 amp, which is bypass current maximum. Current to all cells except the low cell would be effectively bypassed.
Old Mar 15, 2013, 04:15 PM
Remote_Pilot is offline
Find More Posts by Remote_Pilot
Champagne Supernova
Remote_Pilot's Avatar
Quote:
Originally Posted by Gregor99 View Post
Monitor reports the individual cell voltages. Useful if you want check the voltages on your packs. There is no "balance only" mode. I do not see the value in such a mode. Not sure where this would be more useful than the existing modes.

If you have pack that is way out of balance, you can always set the charge rate to 1 amp, which is bypass current maximum. Current to all cells except the low cell would be effectively bypassed.
Thanks the 1 amp setting worked well balanced the cells right up. For some reason I am just recently having issues with unbalanced lipos. Haven't pinned down exactly whats causing it yet.
Old Mar 15, 2013, 04:29 PM
Gregor99 is offline
Find More Posts by Gregor99
Revolectrix Ambassador
As the packs age, or if the packs are not well matched, they can drain at different rates. If the imbalance issue happens after the flight, that is no too unusual. Especially if the cells are deeply discharged. If the imbalance happens after the charge cycle is complete and the pack has sat for a while, that could be a sign that IR in one or more cells has crept up. IR values can give some clues.

You can also monitor the discharge with the CCS. This will more clearly show which cells are sagging under load. For larger packs, using a Pb in regen discharge mode with a load on the Pb battery allows higher discharge rates. I used an old Dean's light bar from my car days. It has 10 automotive bulbs which helps bleed off current and keep the Pb battery from getting full.
Old Mar 17, 2013, 12:55 PM
Dennis C is offline
Find More Posts by Dennis C
Registered User
Dennis C's Avatar
Just started useing the PL6, When I start a new charge I push enter and it goes directly to Lipo confirm, the prompt for number of packs in paralell does not come up

How do I set it so that on each charge it will ask for number of packs?

Dennis
Old Mar 17, 2013, 03:42 PM
Gregor99 is offline
Find More Posts by Gregor99
Revolectrix Ambassador
Dennis, are you pressing and holding start? If so that triggers "quick start" which does not give the option to change packs in parallel. I set the packs in parallel in the preset which lets you use quick start.
Old Mar 17, 2013, 08:29 PM
Dennis C is offline
Find More Posts by Dennis C
Registered User
Dennis C's Avatar
Thanks, I probably am

I knew I could set the Paralell in the pre set, I am trying to charge "flight packs" one plane uses 2x4s 4000 and the other is 1x4s4000 And at the start of the day it is charge all 4 at once.

I will try and pres and let go

Dennis
Old Mar 17, 2013, 10:43 PM
Gregor99 is offline
Find More Posts by Gregor99
Revolectrix Ambassador
That's what I do. I have four packs for one model that takes two packs per flight (12s). I have the preset set for 2P which is what I use during the day (one flight pack at a time). For the first charge at the field I charge all four at once. I use the regular startup for the first charge and set the values manually. Then use quick start from there on out.

Of course I could also make a second 4P preset, which is not a bad idea. Its not like I'm short on space for the presets
Old Mar 23, 2013, 02:10 PM
Dennis C is offline
Find More Posts by Dennis C
Registered User
Dennis C's Avatar
Problem

I just pluged in the PL6 to my lap top with the supplied usb cable, it shows I have no data from charger, and now none of the USB ports work on my lap top. Also the LED on the link does not come on.

battery pluged into charger and USB pluged into computer

I think I am going to have to call my computer tech, but what could be the problem with the FMA link

Dennis
Old Mar 23, 2013, 02:28 PM
Remote_Pilot is offline
Find More Posts by Remote_Pilot
Champagne Supernova
Remote_Pilot's Avatar
Quote:
Originally Posted by Dennis C View Post
Problem

I just pluged in the PL6 to my lap top with the supplied usb cable, it shows I have no data from charger, and now none of the USB ports work on my lap top. Also the LED on the link does not come on.

battery pluged into charger and USB pluged into computer

I think I am going to have to call my computer tech, but what could be the problem with the FMA link

Dennis
Do you have another USB device (thumb drive) to try ?

Reboot the PC would be step one.

Check the pins on the back of the PL6 where the cable plugs in. They sit a little high next to the case and eventually I couldnt get mine plugged in. It seemed like it was but it was missing a pin or 2. I had to push them back to center of the opening.
Old Mar 23, 2013, 02:51 PM
Gregor99 is offline
Find More Posts by Gregor99
Revolectrix Ambassador
If you haven't done so already, be sure to install the appropriate driver.
http://www.revolectrix.com/new_appli...re/pc.usb.html


Then you can use the FUIM test tool to verify that PC is communicating with the FUIM.
http://www.revolectrix.com/applicati...ster/setup.exe

If all USB port stop working sometimes a power off and power on of the laptop may clear the issue.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product Sneak Peek at the NEW Cellpro PowerLab 8 (v2) Tim Marks FMA Direct 6544 Yesterday 01:03 PM
New Product Introducing the ALL NEW Cellpro 10XP Charger Howard Matos FMA Direct 448 Oct 26, 2016 04:58 PM
New Product Introducing the Scirocco--All Molded, All Carbon Pitcheron Ward Hagaman Slope 180 Oct 04, 2014 10:43 AM
Sold Revolectrix/FMA direct Cellpro PowerLab 8 unused new thwang99 Aircraft - Electric - Batteries & Chargers (FS/W) 2 Aug 26, 2010 04:24 PM
Wanted Cellpro 4S 4amp Charger-New Version ( Found One--Thanks! ) helinut4ever Aircraft - Electric - Batteries & Chargers (FS/W) 1 Jan 27, 2009 05:24 PM