Thread Tools
Old Aug 02, 2012, 12:24 PM
w4Rd3n is offline
Find More Posts by w4Rd3n
Registered User
w4Rd3n's Avatar
i also have some kind of jitter if i fly it too fast.
this jitter is becoming a lot more on windy days.
this is just a small clip from today. at 3 secs and at the end you can see the jitter.

http://youtu.be/9eY2X58WIWg
Sign up now
to remove ads between posts
Old Aug 02, 2012, 05:23 PM
Gundy is offline
Find More Posts by Gundy
Blu-Core is my friend
Gundy's Avatar
This is just silly.
http://www.columbian.com/news/2012/j...s-stalls-over/

Later,
Gundy
Old Aug 02, 2012, 06:32 PM
klique is offline
Find More Posts by klique
Mum is the word!
Yep Riddle use ZII's for all kinds of stuff
Old Aug 02, 2012, 06:35 PM
klique is offline
Find More Posts by klique
Mum is the word!
Looks like a little turbulance not flutter.
Quote:
Originally Posted by w4Rd3n View Post
i also have some kind of jitter if i fly it too fast.
this jitter is becoming a lot more on windy days.
this is just a small clip from today. at 3 secs and at the end you can see the jitter.

http://youtu.be/9eY2X58WIWg
Old Aug 03, 2012, 07:57 AM
mmbbb is offline
Find More Posts by mmbbb
Registered User
OK. Built my first ever Zephyr II which also happens to be the first ever flying wing for me.

I've started with the pizza box launch from the beginning and it took off on the first try.
It was the nicest plane I've ever tried in a windy day. Right before the launch, I've also tried to fly my skywalker 1900mm. The plane was staying in place upwind with 3/4 throttle. It was too scary, I landed in 5 minutes. Then came the Zephyr and it flew REALLY nice in that wind. Did few rolls and that sort easily which I was never comfortable before. Never reached the full throttle.
Landed smoothly... except the prop was still sticking out instead of aligning with the body like in the videos (I've already turned on the motor brake before launch).
Then on the second launch right after that, It went straight to the ground On the third as well. Still no visible damage but can't figure out the reason.

Could it be the motor mount bent a little bit on the first landing and causing this? I always launched close to or at full throttle.


My setup:
2x 2200mah 5s batteries in the bay - planning to reclaim this area for autopilot and put the batteries in the wing.
3548 700kv HK SK motor I have motor from CK but I didn't have small enough prop or appropriate size 4S battery at the time.
10x7 Master Airscrew prop.
37A at WOT
but seems to be able to cruise nicely at well below 10A.

I have second frame still in the box... I think I'll take its build lot more serious next time :P
Last edited by mmbbb; Aug 03, 2012 at 11:08 PM. Reason: Corrected motor kV number
Old Aug 03, 2012, 07:28 PM
brosius85 is offline
Find More Posts by brosius85
never mind the boll⁣⁣⁣ocks
brosius85's Avatar
is it still trimmed properly? servos all working throughout their range?

video would be nice, seems very strange to go from flying well to not being flyable instantly
Old Aug 04, 2012, 02:38 AM
brosius85 is offline
Find More Posts by brosius85
never mind the boll⁣⁣⁣ocks
brosius85's Avatar
soooooooon
Old Aug 04, 2012, 06:28 AM
mmbbb is offline
Find More Posts by mmbbb
Registered User
Hi Brosius,

Yes it is trimmed right as far as I know. I'll compare the motor mount with the one in the box... I'm also waiting for a better pushrod clevis from HK...

Your Z looks good. Where do you get those stickers?
Old Aug 04, 2012, 07:36 AM
brosius85 is offline
Find More Posts by brosius85
never mind the boll⁣⁣⁣ocks
brosius85's Avatar
ebay
Old Aug 04, 2012, 09:20 AM
Kloner is offline
Find More Posts by Kloner
Aerial DP
my second go is ready, gonna toss it up monday and see what shes got. Sure learned alot about messing with gorilla glue. That's some good stuff





http://rchelicollective.com/zen/kloner/zIIvII/
Old Aug 04, 2012, 09:50 AM
mmbbb is offline
Find More Posts by mmbbb
Registered User
Brosius,

Where did you get that long yet not thin pushrod? I couldn't find any good on HK...
Old Aug 04, 2012, 10:33 AM
Chevycruizer is offline
Find More Posts by Chevycruizer
Registered User
You do some nice work. I checked out your other pictures you posted. Do you have any build threads posted? especially interested in you antenna builds.

John

Quote:
Originally Posted by Kloner View Post
my second go is ready, gonna toss it up monday and see what shes got. Sure learned alot about messing with gorilla glue. That's some good stuff
Old Aug 04, 2012, 12:19 PM
Kloner is offline
Find More Posts by Kloner
Aerial DP
not really, i just build alot of stuff from the do it yourself CP threads from IBcrazy here. Crosshair, helicals, cloverleafs, spw

Thanks
Old Aug 04, 2012, 12:37 PM
Eagle202 is offline
Find More Posts by Eagle202
Registered User
Eagle202's Avatar
Quote:
Originally Posted by brosius85 View Post
soooooooon
Wow what a face on your ZII? Is that thing hungry or what?
Old Aug 04, 2012, 12:53 PM
Bauf is offline
Find More Posts by Bauf
Registered User
quick question, when i punch to full throttle the z2 "locks" on,so the steering doesnt work.. its only on full throttle. Why is that? My setup is scorpion s2 3020 1110kv motor with a 65A ritewing esc. Using a 10A CC bec and rvosd5.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Build Log Building the ultimate Ritewing Zephyr ThomasWF FPV Talk 34 Feb 20, 2012 06:14 PM
Discussion wing thickness ritewing zephyr Herishi The Builders Workshop 2 Oct 05, 2011 09:36 AM
Discussion Ritewing Zephyr hobbycity motor nexstarselect FPV Talk 2 Mar 07, 2011 05:37 PM