Possible dead Mcpx - RC Groups
Thread Tools
Oct 20, 2011, 05:17 PM
Electronics slayer
SouthPawPaul's Avatar

Possible dead Mcpx

Need some help here.

I've been flying my mcpx now for the past 4/5 weeks and flown a good number of battery packs.

I flew a few packs this morning and then a few hours later after my batteries had charged I plugged it in to find a non responsive mcpx.

The swash tilts in all directions properly and also the blades change pitch when I move the throttle, however the motor does not spin up. The blades spin freely and the main gear also spins freely.

When the battery is first plugged in, the blue LED flashes twice then pauses the repeats, and then after moving the throttle it flashes 3 times then pauses then repeats.

I'm using a Futaba 9c with a Spektrum module and all my switches are in the neutral position and I've also tried rebinding twice with no change. No settings have changed on the radio and I'm definitely on the right model.

Anyone any idea what is going on please?
Sign up now
to remove ads between posts
Oct 20, 2011, 05:24 PM
Screwed Again My Friend
jombo's Avatar
3 things . you could have throttle hold on , or the motor is bad or wires to the motor are disconnected.
Oct 20, 2011, 06:12 PM
Registered User
Race Miata's Avatar
Originally Posted by SouthPawPaul
I'm using a Futaba 9c with a Spektrum module and all my switches are in the neutral position
Assuming you mean throttle at all-the-way down position, did you mistakenly leave switch in idle-up mode? Three flashes sounds like bound successfully but throttle hold or throttle not zero.
Oct 21, 2011, 03:42 AM
Electronics slayer
SouthPawPaul's Avatar
Yes, my throttle is in the all the way down position and also the throttle hold is in the non active position. I can confirm this as the Futaba radio led flashes and the LCD screen shows "Mix" when it's active.

Do HH not publish the flashing error codes anywhere that anyone is aware of ?

Anyone know of a UK tech support line I can call?
Oct 21, 2011, 03:43 AM
Electronics slayer
SouthPawPaul's Avatar
All of the connectors and cables appear to be intact.

Is there an easy way to test if the motor has died?

I'm desperately not hoping that the 3in1 board isn't dead. I wonder if that's a warranty replaceable part?
Oct 21, 2011, 04:43 AM
Electronics slayer
SouthPawPaul's Avatar
OK. I've sorted it. In the spirit of keeping problems with solutions, here's what I did.

I called Horizon UK and spoke to a very knowledgeable person on their repairs dept. He told me that the blinking lights that I was describing is indicating that the board is in "Throttle Hold" mode. Now as I've previously stated my radio wasn't in throttle hold. This was confirmed by using the servo monitor function on the radio.

He next suggested that maybe one of the motors may be binding and causing the 3in1 to force a throttle hold situation. I should disconnect both motors to see if the problem went away. It didn't.

I was all ready to pack the heli up and send it in for a warranty job, when I thought to just do a rebind of the Tx whilst the motors were disconnected (rebinds had previously been unsuccessful in clearing the fault). This time however I got a solid blue light on the 3in1. I disconnected the battery and reconnected the motors one at a time (to try and isolate a motor issue) and the blue light stayed solid. One battery pack down and all is well.

It's still a mystery to me why this cleared the fault. Maybe the controller got it's panties up in a bunch and it needed this process to clear down the fault.

I hope that this can help someone else in the future.
Oct 21, 2011, 02:18 PM
Registered User
Very odd for sure. Glad you fixed it!

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion MCPX Servo Completely Dead... spessx Micro Helis 4 Jul 29, 2011 08:47 PM
Discussion brushless mcpx possible? burro breath Micro Helis 11 Apr 07, 2011 02:48 PM
Discussion Possible dead servo on Wattage Deacthalon EP RTF barraman Electric Plane Talk 5 Aug 12, 2008 01:12 AM
Discussion #6 Channel Dead on 4 in 1? Is this possible? aftalife Micro Helis 8 Jun 30, 2006 03:09 PM
Discussion Possible Dead Cells? PTheDevil Batteries and Chargers 4 May 23, 2006 03:51 AM