New "Ultra Durable" 120 CP Heli from Walkera - V120D02S - Page 598 - RC Groups
Thread Tools
Feb 17, 2013, 09:34 AM
Brent 黑雁
BThirsk's Avatar
Quote:
Originally Posted by samho2088
Is the New V120D02S good for CP beginners?
I felt just like a beginner after 5 months of almost no flying last summer due to a back injury. By the time I was able to fly, winter was here in Canada. I got several miniCPs, a Walkera MiniCP and the SuperCP.
All I can tell you is, flying these fast little guys indoors will promote some serious control. Once you can handle them in tight quarters, flying the V120 outdoors is like a walk in the park. I would recommend a mini and the V120 both to learn on and get a good radio like the Devo 8 , 10 , or 12. I have the 7, 8s, and the 12s. The 8s and 12s are great. I don't like the 7.
Sign up now
to remove ads between posts
Feb 17, 2013, 09:59 AM
Registered Fiend
microrcfiend's Avatar
Quote:
Originally Posted by samho2088
Is the New V120D02S good for CP beginners?
If it's your first cp, it's not advised. Very fragile. Lots of bad design issues and it will never do many things like fly backwards fast or flip with a neutral tendencies, advanced stuff like piroflips is never going to happen like a proper heli.

If you have mastered the basics and want more power then maybe, if you want a frist cp I would say get something that won't collapse on you and something that can actually betaken apart to work on like the mini cp or super cp, they bounce real good too
Feb 17, 2013, 10:49 AM
Registered User
sbstnp's Avatar
Quote:
Originally Posted by Rafa's CB100
Hey Y'all,

I wanted to give an update on this 2S situation.
Nice. Can't wait to put mine together, I have everything just need to solder connectors and assemble on the heli. My ESC is a Plush 12A I had laying around, I went ahead and flashed it with BLHeli so I'll have a governor too. I went for a 10t pinion, hope it will be ok. The ESC is kinda heavy at 12g, but I didn't wanted to spend anymore so I went ahead and used it.

What pinion do you use? What's the flight times? (I'll use Hyperions 320mah)
Feb 17, 2013, 11:07 AM
Registered User
Quote:
Originally Posted by sbstnp
Nice. Can't wait to put mine together, I have everything just need to solder connectors and assemble on the heli. My ESC is a Plush 12A I had laying around, I went ahead and flashed it with BLHeli so I'll have a governor too. I went for a 10t pinion, hope it will be ok. The ESC is kinda heavy at 12g, but I didn't wanted to spend anymore so I went ahead and used it.

What pinion do you use? What's the flight times? (I'll use Hyperions 320mah)
Maybe I'll comment on this too since i have the same setup except for the CC10a esc. I am using the 10t pinion. It gives significantly higher head speed than stock. I have used a 9t also which gives more stock like head speeds. I use the governor.

I had problems with tail wag when running the higher head speed at first. I tried lowering the gain but that just made the tail blow out. I ended up cutting down the tail blades by like 2mm and that fixed the problem. I was able to run normal gain again.

I get 4 min on the hyp 320. 5 on my homemade zippy 400s
Last edited by flint723; Feb 17, 2013 at 11:21 AM.
Feb 17, 2013, 11:19 AM
Live to learn. . .
Rafa's CB100's Avatar
Quote:
Originally Posted by sbstnp
What pinion do you use? What's the flight times? (I'll use Hyperions 320mah)
Quote:
Originally Posted by flint723
Maybe I'll comment on this too since i have the same setup except for the CC10a esc. I am using the 10t pinion. It gives significantly higher head speed than stock. I have used a 9t also which gives more stock like head speeds. I use the governor.

I had problems with the tail wag when running the higher head speed at first. I tried lowering the gain but that just made the tail blow out. I ended up cutting down the tail blades by like 2mm and that fixed the problem. I was able to run normal gain again.

I get 4 min on the hyp 320. 5 on my homemade zippy 400s
Seems like people like the BLHeli code, I bet it'll be nice. I'm also using a 10T pinion. At the 4600 rpm head speed, the Castle Link says that it's running at ~90%, so yeah, it could be capable of higher head speeds. I haven't had to mess with tail blades yet, but let's see how it goes with more flights. I've got my timer set to 4:00, and my packs are at ~3.75V after a few minutes. Neither the battery, esc, or motor are especially hot.

Rafa
Feb 17, 2013, 11:24 AM
Registered User
Quote:
Originally Posted by Rafa's CB100
Seems like people like the BLHeli code, I bet it'll be nice. I'm also using a 10T pinion. At the 4600 rpm head speed, the Castle Link says that it's running at ~90%, so yeah, it could be capable of higher head speeds. I haven't had to mess with tail blades yet, but let's see how it goes with more flights. I've got my timer set to 4:00, and my packs are at ~3.75V after a few minutes. Neither the battery, esc, or motor are especially hot.

Rafa
Which rx do you have in that? I have the old rx2622 2801 version, which could be the problem with my tail. Since no one else I've talked to who did the 2s conversion seems to have that problem.
Feb 17, 2013, 11:47 AM
Live to learn. . .
Rafa's CB100's Avatar
Quote:
Originally Posted by flint723
Which rx do you have in that? I have the old rx2622 2801 version, which could be the problem with my tail. Since no one else I've talked to who did the 2s conversion seems to have that problem.
Mine is the 6 axis RX2636H-D.
Feb 17, 2013, 12:22 PM
Registered User
sbstnp's Avatar
Quote:
Originally Posted by flint723
Maybe I'll comment on this too since i have the same setup except for the CC10a esc. I am using the 10t pinion. It gives significantly higher head speed than stock. I have used a 9t also which gives more stock like head speeds. I use the governor.

I had problems with tail wag when running the higher head speed at first. I tried lowering the gain but that just made the tail blow out. I ended up cutting down the tail blades by like 2mm and that fixed the problem. I was able to run normal gain again.

I get 4 min on the hyp 320. 5 on my homemade zippy 400s
Well from you I found out that Hyperions 320mah fit the battery tray. And about the Zippys, which are out of stock atm.

I use the Solo Pro 180 tail blades which are smaller, I'll let you know how they behave. They fit without any modification and are colored white so highly visible, I am pretty happy with them so far.

I have the 6 axis as well.
Feb 17, 2013, 12:52 PM
Registered User
I've been having a weird vib I couldn't get rid of on the main shaft. So today I went over it again and wasn't finding anything wrong. On a whim threw the main blades (130x bullets) on the scale. And of course, they were .03g different. Put one piece of tape on at the blades cg and it's smooth as glass now.
Feb 17, 2013, 03:13 PM
Seeking Control
lasakro's Avatar
Quote:
Originally Posted by flint723
I've been having a weird vib I couldn't get rid of on the main shaft. So today I went over it again and wasn't finding anything wrong. On a whim threw the main blades (130x bullets) on the scale. And of course, they were .03g different. Put one piece of tape on at the blades cg and it's smooth as glass now.
There has been some sketchy blade discussions in the past. Just to make sure I have it correct because I seek stability. Would you guys agree?:

130X Bullet: Most Stable
V120 Stock: Less Stable
130X KBDD: Least Stable
Feb 17, 2013, 04:09 PM
Registered User
sbstnp's Avatar
Quote:
Originally Posted by lasakro
There has been some sketchy blade discussions in the past. Just to make sure I have it correct because I seek stability. Would you guys agree?:

130X Bullet: Most Stable
V120 Stock: Less Stable
130X KBDD: Least Stable
I'm using Solo Pro 180 blades. More responsive than stock, but I don't see any less stability.
Feb 17, 2013, 06:48 PM
Registered User
Quote:
Originally Posted by lasakro
There has been some sketchy blade discussions in the past. Just to make sure I have it correct because I seek stability. Would you guys agree?:

130X Bullet: Most Stable
V120 Stock: Less Stable
130X KBDD: Least Stable
Not exactly.

v120 stock: most stable
xtreme high performance: stable, but no better than stock response
130x kbdd: still very stable but more responsive, also bogs more than the others
130x bullet: less stable and much more responsive (best IMO)
130x non bullet: too unstable to use in fff or wind. Super responsive, to the point of being out of control.
Feb 17, 2013, 06:56 PM
Registered User
some help please!! .....had a bump with my V200D03 broke one side of landing gear and not sure what else, cause the rudder motor keeps running even when thro.is at 0% disconnected battery and plug back again still doing it, won't stop, would appreciate any suggestions, is there a reset switch for HM-V200D03-Z-26 Receiver or did the servo went bad? am a beginner but have some mechanical abilities...
thank you
Feb 17, 2013, 07:56 PM
Registered Fiend
microrcfiend's Avatar
Quote:
Originally Posted by purrungas
some help please!! .....had a bump with my V200D03 broke one side of landing gear and not sure what else, cause the rudder motor keeps running even when thro.is at 0% disconnected battery and plug back again still doing it, won't stop, would appreciate any suggestions, is there a reset switch for HM-V200D03-Z-26 Receiver or did the servo went bad? am a beginner but have some mechanical abilities...
thank you
You could try here?
https://www.rcgroups.com/forums/show....php?t=1492540

I double checked everything possible today and took the v120 for a tentative maiden and finally got a couple batteries through it with no issues. It feels delightfully powerful after so much 100 size brushed motor heli but the tail seemed to just push left slightly on it's own when turning right. Same happens in a pitch pump but much more subtle.

Tried the tx giro at 75 right up to 95 but the tail slippage seemed to be there. I took apart the tail to check the gears and there's no wear and everything was tight. Is this simply the rudder rod is not the right length as it seems to be pretty neutral tail spooling up with the giro turned down.

Should the gears have anything on them like lithium grease or be totally clean?
Slowly getting there.
Feb 17, 2013, 08:05 PM
Seeking Control
lasakro's Avatar
Quote:
Originally Posted by purrungas
some help please!! .....had a bump with my V200D03 broke one side of landing gear and not sure what else, cause the rudder motor keeps running even when thro.is at 0% disconnected battery and plug back again still doing it, won't stop, would appreciate any suggestions, is there a reset switch for HM-V200D03-Z-26 Receiver or did the servo went bad? am a beginner but have some mechanical abilities...
thank you
Since that is a TT drive tail I'm guessing that you mean that the tail servo motor keeps running and probably without moving the rudder. If that's the case you have stripped servo gears. Without feedback to the pot the motor never stops.

Guys: Thanks for the main blade info.
Last edited by lasakro; Feb 17, 2013 at 08:17 PM.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion new heli from walkera HIKO400? xyzy2 Micro Helis 15 Jan 12, 2012 12:16 PM
Sold Align 70A ESC W/BEC from 500/550 class Heli NEW! HD Hucker Aircraft - Electric - Helis (FS/W) 3 Oct 13, 2011 01:37 PM
Discussion Ultra Durable Diamond Mini Gyro 3 Channel Indoor Ready to Fly RC Remote Control Heli LittleG Coaxial Helicopters 32 Jan 14, 2011 01:55 PM
Discussion Walker 4#3 throttle problem Ė new heli Ronon Micro Helis 2 Jan 24, 2009 05:22 PM