Shop our Airplanes Products Drone Products Sales
Thread Tools
Old Jun 19, 2012, 06:18 PM
Daemon is online now
Find More Posts by Daemon
Registered User
Daemon's Avatar
I ditched Adobe Acrobat some years ago. Use FoxIt reader now, and haven't found a pdf it won't handle normally.

ian
Sign up now
to remove ads between posts
Old Jun 20, 2012, 07:07 PM
sdueck is offline
Find More Posts by sdueck
I Wish I Was Flying...
sdueck's Avatar
Got the Rangelink today. Everything looks great, and I am excited to get it set up in my planes/quad.

One more question for you folks. Is the RSSI output digital or analog? I ask because I want to do this mod to my SSOSD in order to display RSSI.

Thanks,
Scott
Old Jun 20, 2012, 09:10 PM
sid.huang is offline
Find More Posts by sid.huang
Chinglish-funny
Quote:
Originally Posted by sdueck View Post
Got the Rangelink today. Everything looks great, and I am excited to get it set up in my planes/quad.

One more question for you folks. Is the RSSI output digital or analog? I ask because I want to do this mod to my SSOSD in order to display RSSI.

Thanks,
Scott
Analog out. 0-3.3v; (check the rangelink manual)

Sid
Old Jun 20, 2012, 09:20 PM
sdueck is offline
Find More Posts by sdueck
I Wish I Was Flying...
sdueck's Avatar
Quote:
Originally Posted by sid.huang View Post
Analog out. 0-3.3v; (check the rangelink manual)

Sid
K, thanks. I saw that it is 0-3.3V. I just wanted to make sure it wasn't digital. I don't understand how a voltage could be digital, but someone in the thread I linked to mentioned that his RSSI output was digital.

And thanks for the fast shipping!

Scott
Old Jun 25, 2012, 01:48 AM
Teamsherman is offline
Find More Posts by Teamsherman
Member #1
Teamsherman's Avatar
Hi folks,

I've just recieved my usbttl cable but am unsure where to connect the wires to upgrade a rx I gave here. This is the USB I have and cable.


Any info would be great!
Old Jun 25, 2012, 02:53 AM
spotterone is offline
Find More Posts by spotterone
Can you DS it??
spotterone's Avatar
I've just had an issue with my Rangelink (old chainlink) receiver. I plugged it in the same way I've done a number of times before, and the servos were working fine, but then it got really hot in one spot and stopped working. The heat seemed to be coming from the bottom board, in the bottom corner below the antenna.

Anyone know what could have gone wrong? I'm certain I didn't plug the battery in backwards, because the servos were working.
Old Jun 25, 2012, 04:25 AM
Teamsherman is offline
Find More Posts by Teamsherman
Member #1
Teamsherman's Avatar
Quote:
Originally Posted by Teamsherman View Post
Hi folks,

I've just recieved my usbttl cable but am unsure where to connect the wires to upgrade a rx I gave here. This is the USB I have and cable.


Any info would be great!
With this upgrade, using the latest firmware do I need to do the transmitter swell or can I just do the receivers?
Old Jun 25, 2012, 05:07 AM
Teamsherman is offline
Find More Posts by Teamsherman
Member #1
Teamsherman's Avatar
Ok, so i got it working. The instructions for connection in the readme.txt file for my rangelink supplied USB are wrong, only due to me trying the cables in a different configuration did it work. I have now found the actual connection set for my usbttl a few pages back here.

Now that i have done the Tx and rx's, can someone explain the new rssi feature to me?

I am using OSD Pro and before this upgrade my rssi was working fine, so im assuming it will still work fine with the same setup as before?
Last edited by Teamsherman; Jun 25, 2012 at 05:49 AM.
Old Jun 25, 2012, 09:31 AM
Bill Sanford is offline
Find More Posts by Bill Sanford
Destructive testing expert!
Bill Sanford's Avatar
Quote:
Originally Posted by GhostRider32 View Post
Guys, everything works great except now my Skylark trace 3 shows erratic voltages and current readings. It was actually showing 30v at one point on a 4 cell battery. Do I have to recal the current sensor now? I didn't change anything on the OSD itself, just the receiver and transmitter.......
Skylark had a bad current sensor design. Look at their web site and see what the currently shipping current sensor looks like. If yours is different, then throw it away because it is crap and will perform as you are describing.

Their new version current sensor works just fine.

I originally ordered their HK re-branded Tiny OSD which is STILL shipping with the bad current sensor. Skylark wouldn't replace it because they said I needed to work with HK. As well all know, HK has no customer service, so I just tossed it and ordered a new sensor from Skylark and it worked great.

If you ordered from Skylark, they will replace it.

Bill

Bill
Old Jun 25, 2012, 06:48 PM
sid.huang is offline
Find More Posts by sid.huang
Chinglish-funny
Quote:
Originally Posted by Teamsherman View Post
Ok, so i got it working. The instructions for connection in the readme.txt file for my rangelink supplied USB are wrong, only due to me trying the cables in a different configuration did it work. I have now found the actual connection set for my usbttl a few pages back here.

Now that i have done the Tx and rx's, can someone explain the new rssi feature to me?

I am using OSD Pro and before this upgrade my rssi was working fine, so im assuming it will still work fine with the same setup as before?
V1.4 manual:
https://www.rcgroups.com/forums/member.php?u=352541
Old Jun 25, 2012, 06:51 PM
sid.huang is offline
Find More Posts by sid.huang
Chinglish-funny
Quote:
Originally Posted by spotterone View Post
I've just had an issue with my Rangelink (old chainlink) receiver. I plugged it in the same way I've done a number of times before, and the servos were working fine, but then it got really hot in one spot and stopped working. The heat seemed to be coming from the bottom board, in the bottom corner below the antenna.

Anyone know what could have gone wrong? I'm certain I didn't plug the battery in backwards, because the servos were working.

fault rx.send it back for repair.

Sid
Old Jun 25, 2012, 07:16 PM
bartekz9 is offline
Find More Posts by bartekz9
Registered User
Hello,

I have weird problem with interferences of rangelink... one day i have interferences, and another day no.
In micromode i can go easy to 40m and maybe more(i didnt tested more than 40m).

eagle tree elogger charts:

light blue - altitude
dark blue - distance
brown - RSSI


friday, saturday - big decrease of rssi even above base, and failsafes at 1km, 2km...








Sunday:

I thought that interferences was caused by bec, so i moved it and moved RL receiver as far as its possible from bec, and i thought it helped - all time 97-100% rssi even at 2km.





But.... today i didn't touched anything in plane, it was exactly the same as on sunday and i had again the same interferences as on friday, saturday.




So i'm sure that interferences are not from my plane, but what can cause interferences like that, and what can i do to avoid them?
Last edited by bartekz9; Jun 25, 2012 at 09:06 PM.
Old Jun 25, 2012, 08:04 PM
bingo17 is offline
Find More Posts by bingo17
Registered User
bingo17's Avatar
Same thing happened to mine, The rx popped and I had to send it back to Sid for repair.

After I got the repaired rx back it still got warm so I swapped the two digital servo's I had in this plane (funjet), for analogue servo's.
Working fine now...

I never had any problem with this setup and my Hitec optima rx so I guess the rangelink rx don't like that specific servo type.



Quote:
Originally Posted by spotterone View Post
I've just had an issue with my Rangelink (old chainlink) receiver. I plugged it in the same way I've done a number of times before, and the servos were working fine, but then it got really hot in one spot and stopped working. The heat seemed to be coming from the bottom board, in the bottom corner below the antenna.

Anyone know what could have gone wrong? I'm certain I didn't plug the battery in backwards, because the servos were working.
Old Jun 27, 2012, 08:08 AM
Teamsherman is offline
Find More Posts by Teamsherman
Member #1
Teamsherman's Avatar
Quote:
Originally Posted by sid.huang View Post
I couldn't see anything in the manual that explains what the new functions do, can someone tell me the benefits of each option?
Old Jun 27, 2012, 03:38 PM
swa2153 is offline
Find More Posts by swa2153
Registered User

Where to place an order


I ordered a Rangelink system from the Rangepilot.com website. Is this correct?


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Yippee! NEW DRAGON LINK ADVANCED: Full Telemetry, Bluetooth, Droid Planner, Data Modem JettPilot FPV Equipment 54756 Today 08:23 PM
New Product ChainLink UHF Long Range System siim227 FPV Talk 2853 Jul 01, 2013 05:23 PM
New Product ChainLink--The new UHF narrow band long range system BEVRC FPV Talk 878 Jun 08, 2013 07:53 PM
New Product UHF Long range JR / Futaba module Hooks FPV Talk 18 Aug 13, 2012 06:46 AM
Sold [VDS]LRS thomas scherrer UHF + 2 receivers long range LTS49 FPV Equipment (FS/W) 8 Jul 22, 2011 04:55 PM