New Products Flash Sale
Thread Tools
Old Nov 13, 2011, 11:10 PM
whosthebaddest is offline
Find More Posts by whosthebaddest
Registered User
the only thing I can think of is maybe somehow I got the throttle connected to the Rssi outputs and broke it. But I'm pretty darn sure I didn't do this especially on both RX's.

Also when I power up the RX with little servos from hobbyking connected they servos will jump for a split second when I power up the RX then no power to the servo

when i do this with my hitec 81 servos they don't even jump but the other servos do jump. no response from hitec 81 servos and they do work with other receiver
Sign up now
to remove ads between posts
Old Nov 13, 2011, 11:33 PM
Tracks is offline
Find More Posts by Tracks
Team Basement-RC
Tracks's Avatar
Quote:
Originally Posted by whosthebaddest View Post
yes I'm getting the green light. Turn the DL TX off unplug the RX.

Then I hold down the (black) botton while I am powering up the DL TX

I get a green light flashing. Then I power up the receiver. I wait like 20 seconds. Then I unplug the power to the DL TX. and plug it back it. I get solid green light. nothing from the RX no bind

also I'm using a Mono 3.5 plug for the trainer. I thought it should be mono. do you need stereo plug?

and I only have ppm and ground going to the plug. Do i need to run the power to the plug I put in the trainer port with a stereo plug???

I can't figure it out!! other people have it working this way with the dx6i I've been through everything!!

so stuck
You only need the mono plug. After you go through the binding steps, power everything off. Then power it all up.
Old Nov 13, 2011, 11:35 PM
whosthebaddest is offline
Find More Posts by whosthebaddest
Registered User
Ok I think I've done this I will try again
Old Nov 14, 2011, 12:00 AM
man2000me is offline
Find More Posts by man2000me
Mums the word.
man2000me's Avatar
Mike, can you please help out. I'm not sure if I was disrespectful towards you in anyway but I'm sorry. I see you respond to others post but skip over mine. I'm just looking for an update on the DLrx that you were going to send. I sent the paypal money but not heard or received anything. Thanks.
Old Nov 14, 2011, 12:06 AM
whosthebaddest is offline
Find More Posts by whosthebaddest
Registered User
I've tried everything. It seems like everything is working but I can't bind either receiver!!! DARN!!!


I have no Idea what to do now.
Old Nov 14, 2011, 01:48 AM
airwolf32 is offline
Find More Posts by airwolf32
Registered User
airwolf32's Avatar
Quick question on the DragonLink (hopefully not a dumb one):

These guys getting 25km out with this radio setup, what are they using for the video transmission that gets that far? A second dragon link?

After reading about this DL system, I started wondering if this would start out-distancing the ability of current video transmission setups, even if you're IBCrazy and know what you're doing.
Old Nov 14, 2011, 03:20 AM
ScooterInVegas is offline
Find More Posts by ScooterInVegas
Village Idiot!
ScooterInVegas's Avatar
Quote:
Originally Posted by airwolf32 View Post
After reading about this DL system, I started wondering if this would start out-distancing the ability of current video transmission setups
Thats sorta the point.
Old Nov 14, 2011, 05:33 AM
lrrps is offline
Find More Posts by lrrps
Registered User
lrrps's Avatar
I have a question.

Does the DL work with the Range Video OSD 5 ?

Thanks.
Old Nov 14, 2011, 05:37 AM
HF_ATL is online now
Find More Posts by HF_ATL
Registered User
yes, completely

Quote:
Originally Posted by lrrps View Post
I have a question.

Does the DL work with the Range Video OSD 5 ?

Thanks.
Old Nov 14, 2011, 07:21 AM
JohnB36 is offline
Find More Posts by JohnB36
Leesburg FL

Mounting to Futaba 9CAP Super


I use my transmitter on multiple bands (50Mhz, 2.4Ghz, 72/75 Mhz) depending on what I'm fooling with, and wanted to keep the plug-in ease of changing bands.

I used a spare RF module block, gutted it, and wired in the DL TX. I used 3M Auto Trim tape (which works great to attach receivers, gyros, whatever in planes as well) and a dab of household GOOP to bond the DL TX to the module.

The Futaba/DL needs the 10k resistor between the PPM and +V line to recognize the PPM stream correctly. I also put a 10k between Gnd and the LED pin to turn on the "RF" LED. This is more of a "the module is plugged in" than an RF indicator, but it ties all the loose ends together.

When I got the DL system, it came with two 10k resistors, rather than a 10k and a 1k shown in the wiring diagram for the Futaba/DL connections. 10k is fine for both connections.

I did take the liberty of putting info on my DL TX housing, as folks are asking "NOW what have you attached to your TX?!" .

I'm currently using the DL in a 78" flying wing, and have ordered a few more receivers for my Senior Telemaster, Jerrys Big Boy, and a modified FPV168.

Very nice system!

I did have to bend the handle on the Futaba a bit in a vise to clear the DL antenna.

I just got the system, so I'll contribute what I can to the forum once I get up to speed and finish reading all the posts!

Thanks Mike, for a great product!

John
N1KUB
Old Nov 14, 2011, 07:43 AM
JettPilot is online now
Find More Posts by JettPilot
JettPilot's Avatar
Quote:
Originally Posted by jmaurin View Post
Link to register is current disabled. There's no need to register for anything on the new site at the moment....this is for future features.
Yes,

We will provide a link to register all your credit card numbers

Mike
Site Sponsor
Old Nov 14, 2011, 07:48 AM
JettPilot is online now
Find More Posts by JettPilot
JettPilot's Avatar
Quote:
Originally Posted by jmaurin View Post
For all: i'm just helping Mike with somethings about the new site, and everyone can help.
If you like to help us, you can do it by translating any page like instructions. The new site is "multi-lingual", so all pages can be on varios languages to help even more users.

Currently i'm translating all pages to Brazilian Portuguese. If you translate any page, just send me the text by PM or e-mail, with your name [credits].
I'm sure Mike wouln't be mad with more languages for the DL site
Actually,

Jmaurin made the new site, he is a very talented guy ! Not only does he do Websites, he also knows a LOT about electronics and programming. When he started giving me suggestions about the next version Dragon Link, he suprised me by understanding the problems and solutions. His suggestions of what to do were almost exactly what we are doing.

I have high expectations for the website, this is just the beginning, it will get much better from here.

Mike
Site Sponsor
Old Nov 14, 2011, 07:51 AM
JettPilot is online now
Find More Posts by JettPilot
JettPilot's Avatar
Quote:
Originally Posted by man2000me View Post
Mike, can you please help out. I'm not sure if I was disrespectful towards you in anyway but I'm sorry. I see you respond to others post but skip over mine. I'm just looking for an update on the DLrx that you were going to send. I sent the paypal money but not heard or received anything. Thanks.
Hi,

I did not mean to skip over your posts. I have been in another production run and just crazy busy keeping up with everything. Its all good, but I do not get enough time to answer everyone all the time.

I will send your RX right away !

Mike
Site Sponsor
Old Nov 14, 2011, 07:54 AM
JettPilot is online now
Find More Posts by JettPilot
JettPilot's Avatar
Quote:
Originally Posted by whosthebaddest View Post
I've tried everything. It seems like everything is working but I can't bind either receiver!!! DARN!!!


I have no Idea what to do now.
I suspect 2 things. Either something strange with the PPM, or a calibration issue of the Transmitter.

Since you seem to have done everything perfectly, I will send you another TX and RX'es to try. If another system does not work, then we can start to look at your RC transmitter hookup. It is possible to fool the LED into going green sometimes even if the PPM is not good ( Like feeding it with PCM ). If they do work, then just send back the old ones after the new ones are tested and working.

I will need your full name and address.

Mike
Site Sponsor
Old Nov 14, 2011, 08:24 AM
Matt Gunn is online now
Find More Posts by Matt Gunn
RCGroups Editor
Matt Gunn's Avatar
Mike, your PM box is full and I'm unable to send you the info you requested for my replacement receiver. Sent you an email from your website a few days ago also but no reply.
Please advise.
thanks,
Matt
Administrator


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product Long Range UHF RC system now avail on STOCK thomasscherrer FPV Equipment 14252 Dec 03, 2016 07:32 PM
Wanted Scherrer UHF long Range or Dragon Link patrick21x FPV Equipment (FS/W) 6 Dec 24, 2015 04:50 AM
Yippee! Win a FREE Dragon Link UHF Long range RC system - BEST VIDEO contest for AUGUST !!! JettPilot FPV Talk 60 Aug 21, 2014 04:40 PM
New Product ChainLink UHF Long Range System siim227 FPV Talk 2853 Jul 01, 2013 05:23 PM
Yippee! Win a FREE Dragon Link UHF RC System - Video Contest JettPilot FPV Talk 63 Aug 02, 2011 11:52 PM