Thread Tools
Sep 28, 2012, 04:44 AM
Registered User
I just got my Flash D in the mail Wednesday and the Crack Yak I ordered for my son should be here tomorrow. Hope to fly one on Sunday... can't wait!

I am debating on if I should install the landing gear. I always fly in a grass field, not always maintained well. I Have seen gear get ripped off other planes causing damage. Lots of people just belly land in the grass.

Anyone have any thoughts or experiences with these planes and landing gear on grass?
Sign up now
to remove ads between posts
Sep 28, 2012, 05:26 AM
Registered Addict
Kris...'s Avatar
Quote:
Originally Posted by missileman
I just got my Flash D in the mail Wednesday and the Crack Yak I ordered for my son should be here tomorrow. Hope to fly one on Sunday... can't wait!

I am debating on if I should install the landing gear. I always fly in a grass field, not always maintained well. I Have seen gear get ripped off other planes causing damage. Lots of people just belly land in the grass.

Anyone have any thoughts or experiences with these planes and landing gear on grass?
Yeah i have landed in grass long and short with know problems with the landing gear, I would not worry your good to go missileman.
Sep 28, 2012, 06:11 AM
Registered User
docbrew's Avatar
No landing gear here. I float it in and plop it on the ground or hand catch. Heck mine get doinked into the ground way more than floating in As long as you are landing on grass I wound't worry about landing gear.
Sep 28, 2012, 08:19 AM
Team Twisted!
cdee's Avatar
Quote:
Originally Posted by JForbes
Would you say it's worth a motor upgrade for those flying on 2s, or maybe better suited just for the 3s users?
Both the 24g and 26g motors are very nice, the 26g will give you a little more power, but also drains the battery a little quicker, so it's a bit of a trade off. If you are happy with your current setup probably no reason to upgrade, but certainly consider the 26g on your next build.
.
cdee
.
Sep 29, 2012, 11:12 PM
Registered User
3flyguy3's Avatar

Motor or ESC?


I "borrowed" my orange rx from my Edgd over to another plane to text its esc. Turns out the esc was fine. I put the rx back on the Edge and I have all surface movement and LEDs but no motor. The esc doesn't doesn't arm. So is the issue the motor or the esc? Why would a functioning esc/motor stop working after I reinstalled the rx?
Sep 30, 2012, 12:02 AM
Registered Addict
Kris...'s Avatar
Quote:
Originally Posted by 3flyguy3
I "borrowed" my orange rx from my Edgd over to another plane to text its esc. Turns out the esc was fine. I put the rx back on the Edge and I have all surface movement and LEDs but no motor. The esc doesn't doesn't arm. So is the issue the motor or the esc? Why would a functioning esc/motor stop working after I reinstalled the rx?
Try adding a couple of down clicks on the throttle trim then see if your esc arms.
Sep 30, 2012, 12:02 AM
Сделайте Америку Великой Снова
7oneWo1f's Avatar
Quote:
Originally Posted by 3flyguy3
I "borrowed" my orange rx from my Edgd over to another plane to text its esc. Turns out the esc was fine. I put the rx back on the Edge and I have all surface movement and LEDs but no motor. The esc doesn't doesn't arm. So is the issue the motor or the esc? Why would a functioning esc/motor stop working after I reinstalled the rx?
Check your trim and subtrim on your throttle. Make sure your throttle is low. Make sure you haven't reversed your throttle channel. Rebind. Just generic things to try that are related to what your report. After that, try a different ESC with the receiver, or a different motor with the ESC.
Sep 30, 2012, 06:28 AM
Registered User
Quote:
Originally Posted by 3flyguy3
I "borrowed" my orange rx from my Edgd over to another plane to text its esc. Turns out the esc was fine. I put the rx back on the Edge and I have all surface movement and LEDs but no motor. The esc doesn't doesn't arm. So is the issue the motor or the esc? Why would a functioning esc/motor stop working after I reinstalled the rx?
You might have to recalibrate the throttle endpoints.
Sep 30, 2012, 09:06 AM
Registered User
3flyguy3's Avatar
Quote:
Originally Posted by LoneWolfRC
Check your trim and subtrim on your throttle. Make sure your throttle is low. Make sure you haven't reversed your throttle channel. Rebind. Just generic things to try that are related to what your report. After that, try a different ESC with the receiver, or a different motor with the ESC.
Ok, I'll try the suggested. I did rebind, no success. And even tried a different esc with the rx. Rx is fine on the other esc/motor. I even tried a different rx on the suspect esc/motor. The other motor/esc I have, don't fit the bullet connectors. Would I have to solder up some connections to fit the Slicko motor and Twisted esc? Or is it safe to electric tape them temporarily?

Quote:
Originally Posted by jetinteriorguy
You might have to recalibrate the throttle endpoints.
Do you know off hand if that's covered in the manual for the DX6i? I can't look at this very moment. If it's not covered, do you know how?
Sep 30, 2012, 06:01 PM
Registered User
Quote:
Originally Posted by 3flyguy3
Ok, I'll try the suggested. I did rebind, no success. And even tried a different esc with the rx. Rx is fine on the other esc/motor. I even tried a different rx on the suspect esc/motor. The other motor/esc I have, don't fit the bullet connectors. Would I have to solder up some connections to fit the Slicko motor and Twisted esc? Or is it safe to electric tape them temporarily?


Do you know off hand if that's covered in the manual for the DX6i? I can't look at this very moment. If it's not covered, do you know how?
You have to calibrate throttle endpoints through the ESC, so you have to check the manual for the ESC to see how to do it using your transmitter. Usually you turn on the trans, move the throttle stick all the way up, then turn on the esc and wait for a couple of beeps then move the throttle stick down and it should arm itself and do the normal startup beeps. But check your esc manual to be sure.
Sep 30, 2012, 06:18 PM
Team Twisted!
cdee's Avatar
ESC Arming....
.
For the Twisted Hobbys' ESC, there is a short video on how to initialize it, on the Twisted Hobbys' site - ESC pages
.
cdee
.
Sep 30, 2012, 07:27 PM
Registered User
3flyguy3's Avatar
Tried setting up throttle calibration per video...nothing. No response.
Oct 02, 2012, 01:37 AM
Registered User
Aviefly's Avatar
We had the first proper indoor session on Saturday night. Here is a video of some of the mayhem that ensued, watch for the crash session at the end The only casualty after all that abuse was one eight inch prop and a slightly loose motor mount, we left with everything still flyable fun fun fun


Warning this video contains aircraft abuse

First indoor mayhem and madness 2012 (5 min 16 sec)
Oct 02, 2012, 02:51 AM
Registered Addict
Kris...'s Avatar
Man looks like you had fun mate wish there was an indoor session near me.
Oct 02, 2012, 05:40 AM
Registered User
Mike Smart's Avatar
Quote:
Originally Posted by Kris...
Man looks like you had fun mate wish there was an indoor session near me.
Ours start again on 11th October - can't wait

Mike


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Build Log Twisted Hobbys - Telink 43" Yak 55 - Build, Fly, Vid hercdriver7777 3D Foamies 1008 Apr 04, 2017 12:39 PM
Discussion Twisted Hobbys - RC Factory USA Sbach 342 39" Build Thread & Flight Video!!!!! aerofundan 3D Foamies 497 May 24, 2015 08:01 AM
Build Log Twisted Hobbys - Telink 3D Buster EPP Bipe Build Thread, Flight Video just posted!!!! aerofundan 3D Foamies 578 Apr 21, 2015 04:01 AM
Discussion Twisted Hobbys - RC Factory USA YAK-55 39" Build Thread/Videos & Flight Video!!!!! cbriggs11 3D Foamies 78 May 28, 2014 05:40 PM
Discussion RC Factory USA - Twisted Hobbys - 1.2m SU 29 Build Thread. hercdriver7777 3D Foamies 97 Oct 19, 2011 06:34 AM