Thread Tools
Oct 03, 2011, 01:19 PM
Registered User
Question

Anyone else having problems with T-Pro (Tower Pro) MG90 servos?


Just curious - anyone else had any significant issues with T-Pro MG90 servos? I got 4 of them from hobby partz, one's got the jitters (BAD!). I've tested it thoroughly, it's definitely the servo.

I want metal gear and I am just having a hard time willing to spend $20+ for a Hitec HS-5050MG on a foamie (wouldn't blink if it were a more expensive model). From all the searching I've done on the net, and here, it looks like in general people are having really good experience with the T-Pro's. The other three I got seem to be fine, so I'm hoping the one is just bad luck.

I ordered two more servos. I am going to put some contact cleaner on the pot of the bad one and put all 4 on a servo cycler for a while, to see if I can't ressurect the bad one and test out the good ones. But not sure I want to trust the bad one on a plane, it was on a airelon and started the jitters during my radio setup, right before a maiden flight.
Sign up now
to remove ads between posts
Oct 03, 2011, 03:21 PM
Dean
A10FLYR's Avatar
RC model reviews on u-tube claims all TowerPro servos to be junk.....
Oct 03, 2011, 03:55 PM
Registered User
I did give MG90s a try, and one od them burned out (electronics) at my desk within few minutes, - using 4-cell NiMH pack and servotester, and at no load.
Well, I found a message that HXT900 can accept the metal gear of MG90s, so I desided to end their road at once - I have HXT900MG servos now, and they work like a charm.

But You must use "black" top cover at blue servo, and workaround different second shaft length (that from HXT is too short, and the one from MG is a little longer than fits - I did made a deeper hole for it..
Oct 03, 2011, 04:25 PM
Balsa addiction since age 3
ScottSails's Avatar
I had one fail on the bench - elevator servo and the tail was resting on it while powered. It caused it to fail just from that load after maybe 5 min. I blame it on myself but suspect a Hitec servo would not have burned up.

I like the suggestion of using the HXT900 servo with the MG.

Scott
Oct 03, 2011, 11:12 PM
Registered User
Sprayed a little contact cleaner on the pot, cycled the main shaft about 20 times, reassembled and seems to be working fine. Don't really want to trust it for a main control surface. Maybe I'll let it move some eyeballs inside a pumpkin.

Will run the other MG90's through a servo test for a while to make sure they don't flake right off the bat.
Oct 04, 2011, 10:20 PM
Registered User
Update: the cleaned up servo (bad #1) seems to be doing ok. 10 minutes on the cycler and so far so good. Question is, do I trust it to not go again.

The other one I used for airelons was also jittery after hooking up to the tester, but after cycling for 10 minutes, it seems ok. Both of the servos for the flaps seem fine out of the box.

I'll keep cycling them once a day for the next week to see what happens. If things continue to look good by the weekend, I might actually fly.
Oct 04, 2011, 10:23 PM
smoke is my wattmeter
I've abused about 8 of them for a couple of years and never a problem.
Oct 05, 2011, 02:39 AM
Registered User
Quote:
Originally Posted by krexken
I've abused about 8 of them for a couple of years and never a problem.
Perhaps they are "updated" now, since your version couple of years ago ?
Oct 05, 2011, 10:22 AM
Registered User
It's looking to me that some of the gear grease has gotten on the pot. Could be careless assembly. The design of the servo, and electronics all seem fine.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Found Anyone local have a t-pro mg90 servo I can come buy this weekend??? ddrummer508 Aircraft - Electric - Helis (FS/W) 0 Sep 24, 2011 11:49 AM
Discussion Is Anyone else having X-stal problems with there Bergs? kushal_22 Electric Plane Talk 18 Jul 04, 2006 04:41 PM
Rant Anyone else having problems with Align 35A ESC's? sharky47 Mini Helis 27 Mar 21, 2006 05:59 AM
Anyone Else Having Problems with the GWS Videos? aeronca GWS (Grand Wing Servo) 4 Aug 22, 2004 06:00 PM
Anyone else having problems with little kids interrupting? Lynxman Micro Helis 33 Jul 05, 2004 10:55 PM