Thread Tools
Old Feb 14, 2012, 07:35 PM
brianshell is offline
Find More Posts by brianshell
Registered User
brianshell's Avatar
Thoughts on this? The strut is not as thick as the first generation (Which was my initial concern) and doesn't really fit in the "track".

VID-20120214-00003.3GP (0 min 8 sec)
Sign up now
to remove ads between posts
Old Feb 14, 2012, 08:32 PM
Bilymac is offline
Find More Posts by Bilymac
Registered User
That doesn't look right. You can try sending the video in to the vendor.
Old Feb 14, 2012, 09:14 PM
Bilymac is offline
Find More Posts by Bilymac
Registered User
I just looked at the picks on the HK site, and they look the same as the ones in your video.
Old Feb 14, 2012, 09:16 PM
brianshell is offline
Find More Posts by brianshell
Registered User
brianshell's Avatar
Quote:
Originally Posted by Bilymac View Post
I just looked at the picks on the HK site, and they look the same as the ones in your video.
Wow.. I'm surprised to hear that.

I just put the wings together anyway (with the floppiness in the struts)... and as you might expect, the top wing rocks back and forth, with a play of about 3 inches each direction (6 inches total).

It's possible it will tighten up once I have all the support wires in place. But I think I'm going to stick some balsa wood inside the brackets to make it more rigid.
Old Feb 14, 2012, 11:29 PM
STATUS is offline
Find More Posts by STATUS
STATUS TUNING
STATUS's Avatar
Quote:
Originally Posted by brianshell View Post
Thoughts on this? The strut is not as thick as the first generation (Which was my initial concern) and doesn't really fit in the "track".

http://youtu.be/lvw_a7xK4Yk
ooh snap, thats no good even v1 had too much movement.

https://www.rcgroups.com/forums/show...&postcount=141
Old Feb 15, 2012, 02:00 AM
brianshell is offline
Find More Posts by brianshell
Registered User
brianshell's Avatar
Well, it's all put together and it looks great.

Unfortunately, it looks like the ESC is dead-on-arrival. The BEC appears fine (it powers up my receiver) but the ESC makes no sounds at all when it powers up, and definitely isn't powering the motor. (Unless there's some magic arming procedure I'm not aware of). Tried a 6S and a 5S battery with it and same results with both.

Looks like I've also got a servo that's glitchy on one of my ailerons. (Seems to have a mind of its own).

So far I'm having a difficult time being impressed. =(
Old Feb 15, 2012, 02:17 AM
gastolectric is offline
Find More Posts by gastolectric
Registered User
gastolectric's Avatar
Brian, seems silly point to raise, (it's caught me out before though) check the 3 esc connections to the motor
Old Feb 15, 2012, 02:36 AM
brianshell is offline
Find More Posts by brianshell
Registered User
brianshell's Avatar
Quote:
Originally Posted by gastolectric View Post
Brian, seems silly point to raise, (it's caught me out before though) check the 3 esc connections to the motor
So I am admittedly still a newb here... but my understanding is that there's no wrong way to hook the three ESC wires to the motor (other than if you have something backwards, the motor will spin the wrong way).

Is that the case here?
Old Feb 15, 2012, 04:51 AM
gastolectric is offline
Find More Posts by gastolectric
Registered User
gastolectric's Avatar
Quite right you are, but I had a new Dynam spittie play dead when I first tried it and ultimately traced it to a loose connection on one of the esc leads (held in place by the shrink tube with no soldered joint.

It's a pity to hear that V2 hasn't ironed out all the bugs of V1 coz she really is a lovely sized girl when she's in the air!!
Old Feb 15, 2012, 11:25 AM
Bilymac is offline
Find More Posts by Bilymac
Registered User
I seem to recall reading about ESC issues, and one fix was to connect the battery with the TX on, and the throttle stick in the full on position, and within three seconds, reduce it too the off position. It has something to do with ESC calibration. You might give that a try.
Old Feb 15, 2012, 03:28 PM
handy_andy is offline
Find More Posts by handy_andy
Registered User
Brian, Make sure your throttle trim is all the way down or off. The ESC problem happened to me as well and bringing the trim down to zero made it work right away.
Last edited by handy_andy; Feb 15, 2012 at 03:50 PM.
Old Feb 15, 2012, 04:49 PM
DarwinF is offline
Find More Posts by DarwinF
Registered User
I really wish this plane would fit in my car!
Old Feb 15, 2012, 06:13 PM
brianshell is offline
Find More Posts by brianshell
Registered User
brianshell's Avatar
Quote:
Originally Posted by Bilymac View Post
I seem to recall reading about ESC issues, and one fix was to connect the battery with the TX on, and the throttle stick in the full on position, and within three seconds, reduce it too the off position. It has something to do with ESC calibration. You might give that a try.
Sir, I owe you a beer!!!!!! This did the trick!! (A mention of this in the manual might have been helpful!) =)
Old Feb 15, 2012, 08:49 PM
Bilymac is offline
Find More Posts by Bilymac
Registered User
Glad I could help. I'm pretty new to this myself, so keeping up on these forums can be a big help. Keep us informed on your Pitts, this is one I really want to buy.
Old Feb 15, 2012, 08:55 PM
brianshell is offline
Find More Posts by brianshell
Registered User
brianshell's Avatar
Sincere apologies for all the stupid newb questions.. can someone tell me where (and how) to mount the ESC, and also where's the best place to mount the battery, considering I don't want to 3D the plane, just have some fun sport flying.

Thanks again for all the help.. I owe you guys big for even having gotten this far =)


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion 63" BlitzWorks P51D Mustang / Banana Hobby - HELP jdwphotos.com Electric Warbirds 5 Apr 07, 2012 03:26 PM
Discussion Just got my Blitz RC Works Pitts Special from Banana Hobby! Sparkorama Electric Plane Talk 26 Jul 06, 2011 07:02 PM
Discussion BltzRC(Banana Hobby) 63" P51 splais Electric Warbirds 9 Jan 14, 2011 10:03 PM
Discussion Banana Hobby Pitts 3rd flight..... almost jimmyg79 Electric Plane Talk 3 Feb 05, 2010 09:48 AM
Help! Banana Hobby Pitts joebull Banana Hobby 4 Oct 24, 2009 01:20 AM