RCTimer/Turnigy/Hobbywing ESC DIY Firmware Flashing - Page 425 - RC Groups
Thread Tools
Nov 14, 2012, 03:50 AM
Registered User
Originally Posted by simonk
Hello! Hmm, I do not have that motor or that board (and it is no longer available). I have not heard that sort of sound before. There definitely seems to be a problem with the sense feedback, or maybe with the signal input. You say this happens with all of the boards and motors, right? Does the logic side of the board look like this image? If not, please take and post a picture of it. Have you tried with a servo tester just to rule out input signal problems?
Hello, thank you for reply.
Board looks exactly like this: http://i1239.photobucket.com/albums/...s/P1010165.jpg and this : http://i1239.photobucket.com/albums/...s/P1010162.jpg

Atmel chip is hidden on the other side of the board, so it can't be seen - I'm using connection with pads.
I have tried yesterday Wii-ESC firmware and with this it is fairly OK - just startup is not that smooth as with your FW.
I haven't tried servo tester yet (ordered) but I can rule out the input signal problem as I have tried with cheap 35Mhz TX/RX and also with Graupner MX20 and both act the same.

What part of code could I try to change to tune-up that timing? I agree that problem is probably with sensing.
Sign up now
to remove ads between posts
Nov 14, 2012, 03:58 AM
APM Copter Developer
Marco67's Avatar
Stranger, with wii-esc the startup is much more smooth than with SimonK and quieter motors, tested with MK3638 and TM2814.
SimonK just seems more responsive at low rpm.
Nov 14, 2012, 04:12 AM
Registered User
I have tried yesterday this ESC with china 2212 motor as well - the misfiring sound and drop of power was still there, but it wasn't that bad.

What is interesting, I have tried stock ESC with 2212 motor and it was working fine - while with this 3536 motor it was unusable.

I have tried these 3536 motors with other ESC (Mystery 30A stock firmware) and they were working fine.
Nov 14, 2012, 03:21 PM
Registered User
Originally Posted by rcjuampa
One more ESC to the list. This is SAKER 30A SBEC, flashed and tested.
row pads
ext osc yes
FW file kda.hex
Is this the same esc as the Multistar 30 A ?
Nov 14, 2012, 03:57 PM
Too Many Thread Subscriptions
TheFernMan's Avatar
anyone know why the Mystery 30amps are not on the database sheet list?
Nov 14, 2012, 04:18 PM
g0t rabb1t?
ABLomas's Avatar
Originally Posted by TheFernMan
anyone know why the Mystery 30amps are not on the database sheet list?
They are - both cloud and pentium series.
Nov 14, 2012, 04:21 PM
Too Many Thread Subscriptions
TheFernMan's Avatar
Originally Posted by ABLomas
They are - both cloud and pentium series.
no, the ones im looking at are just like the BluesSeries 30 amps
Nov 14, 2012, 04:25 PM
Too Many Thread Subscriptions
TheFernMan's Avatar
These are what im looking at..
Nov 14, 2012, 07:33 PM
Registered User
wister's Avatar

I have been having a problem connection to the server using the esc flash tool. I used this in the past and it worked with no problem. I tried a few motnths ago and got an error that was either 530 or 510, or 501 (I cant remember exactly which) basically it said not logged into server, or cannot log in. I thought maybe the severr was having problems and forgot about it.

Now I am trying again to update my esc's, actually I did update them by copying the hex into the debug dir of the esc flash tool program but the esc's didnt seem to work right, not enough power, also made the motors feel like the bearings were, how to explain this, when I spin the motor with no power applied it was harder to turn them while connected to the esc, disconnected or connected to a different esc the motor spun easy again.

So I am trying to update the esc's to 9-30 hex "bs_nfet.hex" and I am stil getting an error when trying to download from the server. I updated the dot net to 4.5, then removed it and installed the 4.0 version. I am still getting the error that now says

"Unhanded exception has occurred in your application. if you click continue...
Unable to connect to remote server" but no error code

I have tried on 2 different PC's both running win 7 x64 and get the same problem

Please help

Should I be ok coping the bs_nfet.hex and bs_nfet.inc files directly into the debug directory (overrighting the old files) then flash that way? Like I said I tried this before but the esc's (that worked great with an older version of bs_nfet) werent working correctly after?? not sure if it actually flashed the 9_30 ver or a real old ver?

Nov 14, 2012, 10:39 PM
Registered User
Originally Posted by LittleMo
The bundled Linux avrdude is 32-bit and I don't have a 32-bit version of libusb (Arch Linux).
I run fine with Fedora 12.
Nov 15, 2012, 12:51 AM
Too Many Thread Subscriptions
TheFernMan's Avatar
USB linker in stock http://www.hobbyking.com/hobbyking/s...dProduct=10628
Nov 15, 2012, 12:45 PM
What goes up...
acuralegendz's Avatar

New HK Redbrick 30a

Has anyone seen or flashed this version of the HK Redbrick 30a
Nov 15, 2012, 02:39 PM
Registered User
saxon0010's Avatar
Has anyone flashed this ESC:
XAircraft 450 PRO E3007 X450 Pro 10A Brushless ESC

Thanks, Saxon
Nov 15, 2012, 03:57 PM
Registered User
Originally Posted by acuralegendz
Has anyone seen or flashed this version of the HK Redbrick 30a
Do they match THIS POST ?
I replied below it with another link to a previous post (also in this thread)
Nov 16, 2012, 12:25 AM
Registered User
Originally Posted by RQuad

Simon came up with this:
When you want to test the ESC reaction on fast throttle changes it might not be sufficient to use a servo tester or just move the throttle stick.
Just program your transmitter such, that a switch sets the throttle to max.

I used a mix of a 100% switch to my normal throttle, so I can set the throttle from what ever the stick input is to 100% with the flip of this switch- easy and efficient!

Thanks - great idea, I did the same and as well as reassuring me that the MT4008s won't mistime, it shows up the faster response from the SK flashed F30A compared with the RCTigermotor T40A. At lower power the F30A is just as efficient as the T40A but I still have the unexplained 25% lower maximum power (thrust and amps) from the F30A. I have some F40As on their way to me so I'll flash one of those and do a trial with it.

Edit: as a test I reflashed the F30A with WII ESC Firmware and the figures at hover power settings (500, 750 and 900g thrust) were very similar to the SK flash and also to the RCTigermotor T40A but max power was up to 1680g thrust - 100g more than the SK flash but still down on the 1800gthe motor/prop combination (MT4008-12 and Graupner 17x8 E-Prop) developed on the T40A ESC - curiouser and curiouser.
Last edited by RedSky; Nov 16, 2012 at 01:34 AM.

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Rctimer 30A esc cutting out with KK board Efliernz Multirotor Drone Talk 2 May 26, 2011 03:20 PM
Sold FS: Tricopter Parts- HK401b, Pentium 30A ESC, rctimer 750kv motors pwu_1 Aircraft - General - Miscellaneous (FS/W) 2 Jan 18, 2011 10:58 PM
Sold RCTimer 2826-6 + ESC 30A New in packaging will trade as well Pics Added! planebldr Aircraft - Electric - Power Systems (FS/W) 4 May 25, 2010 10:54 PM
Discussion RCTimer 30A Programmable ESC hunter7193 Power Systems 8 Jan 02, 2010 03:27 PM
For Sale Several New ESC's - 10a, 20a, 30a - Reduced Callen9345 Aircraft - Electric - Power Systems (FS/W) 0 Apr 20, 2009 03:31 PM