Shop our Airplanes Products Drone Products Sales
Thread Tools
Old Oct 22, 2012, 04:49 PM
sirbow2 is offline
Find More Posts by sirbow2
Emress
can you post a pic? the sck error isnt important and it will still work( if im thinking of the right one), so it might be another issue
Sign up now
to remove ads between posts
Old Oct 22, 2012, 05:26 PM
LittleMo is offline
Find More Posts by LittleMo
Registered User
LittleMo's Avatar
I have put my Arduino USB Linker project up on github and released version 0.2. This version can use faster signaling over the servo wire. It will now run at about 50 kbps max (20Ás signaling). Default is still around 7343 bps (136Ás) though, see BITTIME in the source.

https://github.com/c---/ArduinoUSBLinker
Old Oct 22, 2012, 05:38 PM
SadSack is offline
Find More Posts by SadSack
Registered User
Quote:
Originally Posted by LittleMo View Post
I have put my Arduino USB Linker project up on github and released version 0.2. This version can use faster signaling over the servo wire. It will now run at about 50 kbps max (20Ás signaling). Default is still around 7343 bps (136Ás) though, see BITTIME in the source.

https://github.com/c---/ArduinoUSBLinker
Well thanks as fast as ISP

thx, phil

Out of interest could i move pin2 to pin13 ? Just it puts both pins side by side, not important.
Old Oct 22, 2012, 06:13 PM
LittleMo is offline
Find More Posts by LittleMo
Registered User
LittleMo's Avatar
Quote:
Originally Posted by SadSack View Post
Out of interest could i move pin2 to pin13 ? Just it puts both pins side by side, not important.
The only easy change would be to switch to PD3/INT1 due to the use of the pin as an external interrupt. In theory almost any pin could be used on modern ATmega's but would require slightly more overhead because the other pins can't trigger only on a specific state change (eg. RISING).

At some point I'll test it on some other pin and see if it has any negative effect.
Old Oct 22, 2012, 07:28 PM
ziss_dm is offline
Find More Posts by ziss_dm
Registered User
Hi,

Quote:
Hmm, actually, wii-esc v2 seems to currently only update the power (run_power_control()) after every commutation, unless I'm misunderstanding the pt_threads, whereas I do it cooperatively from all wait loops.
True, but my motors on Idle, commutating faster than new PPM frames are coming. So, it not induce any measurable delay.

On other hand, due the higher resolution and more linear response, on the same setup, I can increase proportional gains 1.5 - 1.8 times higher without oscillations (comparetivelly to RapidESC).

regards,
ziss_dm
Old Oct 22, 2012, 07:35 PM
simonk is offline
Find More Posts by simonk
hacker
Quote:
Originally Posted by ziss_dm View Post
On other hand, due the higher resolution and more linear response, on the same setup, I can increase proportional gains 1.5 - 1.8 times higher without oscillations (comparetivelly to RapidESC).
Hello! Are you comparing with complementary PWM enabled, or is this just from SDM? I will have to test this.
Old Oct 22, 2012, 07:57 PM
ziss_dm is offline
Find More Posts by ziss_dm
Registered User
Hi,

Just SDM (ESC: HK261000001, Motor: 1811-2000)

regards,
ziss_dm
Old Oct 23, 2012, 02:17 AM
LazyZero is offline
Find More Posts by LazyZero
Master of Flash
LazyZero's Avatar
Hi,

Anybody knows which variant fits to this ESC.
Aeolian Evolution 80A
BEC 3A/5V Vers.4.0
2-6S lipo 80A



thanks Christian
Old Oct 23, 2012, 03:41 AM
magic_marty is offline
Find More Posts by magic_marty
<Marty>
tried to flash my HK F30 esc and no luck both the flash tools i tried says they can't find the USB device...i did install the drivers and in the device manager it shows the usbap device is working properly...anybody have any suggestions on how i can get it working...im running xp home edition...

get this error: could not find USB device with vid=0x16c0 pid=0x5dc vendor='www.fischl.de' product='USBasp'
Old Oct 23, 2012, 03:47 AM
LazyZero is offline
Find More Posts by LazyZero
Master of Flash
LazyZero's Avatar
Try the "all usbasp clone" instead of USBasp in the programmer selection drop-down box

Christian
Old Oct 23, 2012, 03:50 AM
magic_marty is offline
Find More Posts by magic_marty
<Marty>
tried the any clone usbap and get same error...


C:\Documents and Settings\Martin\Desktop\Lazyzero flashing tool\tmp\/hfuse.hex:r
avrdude.exe: error: could not find USB device with vid=0x16c0 pid=0x5dc
Old Oct 23, 2012, 03:52 AM
LazyZero is offline
Find More Posts by LazyZero
Master of Flash
LazyZero's Avatar
can you post a screenshot from your devicemanager when the usbasp is plugged to the PC?
And one when the error occurs.
Old Oct 23, 2012, 03:56 AM
magic_marty is offline
Find More Posts by magic_marty
<Marty>
screen shot
Old Oct 23, 2012, 03:58 AM
magic_marty is offline
Find More Posts by magic_marty
<Marty>
shot of the error ...
Old Oct 23, 2012, 04:02 AM
LazyZero is offline
Find More Posts by LazyZero
Master of Flash
LazyZero's Avatar
Does the power LED go off when you connect ESC to the usbasp? Then you probably short cut something or draw to much current and the USB rejects the device.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Rctimer 30A esc cutting out with KK board Efliernz Multirotor Talk 2 May 26, 2011 03:20 PM
Sold FS: Tricopter Parts- HK401b, Pentium 30A ESC, rctimer 750kv motors pwu_1 Aircraft - General - Miscellaneous (FS/W) 2 Jan 18, 2011 10:58 PM
Sold RCTimer 2826-6 + ESC 30A New in packaging will trade as well Pics Added! planebldr Aircraft - Electric - Power Systems (FS/W) 4 May 25, 2010 10:54 PM
Discussion RCTimer 30A Programmable ESC hunter7193 Power Systems 8 Jan 02, 2010 03:27 PM
For Sale Several New ESC's - 10a, 20a, 30a - Reduced Callen9345 Aircraft - Electric - Power Systems (FS/W) 0 Apr 20, 2009 03:31 PM