Thread Tools
Jan 19, 2012, 08:43 AM
manuLRK

calibration


FYI,

Got something really strange with 1 of the 4 plush 10A esc.
I reflashed all 4 with latest firmware. Calibrated all 4 at the same time. Only 1 does not "store" the value..., after a repower, it lost the calibration.
I tried to calibrate it separately, it does the calibration well, all ok, but after a repower, it loses it.
Solution, i had to trim down the throttle by a few trims
1)Full throttle -> 2)lower it -> 3)i get the calibration beeps "ok" -> 4)start the motor and see the effect of the calibration. 5)power off / on and lose the calibration

Now, when i do 1), 2), 3), 3bis) 5 trims lower, ....
It keeps calibration.

I should be on the edge of something...


For the info: the startup without calibration does follow this order! So, calibration with esc without ext osc, is a must! And it works great! Thanks Siimon. And now the programming without reflash...

Esc OSCCAL
1 A2(162)
2 A6(166)
3 AD(173)
4 B0(176)


Thanks,
Manu


Sign up now
to remove ads between posts
Jan 19, 2012, 09:28 AM
manuLRK
Try to lower the P factor and see how it behaves.
In hovering its a nice "sound", when you move the copter, you hear clearly the "chirping low tone, grrrr, grrrr", which is NOT good! It should always be a sweet "phwee, pfweee" sound.

I am experiencing same kind of behavior on one of my kk-copter with lot of vibration due to not well balanced props and these motors (1200kv i think).
I set P as high as possible, in hover it looks rock stable, then, when start flying, i get constant "chirping low tone" like motors can't follow and lose sync for a short moment.
The esc takes all the unfiltered pwm commands.
So i should first get rid of the vibration, and see if i gets better.
Second, use a better "vibration tolerant" firmware..., or the esc firmware can do a part of the job...


Quote:
Originally Posted by Cossacs
Yes, 4s, here is video, going full throttle on 0:13

I've pulled one dedicated motor much harder before in static with no problems. 8cm wire length from ESC to battery should not be a problem. But long Battery-ESC wire length in combination with -5c outside temperature (increased capacitor impedance) and really hard setup (3x2820/14 Pulso 140 gramm motors per each 4s 5000 30C battery) and low input capacitor (only 440uF per ESC) could be a problem, how do you think?

I have not tried wii-esc code yet because i do not exactly know why i never seen such problem with one motor only.

Which input PWM refresh rate you recommend to use? Does it really matter?

Thanks
Last edited by alll; Jan 19, 2012 at 09:38 AM.
Jan 19, 2012, 09:54 AM
Registered User
Quote:
Originally Posted by timecop
Theres no reason the app should be > 800x600
Also, don't forget to account for taskbar or those with 800x600 won't be able to display it..... it's rarely a problem on the laptop but for some netbooks....
Jan 19, 2012, 12:46 PM
Suspended Account
lol my tablet is 1280x800...
Jan 19, 2012, 12:52 PM
Master of Flash
LazyZero's Avatar
Will your Tool be cross platform?
If you need avedude with xwopen USBasp support give me a pm.

Best Christian
Jan 19, 2012, 12:56 PM
I don't speak German ....Yet !
GrootWitBaas's Avatar
he said c# so I guess not ...
Jan 19, 2012, 12:57 PM
Suspended Account
run it in wine lol its not that difficult to find .net emulator
Jan 19, 2012, 01:00 PM
I don't speak German ....Yet !
GrootWitBaas's Avatar
Yes sure I'll find a way to run it, but I hope you'll share the code so I can use your hard work to make a nice Mac Gui ...
Jan 19, 2012, 01:01 PM
Master of Flash
LazyZero's Avatar
Why not directly compile with mono? So no need for an additional emulator.

Christian
Jan 19, 2012, 01:40 PM
30 RC's and counting
Bmr4life's Avatar
Quote:
Originally Posted by chatch15117
lol my tablet is 1280x800...
Most tablets were introduced just a few years ago so their resolutions are pretty up to date.
Jan 19, 2012, 04:59 PM
throw new IOPilotException();
IceWind's Avatar
If it doesn't have any funky code c# will run in Mac and Linux using Mono.
Jan 19, 2012, 05:04 PM
Suspended Account
Quote:
Originally Posted by IceWind
If it doesn't have any funky code c# will run in Mac and Linux using Mono.
And here I thought Mono was some kind of disease. Oh, wait. Mac and Lunix. It probably is.
Jan 19, 2012, 05:38 PM
Suspended Account
i like this timecop dude

i will use std libraries. if i can run asp in linux apache server u can figure out simple gui.
Jan 19, 2012, 05:45 PM
Thou who know not
Po73's Avatar
Quote:
Originally Posted by chatch15117
i like this timecop dude

i will use std libraries. if i can run asp in linux apache server u can figure out simple gui.
I thought a STD was a bad thing? Never the less, I've ordered a set of RCTimer 20amp ESCs and plan on flashing them
Jan 19, 2012, 06:21 PM
throw new IOPilotException();
IceWind's Avatar
Quote:
Originally Posted by timecop
And here I thought Mono was some kind of disease. Oh, wait. Mac and Lunix. It probably is.
Unless you use some BSD or Solaris I'd say you're a Windows fanboy!


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Rctimer 30A esc cutting out with KK board Efliernz Multirotor Drone Talk 2 May 26, 2011 02:20 PM
Sold FS: Tricopter Parts- HK401b, Pentium 30A ESC, rctimer 750kv motors pwu_1 Aircraft - General - Miscellaneous (FS/W) 2 Jan 18, 2011 09:58 PM
Sold RCTimer 2826-6 + ESC 30A New in packaging will trade as well Pics Added! planebldr Aircraft - Electric - Power Systems (FS/W) 4 May 25, 2010 09:54 PM
Discussion RCTimer 30A Programmable ESC hunter7193 Power Systems 8 Jan 02, 2010 02:27 PM
For Sale Several New ESC's - 10a, 20a, 30a - Reduced Callen9345 Aircraft - Electric - Power Systems (FS/W) 0 Apr 20, 2009 02:31 PM