Flycam / KK Blackboard / Naviboard / Sonar Thread - Page 107 - RC Groups
Shop our Airplanes Products Drone Products Sales
Thread Tools
Dec 26, 2012, 05:37 PM
Multirotor Builder!!!!!
Yep shows in the video. But can't fly now raining and 30 mph winds. It hold pretty good.
Sign up now
to remove ads between posts
Dec 26, 2012, 07:10 PM
Multirotor Builder!!!!!
I found my night flying video looking for my other one.

MCFC KK2 quad at night.AVI (4 min 25 sec)
Dec 27, 2012, 12:25 AM
"Pretty good" is not enough for the same price that You can buy the Naza (just one example ) and fly stable out of box.
What are we talking about here ? Is not the cheep board or free one to tolerate all this problem.
Anybody pay loot of money for tolerate those problems.
Yes..I agree to encourage Mr Minsoo, but not on my nerve, money and time.
Are You kidding me ? After more then one Year of testing and manual fallowing, still having problem and broken board (no the only one with negative message), mean time same price (more or less) the other boards work like charm out of box !?
Nor mention haw many times I ask help on their site or on Youtube channel in all this time, and only one answer on Youtube after more then 1 Year.
I'm not stealing my money, they are hard working.
Dec 27, 2012, 06:45 AM
It also easier to break down stuff than give info that can help people with their problems.I never had any plane helicopter,whatsoever. I am now playing around for a good half year with the quad.
The first board was the blackboard v2 work good till a gyro broke. Got it replace by mr minsoo for the MCFC and also bought the navi board.

If ya want a bargan go buy HK lcd board and flash it with the 1.5fw works great and if you crash its only 25usd. I got 2 of them to do crazzy.

But yesterday i did a complete reset of the MCFC board set everything to default
settings!LIKE IT COME OUT OF THE BOX.even the pid settings are for a quad with 230 pitch and roll. I got a 290 pitch and roll
In between the rain showers went out for a lift.Pretty cold outside and heavy winds.

Flycam MCFC Flyig out of the box (2 min 43 sec)

So mail Mr minsoo try work something out. Else buy the naza, and have a good flight.
Dec 28, 2012, 07:34 AM
Registered User
Well a week ago I emailed Mr Minsoo about my Navi 1 barometer, and to my surprise I was told I would get the new MCFC which arrived on the 27 Dec. I have been reading the recent posts and just kept my fingers crossed that things may turn out Ok.

I spent the whole day with the new board but it just would not lock any satellites, I even connected my home brew satellite cable with my GPS that I know works. I had given up and I had just sent Mr Minsoo an email about it when the Satellites locked in the house; this was at1:00 Am. I have no idea what I did but here are some of the things that I did in desperation.

1) I calibrated the GPS lots of time.
2) I connected the GPS board to the ground station and observed the Green LED flashing.
3) I connected the GPS to my home brew extended cable.
4) I tested the cables with a multi-meter.
5) I plugged and unplugged the cables many times.
6) I also reset the board to factory settings.

Theeen it worked?

This morning I took the copter out side and after 15 minutes nothing so I recalibrated the GPS after 10 minutes nothing so I recalibrated again and this time I got a lock after 7 minutes. I then powered the copter down and waited about a minute and powered up again and this time it locked after 24 seconds.

7) I have now twisted the GPS cable thatís between the 2 boards this way it will tend to have tension on it and may keep the pins in better contact.


I think the issue is with the GPS cables contact with the pins.
On a side note I did flash back to V1.0 but that made no difference.

Sad thing is I find one of my ESC has stopped working; this copter has had very little flying so I will spend some time to investigate, maybe it sat around for too long, and Iíll recalibrate it later. As I write this the GPS has locked in the house after just 4 minutes.
Dec 28, 2012, 07:16 PM
Registered User

Today I reset the ESCs to default and calibrated the throttle range; one ESC is very sluggish so I have to wait until I can buy one.

I have spent most of the day investigating its characteristics, to get a quick GPS lock for the first time after a prolonged period of power down it seems that a calibration of GPS is the best thing to do. After the initial lock it now locks within 1-2 minutes. Note due to weather I did most of the GPS test in the house and the average satellites was 7 and the most was 10. I did manage to leave the copter outside between bouts of drizzle rain and I had over 15 minutes of satellite lock; solid blue LED.

I just hope that this copter will fly as itís supposed to so I can get it FPVed.
Dec 29, 2012, 01:02 PM
Well wen i didnt fly for more then a day i t would take a little longer for the gps to lock,
also the first time it went for days, magnetometer going good,bad,good, till i calibrated the
magnetometer correct.

So today was a windy days again but without rain and less coolder, so tried my 9.5 inch FPV
monitor, still new to it and only flying for 5 months so bare zith me, but it works!!!!

FPVPractise (5 min 59 sec)
Dec 29, 2012, 02:04 PM
Registered User
Very encouraging, what capacity are those batteries? Also what ESC are you using? I need to replace mine?
Dec 29, 2012, 03:02 PM
They are 2 3s 5000mAh batt. but normally i fly with 1 5000mah 3s.
I am using the turnigy flush 18a esc.
I bought a 500mah 3s for the fpv because with 2 3s batt its on the edge of being to heavy.
Dec 29, 2012, 08:41 PM
Registered User
Originally Posted by GeO82
They are 2 3s 5000mAh batt. but normally i fly with 1 5000mah 3s.
I am using the turnigy flush 18a esc.
I bought a 500mah 3s for the fpv because with 2 3s batt its on the edge of being to heavy.
Well I've one 30A Turnigy Plush ESC so I might as well get another 3. I haven't had much luck over the last 2 years with 2 Quads,

I bought a Fie-yu Tech Dream Catcher ages ago that was too stable to fly around, it just kept fighting the controls to stay in the hover but after some complaints from the many customers they did eventually do an update and also it needed 2 capacitors to be removed from the PCB board. It flies better now but I haven't FPV it yet due to bad weather; NAZA was not in existence then.

Testing the X4-Pro with AEE HD set to 720P
FY X4 Quad AEE Camera.MOV.wmv (6 min 3 sec)

Last edited by Njoro; Dec 29, 2012 at 09:02 PM.
Dec 29, 2012, 11:28 PM
@GeO82....."It also easier to break down stuff than give info that can help people with their problems" Well ...I'm not stealin my money, so I found no problem being pisst off and tell to the other what can aspect before trow the money.
On the moment i buy the set, there was not even help in English from seller. Only after about one Year start to put some poor English on Youtube.
I email to them, I write many time on all possible channels... Im not started today on rc.
Anyway..forget about negative stuff.

My blue led go instant solid whe I power on the radio.
I was able to fly, but not with the blueboard that is broken on the box. I use HK green board with naviboard gps.
All those "disperate" stuff ...I did them in about 2 Years, that I'm dreaming all night flashing leds.
In my case... the red led go crazy when he want, even in fly time.
The alt position work , but nothing about the gps position hold.
Still I will try to fly like that for a wile, because I lost my patience.
I search the gyro for the blueboard, but nothing.
On the videos, I see no stable boards. All of them oscilate and not stay fixed on the position hold.

Have all a good New Year !
Dec 30, 2012, 05:25 AM
Registered User
Hi Lazy Zero
I have a similar problem. Tested KK board before installing naviboard and everything worked. Connected Naviboard and calbrated everything. KK board BLUE Led flashes once when first connected. When I try to arm RED Led flashes on Naviboard, but KK board will not arm. Would really APPRECIATE your advise
Dec 30, 2012, 06:58 AM
Registered User
Chris I have the exactly the same problem everything works but the blackboard won't arm, therefore the motors don't start. Please make some suggestions for me. I am desperate to get this thing in the air.
Dec 30, 2012, 07:32 AM
Registered User
Originally Posted by larryf8
hi guys, been frustrated on getting the kkmulticopter v5.5 to work. tried flashing different firmware but can't get the board to arm. also, i'm using a futaba 72mhz 9chp with a 9 channel any inputs or guide to wire the esc's and receiver to the board will greatly help also. tried the minsoo xcopter v1.0 firmware and went thru the whole process...but won't arm or the blue led to light up.

2 sleepless nights now....motors are emax bl2215/20 1200kv. esc's are 25A emax


Hi Larry, did you get a solution. I have the same problem. regards Andrea
Dec 30, 2012, 08:34 AM
@Artelian: no offence but there where alot of other controllers out there, what did you made you use this one? I have read alot of thread with pro and cons. Pid tuning isnt as easy buy just changing some numbers,alot of factors to consider to make it perfect because it seems that what you want,

I dont know how its with the previous board i only started from the blackboard2, hk v2.0 lcd and
flycam MCFC. Didnt even know that a hobbyking board and nav work together.
All i can says i get mine to work and dont see to osilate ,yeah in the heavy wind but all by all it needs some fine tuning.

Try to lower your throttle trim.

Thread Tools