Frsky receiver not working with brushed motor - RC Groups
Thread Tools
Sep 17, 2011, 09:45 PM
Scratch building addict
rotagen's Avatar
Discussion

Frsky receiver not working with brushed motor


Don't know if anyone else has seen this. It doesn't make sense to me, maybe someone knows why. I dug out an old trainer plane of mine for a friend that is learning to fly. It has a brushed motor/brushed esc designed to handle lipos and I'm running with a small 2S lipo.

The old receiver was FM but I wanted to try my Frsky rx in it.

Well all channels worked except the esc/motor (ch3). I got proper servo movement but no response from the motor. Took me a long time as I figured it was the esc, then possibly the old brushed motor but swapping them out did nothing, no motor response.

Then went back to the old FM receiver and everything functioned.

Anyone know why? It seems crazy to me, the Rx should be giving the same signal to the esc, but maybe not ?
Sign up now
to remove ads between posts
Sep 17, 2011, 09:49 PM
I don't want to "Switch Now"
pmackenzie's Avatar
Make sure the FrSky reciever is not in "High Speed" mode.
The LED should flash slowly if you turn on the receiver without turning on the transmitter. If it flashes quickly then press the bind button for 3 seconds to change modes.

(This assumes you are using a D8 telemetry receiver)

Pat MacKEnzie
Sep 19, 2011, 01:22 AM
Sudden Freak
c2po's Avatar
Quote:
Originally Posted by rotagen
Anyone know why? It seems crazy to me, the Rx should be giving the same signal to the esc, but maybe not ?
Probably because old FM receivers usually output 5V PWM signal, and FrSky receiver has 3.3V PWM output (as also many other modern receivers).
I bet your brushed ESC doesn't like it. Look here for more info.
Sep 19, 2011, 06:05 PM
Suspended Account
Old brushed ESC was probably made to match old FM receiver.

Just stay with old FM radio.

To fly with 2.4, change motor and ESC to modern brushless.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! Blade SR120 - main motor not working ulogix Electric Heli Talk 4 Apr 24, 2011 04:07 PM
Help! Syma S006 front motor not working helimark112052 Coaxial Helicopters 2 Mar 07, 2011 04:18 PM
Help! ESC not working with Futaba Receiver. ovajay Power Systems 10 Oct 07, 2006 08:25 AM
electrifly receiver with 30a esc not working need help maeu2003 Radios 4 Jul 16, 2004 04:47 PM