Can't get Guardian to work - RC Groups
Shop our Airplanes Products Drone Products Sales
Thread Tools
Aug 30, 2011, 11:12 PM
Registered User
Tony97's Avatar
Help!

Can't get Guardian to work


I installed the guardian today. Light blinks, servo display and art. horizon all work. I ran setup wizard too. The Guardian isn't on or working. No "G" on the screen. What am I missing? I tried different switch settings too like AUX1 & AUX2, AUX1 3 position, etc. No luck. Thought was my AUX2 switch. Moved to gear switch. No luck. HELP.
Sign up now
to remove ads between posts
Aug 30, 2011, 11:36 PM
I should be flying right now!
al1242's Avatar
Did you go into the Configure radio menu and turn on the guardian under "Stabilization/Elevon mixing on"? It is kind of confusing but that must be "yes" and make sure wing type is standard(if it is a normal plane)


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion PARIS v4.0 board. Can't get it to work. Kyle D. Multirotor Drone Talk 28 Dec 25, 2011 10:15 PM
Discussion Can't get Co-Pilot II Display to work on Vista 64bit system ozsteel FMA Direct 1 Aug 15, 2011 09:44 AM
Help! Just can't get this loft to work (SW2010) ICU CAD/CAM 12 Jul 12, 2011 10:15 PM
Discussion Can't get Trainer function to work on Futaba 6EXA FlyValue Radios 2 May 17, 2011 03:32 AM
Question Can't get the Field Link programmer to work DonDuc Castle Creations 3 Mar 28, 2011 11:58 AM