Lumenier RB2205C-12 2400KV SKITZO Ceramic Bearing Motor
Thread Tools
Old Aug 19, 2011, 09:44 AM
charles1956 is offline
Find More Posts by charles1956
Registered User
Discussion

Hacker USB interface programmer


Hi,
I am unable to get the computer to recognise the device. Have tried a windows 7 computer, even dug out the old vista machine. A friend had an old XP machine which worked with it, but he has now got rid of the computer. Have tried the hacker website.... It may be something to do with setting the correct com port. Help anyone?
Sign up now
to remove ads between posts
Old Aug 20, 2011, 12:36 PM
charles1956 is offline
Find More Posts by charles1956
Registered User

more info on problem


The program installs off the cd, or off the Hacker website. But the program doer not recognise the usb device or the sc. The indicators stay red on the control panel. The lights on the usb device are sometimes red and sometimes green.

Any help anyone?
Old Aug 20, 2011, 10:00 PM
FL62 is offline
Find More Posts by FL62
Average Joe 2 Semi-Pro n Back!
FL62's Avatar
Charles,
Do you have a version 2 programmer, or a version 1? It will say on the label on the USB device.

Also, are you running a 32bit or 64bit version of windows?

Mike
Old Aug 23, 2011, 07:50 AM
charles1956 is offline
Find More Posts by charles1956
Registered User
Hello Mike,
Thanks for the response.
The version is #two
Windows 64 bit
The hobbyshop has just sent me another one. I have yet to try connecting the sc as I am at work. What I notice though is that the little interface recognises when the software is switched on or off (green/red light) however the software does not.
Everytime I start the software the Norton antivirus has a fit saying that this unknown blah blah is trying to make changes to my computer. I tell it it is OK and it loads. I tried disabling the firewall and antivirus, but this message still comes up on loading the program.
Tonight I will try the new one again.
Charles
Old Sep 01, 2011, 01:28 PM
FL62 is offline
Find More Posts by FL62
Average Joe 2 Semi-Pro n Back!
FL62's Avatar
Charles,
Any luck on this one?

Let us know if we can help!

Thanks
Mike
Old Sep 22, 2011, 08:09 PM
FlySwatter is offline
Find More Posts by FlySwatter
Registered User
I am having the same problem. I think it has to do with the driver. If anyone can offer ideas I would appreciate it.
Old Sep 26, 2011, 10:28 PM
c-182 is offline
Find More Posts by c-182
RC Addiction
c-182's Avatar
Quote:
Originally Posted by FlySwatter View Post
I am having the same problem. I think it has to do with the driver. If anyone can offer ideas I would appreciate it.
Ditto....me too
Old Oct 20, 2011, 10:39 AM
russ skinner is offline
Find More Posts by russ skinner
Registered User
Same issue for me - Hacker X-Pro-USB Interface ver1 will not work with Windows 7.

I have installed the latest Silicon Labs driver, Ver 2.6, and the computer recognises the interface - green light on adapter lights - but Hacker software will not detect it. I have also tried downloading the ver 2 software from the Hacker website, but this also fails to work.

Just wondered has anyone managed to get the version 1 adaptor working with Windows 7?
Old Jan 15, 2012, 02:00 PM
7oneWo1f is offline
Find More Posts by 7oneWo1f
AMF Years
7oneWo1f's Avatar
I had the same problem, and I found a solution. I have a pretty good idea what the problem is. I will share the solution (work around) with anybody who doesn't work for hacker and who agrees to not publish the solution on the internet.

The reason I won't publish it is because I am sick of companies expecting free alpha and beta testing of their customers. Until hacker fixes the problem, I do not recommend their ESCs if you want to program them on the computer.

I do this kind of troubleshooting in my line of work from time to time. Hacker can pay me for the information, because I don't work for free for for-profit companies. I'll take a power 25 setup for the information.
Old Jan 15, 2012, 03:09 PM
FL62 is offline
Find More Posts by FL62
Average Joe 2 Semi-Pro n Back!
FL62's Avatar
The Problem is that the software CD auto installs the wrong version of the driver. The original version of the Hacker USB programmer was not compatible with 64bit operating systems. The new one is, however it auto-installs the wrong driver. It can be fixed very simply after installing by doing these steps:

Goto you device manager and scroll down the hardware list to the "ports" section. -> select the "Silicon labs CP210x..." (you must have the USB Cable and adapter plugged in to see this) item and then RIGHT CLICK your mouse on this selection -> when the menu pops up, select "Update Driver".

This will launch the update driver wizard. On the first screen, select "Browse my computer for driver software", then on the following screen, select "Let me pick from a list of device drivers on my computer".

It will then show you a list of compatible drivers. There are two listed by default, one with a driver date of January 2011, and an older one listed with a 2009 date.

Select the OLDER of the two drivers, and hit OK.

You may have to re-boot your computer, but this will fix the issue.

When you open the Hacker software, you should now get a green light next to the "USB" at the bottom of the software. If you are still getting a red light next to "ESC" after it's plugged in to the programmer, you may need to plug in a flight battery into the ESC. This is common on OPTO ESC's as they don't have an onboard power source.

N6145K - please take your so-called "Help" elsewhere - your post does absolutely nothing to help the situation!
Old Jan 15, 2012, 03:24 PM
7oneWo1f is offline
Find More Posts by 7oneWo1f
AMF Years
7oneWo1f's Avatar
It got you to post a solution, which I assume you think is helfpul.

I think it is helpful to some, but to others, who don't have time to spend searching for a solution to a system that is supposed to be plug and play and easy to use, it is not useful.

It is more useful to shame hacker into doing some QA.


Too bad Hacker's not doing QA on their software. You're not helping.
Last edited by 7oneWo1f; Jan 15, 2012 at 04:41 PM.
Old Jan 16, 2012, 12:01 PM
JK13 is offline
Find More Posts by JK13
Goes to eleven!
JK13's Avatar
Quote:
Originally Posted by N6145k View Post
It got you to post a solution, which I assume you think is helfpul.

I think it is helpful to some, but to others, who don't have time to spend searching for a solution to a system that is supposed to be plug and play and easy to use, it is not useful.

It is more useful to shame hacker into doing some QA.


Too bad Hacker's not doing QA on their software. You're not helping.
Solution did not work!
Changed drivers to older version and same result-
Hacker needs to step-up here??
Any other ideas?
Thanks,

Joe
Old Jan 16, 2012, 12:48 PM
russ skinner is offline
Find More Posts by russ skinner
Registered User
Quote:
Originally Posted by FL62 View Post
The Problem is that the software CD auto installs the wrong version of the driver. The original version of the Hacker USB programmer was not compatible with 64bit operating systems. The new one is, however it auto-installs the wrong driver. It can be fixed very simply after installing by doing these steps:

Goto you device manager and scroll down the hardware list to the "ports" section. -> select the "Silicon labs CP210x..." (you must have the USB Cable and adapter plugged in to see this) item and then RIGHT CLICK your mouse on this selection -> when the menu pops up, select "Update Driver".

This will launch the update driver wizard. On the first screen, select "Browse my computer for driver software", then on the following screen, select "Let me pick from a list of device drivers on my computer".

It will then show you a list of compatible drivers. There are two listed by default, one with a driver date of January 2011, and an older one listed with a 2009 date.

Select the OLDER of the two drivers, and hit OK.

You may have to re-boot your computer, but this will fix the issue.

When you open the Hacker software, you should now get a green light next to the "USB" at the bottom of the software. If you are still getting a red light next to "ESC" after it's plugged in to the programmer, you may need to plug in a flight battery into the ESC. This is common on OPTO ESC's as they don't have an onboard power source.

N6145K - please take your so-called "Help" elsewhere - your post does absolutely nothing to help the situation!
Thanks for the posting FL62, but unfortunately this did not work for me either. There's a green light on the adaptor, but program window (ver2) still shows a red light for the USB even after reboot. Looks like a software issue to me.

Any thoughts?
Last edited by russ skinner; Jan 16, 2012 at 12:51 PM. Reason: more info
Old Jan 17, 2012, 01:23 AM
JK13 is offline
Find More Posts by JK13
Goes to eleven!
JK13's Avatar
Quote:
Originally Posted by JK13 View Post
Solution did not work!
Changed drivers to older version and same result-
Hacker needs to step-up here??
Any other ideas?
Thanks,

Joe
I did not get the green light-

Joe
Old Jan 28, 2012, 09:27 AM
easttxsrt8 is offline
Find More Posts by easttxsrt8
Registered User
easttxsrt8's Avatar
Still can't get mine to work and can't get a response from Hacker. This is irritating for somebody running mostly Hacker products. I run Castle motors and esc's in my SC trucks and I have never had problems with their software(castle link). Looks like I'll be switching to Castle esc's in the future for my planes also.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
For Sale Mark of the Unicorn (MOTU) FastLane USB Midi Interface rz22g Non R/C Items (FS/W) 1 Aug 04, 2011 11:49 AM
For Sale JR Data transfer CD program & USB interface ptxman Aircraft - General - Radio Equipment (FS/W) 3 Jul 22, 2011 03:29 PM
Wanted Hacker Brushless USB programmer J_Dogg Aircraft - Electric - Power Systems (FS/W) 0 Apr 05, 2011 10:49 AM
For Sale Hacker X-80 Opto Pro ESC and USB programming interface brwilkins Aircraft - Electric - Power Systems (FS/W) 2 Apr 01, 2011 01:27 PM
For Sale Hacker X-70 Opto Pro ESC & USB interface Photoship One Aircraft - Electric - Power Systems (FS/W) 0 Aug 04, 2006 11:39 AM