Brand-New DX8 Won't Hold a Charge - RC Groups
Thread Tools
Aug 19, 2011, 08:14 AM
Registered User
Question

Brand-New DX8 Won't Hold a Charge


Hi there,

Got my brand-new DX8 and charged it up overnight. Everything was great setting up my new 3DHS Edge, so it was on for maybe about an hour - if that. Go to use it today to set up my quad and the battery is down to 3.4v and the alarm sounds.

It was definitely switched off, so that isn't the cause. Also when I turn it on, it kinda "blips" and then turns on properly. Is this normal?

TIA
Sign up now
to remove ads between posts
Aug 19, 2011, 08:32 AM
AndyKunz's Avatar
Did you charge it overnight before starting? The batteries come with only partial charge.

Andy
Aug 19, 2011, 09:23 AM
Registered User
Quote:
Originally Posted by banzi28
Got my brand-new DX8 and charged it up overnight.
Yes I did.
Aug 19, 2011, 09:34 AM
AndyKunz's Avatar
I would call Support and tell them. You'll probably get a new battery.

Andy
Aug 19, 2011, 09:47 AM
Registered User
Many thanks Andy,

I'll give them a call when they open.
Aug 19, 2011, 10:21 AM
Suspended Account
Recycle battery a couple of times and see if it comes to life. It may have been sleeping too long.
Aug 19, 2011, 10:23 AM
Registered User
Quote:
Originally Posted by John Kim
Recycle battery a couple of times and see if it comes to life. It may have been sleeping too long.
I was just thinking of doing this with the cycle mode on my charger. Just don't have the correct cable.
Aug 19, 2011, 10:24 AM
60 years of RC flying
Daedalus66's Avatar
Quote:
Originally Posted by John Kim
Recycle battery a couple of times and see if it comes to life. It may have been sleeping too long.
Good idea. But if it does come to life treat with care. Sometimes they die again. I would call Horizon anyway.
Aug 19, 2011, 10:44 AM
Registered User
They want me to leave it on the charger until the blue light goes out again.
Aug 19, 2011, 10:59 AM
Surface, Air & Water Rc Toys..
freechip's Avatar
Quote:
Originally Posted by banzi28
I was just thinking of doing this with the cycle mode on my charger. Just don't have the correct cable.
Using a servo extension and removing the case around the end with the pins works perfectly. The end spacing is the correct one for the stock battery connector. Just be careful to double check the polarity.
Aug 19, 2011, 11:04 AM
AndyKunz's Avatar
Quote:
Originally Posted by banzi28
They want me to leave it on the charger until the blue light goes out again.
The blue light will not go out with a NiMH pack installed. It only goes out on LiPo packs.

Charge it for 10-12 hours, then see how it does. You should see a rapid drop from the start voltage (5.3-5.6V) down to a level around 5.0V, then it will take "forever" to drop down to 4.5V.

Andy
Aug 19, 2011, 11:10 AM
Registered User
You're kidding me? So the bloody support guy was wrong?

I'll try charging it one more time and then call them back if it doesn't hold a charge. One thing I did notice is that the battery icon bar is only at 50%.
Aug 19, 2011, 11:23 AM
Surface, Air & Water Rc Toys..
freechip's Avatar
Normal for the battery bar graph to show that because its also used for the lipo battery. The bar will be full with a fully charged 8.4v 2s lipo.
Aug 19, 2011, 11:24 AM
AndyKunz's Avatar
Quote:
Originally Posted by banzi28
You're kidding me? So the bloody support guy was wrong?
Don't you just hate humans?!?!?

The LiPo batteries have been so overwhelmingly popular he probably forgot the difference between NiMH and LiPo behavior on the LED.

Andy
Aug 19, 2011, 11:25 AM
Registered User
For the love of...

Is there a direct number for Spektrum support, or is it handled all by Horizon?


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion New E-Flite 3S 11.1V 3200mAh Lipo - "Low Voltage" Won't Charge? itsme2 Batteries and Chargers 4 Oct 16, 2014 06:07 PM
Discussion 6-cell NiMH 900 mAh won't hold much charge Wormwood Batteries and Chargers 4 Apr 04, 2007 04:22 PM
Help! Batt won't hold charge bizzo Batteries and Chargers 12 Aug 24, 2006 12:38 PM
Why won't my brand new NiMH Aerohawk batteries charge correctly? ucsdgemini Batteries and Chargers 14 Mar 13, 2004 08:21 PM
CP1300s won't hold a charge mumblety-peg Power Systems 7 Jan 16, 2002 12:25 PM