Thread Tools
Dec 30, 2011, 11:50 AM
Registered User

Y6 uneven yaw


I built a Y6 and tested the frame with a CC board. Flew fine. I swapped over the WK but yaw is *very* biased in the CW direction. It will yaw 2x-3x faster CW than CCW. CCW is so slow as to be almost unflyable. It also wants a lot of left rudder trim just to keep from spinning. I didn't have this problem with an X8.

I can only theorize that the CCW motors (top motors) are spinning faster than the lowers, thereby causing the torque bias. But don't know why.
Sign up now
to remove ads between posts
Dec 30, 2011, 11:56 AM
OS Sponsor
kinderkram's Avatar
Quote:
Originally Posted by chris24g
I built a Y6 and tested the frame with a CC board. Flew fine. I swapped over the WK but yaw is *very* biased in the CW direction. It will yaw 2x-3x faster CW than CCW. CCW is so slow as to be almost unflyable. It also wants a lot of left rudder trim just to keep from spinning. I didn't have this problem with an X8.

I can only theorize that the CCW motors (top motors) are spinning faster than the lowers, thereby causing the torque bias. But don't know why.
Did you calibrate the mag after swapping the brains? And: does it do this also in manual mode?
You also should try to calibrate your ESCs again.
Dec 30, 2011, 11:56 AM
Registered User
Hey guys, I've been following this forum for a while. They should just have an infinity symbol for the last page. It'll never end. ;-)
I have a software assistant question. I currently am running windows xp 32bit in "Parallel"
on my Mac. Will the software Assistant and Driver work with this setup or do I need to come across the waters and have a "actual" PC running Windows? I was thinking I'd get a head start and enter some settings in to the software Prior to having my y6 delivered to me. I read in the manual the installation procedure. Obviously I didn't connect to the copter first, as i don't have it yet. I did install the driver first though but I'm not sure it worked because of the Mac thing??. I noticed that many of the tools along the menu bar in the assistant were greyed out. inport/export, read/write, and tools. I know someone has dealt with this already but i can't remember the resolution. I'd appreciate any insight from such a knowledgeable forum :-p
thanks,
matt
Dec 30, 2011, 12:01 PM
Registered User
llbr22's Avatar
Quote:
Originally Posted by matthewlavin
Hey guys, I've been following this forum for a while. They should just have an infinity symbol for the last page. It'll never end. ;-)
I have a software assistant question. I currently am running windows xp 32bit in "Parallel"
on my Mac. Will the software Assistant and Driver work with this setup or do I need to come across the waters and have a "actual" PC running Windows? I was thinking I'd get a head start and enter some settings in to the software Prior to having my y6 delivered to me. I read in the manual the installation procedure. Obviously I didn't connect to the copter first, as i don't have it yet. I did install the driver first though but I'm not sure it worked because of the Mac thing??. I noticed that many of the tools along the menu bar in the assistant were greyed out. inport/export, read/write, and tools. I know someone has dealt with this already but i can't remember the resolution. I'd appreciate any insight from such a knowledgeable forum :-p
thanks,
matt
Maybe this will help. turns out I asked this same question not too long ago:
http://www.multirotorforums.com/show...tware-on-a-Mac
Dec 30, 2011, 12:09 PM
Registered User
Quote:
Originally Posted by kinderkram
Did you calibrate the mag after swapping the brains?
Yes

Quote:
And: does it do this also in manual mode?
and yes

Quote:
You also should try to calibrate your ESCs again.
hmm, I'm using simonk escs, is there a calibration procedure for those?
Dec 30, 2011, 12:09 PM
Registered User
Somebody posted a link the Assistant software 1.11 does anybody have that link as well as the 4.0 firmware. I would appreciate it.

Thanks, Michael64
Dec 30, 2011, 12:16 PM
OS Sponsor
kinderkram's Avatar
Quote:
Originally Posted by matthewlavin
I noticed that many of the tools along the menu bar in the assistant were greyed out. inport/export, read/write, and tools. I know someone has dealt with this already but i can't remember the resolution. I'd appreciate any insight from such a knowledgeable forum :-p
thanks,
matt
If you're using bootcamp it should work. The menus are grey because you didn't connect. Once you have a WKM you'll see...
Dec 30, 2011, 12:18 PM
Registered User
Hey llbr, Yep, good info:-)

I wonder if it is Parallels?? Anyways, is my software acting this way because the copter isn't hooked up yet or something else??

Before i change systems,
I guess i could wait a few days to get the copter plug it in and see if i have the same issue. You know how hard it is to wait and i want to get a jump on things if i have to change computers are something like that.
best,
matt
Dec 30, 2011, 12:20 PM
OS Sponsor
kinderkram's Avatar
Quote:
Originally Posted by Michael64
Somebody posted a link the Assistant software 1.11 does anybody have that link as well as the 4.0 firmware. I would appreciate it.

Thanks, Michael64
Here you go: http://www.mediafire.com/?tpuqtyckong316q
Dec 30, 2011, 12:23 PM
Registered User
Quote:
Originally Posted by kinderkram
If you're using bootcamp it should work. The menus are grey because you didn't connect. Once you have a WKM you'll see...
Hmmm I'm using Parallels??
Dec 30, 2011, 12:54 PM
Registered User
kinderkram
Thanks for the link

Michael64
Dec 30, 2011, 12:54 PM
Registered User
Is there a Y6 mixer table posted?
I timed my yaw rates and it takes 10sec to piro CCW and 3 sec for CW.

Gonna be a long day/night.

Worst case, I will put the CC back on to verify the running gear is functioning correctly.
Dec 30, 2011, 01:02 PM
Registered User
llbr22's Avatar
Quote:
Originally Posted by chris24g
Is there a Y6 mixer table posted?
I timed my yaw rates and it takes 10sec to piro CCW and 3 sec for CW.

Gonna be a long day/night.

Worst case, I will put the CC back on to verify the running gear is functioning correctly.
wow! that's a huge difference in timing! I've never setup a Y6, but am curious what the problem may be.
Dec 30, 2011, 01:10 PM
Registered User
Quote:
Originally Posted by llbr22
wow! that's a huge difference in timing! I've never setup a Y6, but am curious what the problem may be.
I recalibrated my Tx in the WK Assistant and it helped a bit. CCW is down to 6 sec, but CW is still 2x faster. I'm running 4.2, but I don't see any release notes on y6 issues so I'm debating on whether it's worth it.
Dec 30, 2011, 02:13 PM
Part 107 certified pilot
RTRyder's Avatar
Quote:
Originally Posted by chris24g
I recalibrated my Tx in the WK Assistant and it helped a bit. CCW is down to 6 sec, but CW is still 2x faster. I'm running 4.2, but I don't see any release notes on y6 issues so I'm debating on whether it's worth it.
If you're running with reflashed ESCs it's likely a timing difference between the clockwise and counterclockwise ESCs. I ran into that same issue with the Droidworx AD6 I just converted from MK to a WKM controller. In this case the counterclockwise motors would start before the clockwise and while I could get it to fly a bit there were other related issues that made it impossible to use the reflashed ESCs. The odd thing is I have a set of the exact same ESCs reflashed with the same firmware that work perfectly on my CineStar 6 with WKM, the second set I could not get to work right with any version of firmware I tried...

Solution? I have a new set of ESCs on the way for the AD6. The set that is having problems have 4 that are synch'd enough to use together so I guess I'll be building a quad that needs 30A ESCs...


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Ballistic Recovery System for Multirotors Duck! Aerial Photography 66 Nov 13, 2015 04:37 PM
Discussion DJI - WooKong eStab for Scale sidneyw Scale Helicopters 97 Dec 30, 2012 10:48 AM
Discussion FY3ZT Autopilot for Aerial Photography feiyudz Aerial Photography 116 May 07, 2012 04:58 PM
Discussion DJI AceOne autopilot for sale... hazchem88 Aerial Photography 4 Mar 31, 2011 03:54 AM
Discussion DJI Innovation helicopter autopilot XP.3.1 for European customers JoelT Aerial Photography 2 Sep 24, 2009 11:43 AM