Thread Tools
Feb 10, 2013, 02:30 PM
Some.. call him Tim...
Ducati Mechanic's Avatar
Quote:
Originally Posted by ecaa3d View Post
Go for it....I'm thinking old V1, everyone else running the v2 around here is still using the 15x6. I don't know why.

I use 16x8 Carbon Cam on 5s Hacker setup. I wouldn't trade it.
Quote:
Originally Posted by bryansifsof44 View Post
I use the 4315-480 with a 16x8 on 6s and wouldn't have it any other way.
15x6 or 15x7 xoar are the correct props for the 4016t/500 V1(always check your amp draw)

The new 4016/t500MKII can swing from a 15x7 up to a 16x8zoar. 16x8 apc is not Recommended due to its higher amp draw.

I personally run a 15x7 xoar with a V1 in the extra, and a 16x8 xoar (64" MXS) with the MKII. If I was running the v2 motor in the 60" extra, I would probably run a 15x8-15x9.
Last edited by Ducati Mechanic; Feb 10, 2013 at 02:40 PM.
Sign up now
to remove ads between posts
Feb 10, 2013, 02:42 PM
Registered User
I just picked up a new V2 so I now have a V1 and V2. Just wondering

-Are you running the 16x8 on 6s with the V2?
-with the 16x8 would be better in the extra or edge i have. I need one to crash before getting the MXS haha.

Thinking bigger prop on the Edge for 3d.


Quote:
Originally Posted by Ducati Mechanic View Post
15x6 up to 15x8 xoar are the correct props for the 4016t/500 V1

The new 4016/t500MKII can swing from a 15x7 up to a 16x8zoar. 16x8 apc is not Recommended due to its higher amp draw.

I personally run a 15x8 xoar with a V1 the extra, and a 16x8 xoar with my 64" MXS. If I was running the v2 motor in the 60" extra, I would probably run a 15x8-15x9.
Feb 10, 2013, 02:45 PM
bryansifsof44's Avatar
Quote:
Originally Posted by Ducati Mechanic View Post
15x6 or 15x7 xoar are the correct props for the 4016t/500 V1(always check your amp draw)

The new 4016/t500MKII can swing from a 15x7 up to a 16x8zoar. 16x8 apc is not Recommended due to its higher amp draw.

I personally run a 15x7 xoar with a V1 in the extra, and a 16x8 xoar (64" MXS) with the MKII. If I was running the v2 motor in the 60" extra, I would probably run a 15x8-15x9.
That's what I thought. For the Extra I most likely will be using a 16x8 PJN but will try the 15x10 PJN.
Feb 10, 2013, 02:46 PM
Some.. call him Tim...
Ducati Mechanic's Avatar
I made some corrections to my top number you guys are too fast for me

Yes 16 x 8 xoar on 6s with the v2 mkII, but not a apc, and 15x7 xoar on 6s v1 motor. You should only go up to 15x8 xoar with the v1 if your amp, and watt draw allow it.



Quote:
Originally Posted by Ducati Mechanic View Post
15x6 or 15x7 xoar are the correct props for the 4016t/500 V1(always check your amp draw)

The new 4016/t500MKII can swing from a 15x7 up to a 16x8zoar. 16x8 apc is not Recommended due to its higher amp draw.

I personally run a 15x7 xoar with a V1 in the extra, and a 16x8 xoar (64" MXS) with the MKII. If I was running the v2 motor in the 60" extra, I would probably run a 15x8-15x9.
Last edited by Ducati Mechanic; Feb 10, 2013 at 02:53 PM.
Feb 10, 2013, 02:57 PM
Registered User
what about 15x8 aeronaut on v1?
Feb 10, 2013, 10:39 PM
Some.. call him Tim...
Ducati Mechanic's Avatar
Quote:
Originally Posted by ecaa3d View Post
Go for it....I'm thinking old V1, everyone else running the v2 around here is still using the 15x6. I don't know why.

I use 16x8 Carbon Cam on 5s Hacker setup. I wouldn't trade it.
Quote:
Originally Posted by rimaarts View Post
what about 15x8 aeronaut on v1?
Probably to much prop on 6s. Cf Props Draw notoriously high amperage, Due to the fact that they don't flex much, But I wouldn't know until I put it on a wattmeter.

Most of us stick with xoar, because of the softer amp draw. Be careful not to overtax that motor! I never went over 15x7 xoar with my v1 motors.

Ideally you want around 1450 Watt at around 60amp on 6s with the V1. On 5s your amperage will be closer to 70amp, and usually around 1200watt.

The hacker is a great motor on 5s. I had one in my edge. It's KV is a bit higher so it really go's! I bet that setup works nicely!
Last edited by Ducati Mechanic; Feb 10, 2013 at 10:51 PM.
Feb 11, 2013, 12:05 AM
aka ECAA3D
m0dest's Avatar
Quote:
Originally Posted by Ducati Mechanic View Post
Probably to much prop on 6s. Cf Props Draw notoriously high amperage, Due to the fact that they don't flex much, But I wouldn't know until I put it on a wattmeter.

Most of us stick with xoar, because of the softer amp draw. Be careful not to overtax that motor! I never went over 15x7 xoar with my v1 motors.

Ideally you want around 1450 Watt at around 60amp on 6s with the V1. On 5s your amperage will be closer to 70amp, and usually around 1200watt.

The hacker is a great motor on 5s. I had one in my edge. It's KV is a bit higher so it really go's! I bet that setup works nicely!

It does. It's Steve McQueen proof too.
Feb 11, 2013, 10:28 AM
Some.. call him Tim...
Ducati Mechanic's Avatar
Nice!
Feb 14, 2013, 12:48 PM
Registered User
nofreee's Avatar
When anybody has a free moment, would you mind taking some measurements of the tail for me? Trying to see if I can stuff one of these into my car.

Total height of the tail including the landing gear and the elevator width would be great.

Thanks!
Feb 14, 2013, 01:28 PM
2.3 D Hack Bradenton FL
frankjp's Avatar
Quote:
Originally Posted by nofreee View Post
When anybody has a free moment, would you mind taking some measurements of the tail for me? Trying to see if I can stuff one of these into my car.

Total height of the tail including the landing gear and the elevator width would be great.

Thanks!
14 1/8th" High and 24" wide
Feb 14, 2013, 01:39 PM
Registered User
nofreee's Avatar
Quote:
Originally Posted by frankjp View Post
14 1/8th" High and 24" wide
Greatly appreciated!
Feb 14, 2013, 07:28 PM
This is BAT country!
Gonzo 1971's Avatar
Mine fits in the backseat of my G6 with no problem. Just for reference.
Feb 14, 2013, 09:51 PM
Thumbs in training
ryyoungs's Avatar
Quote:
Originally Posted by ryyoungs View Post
I have a JR ds3421 servo on the elevator of 60" extra that will jitter when I hold it steady at any given point, but doesn't do it all the time and not always at the same position. This is on the bench and not under load. I never noticed it before, I've only had the plane for 2 months with 15 flights on it, and am wondering if this is normal and once under load it will be fine?
I just heard from Horizon Hobby today and they were not able to find anything wrong with the servo. I guess there was a recall on some DX8 gimbals, but mine wasn't one of them. He said depending on the receiver I'm using sometimes when you set the frame rate to 22ms it can cause this issue. Needless to say my issue isn't solved. The rep from Horizon Hobby said he's going to send back the servo and after I have it installed to call him and see if we can't trouble shoot it over the phone.

Even thou my issue hasn't been solved yet I am happy with the service from Horizon Hobby up to this point.
Feb 14, 2013, 11:22 PM
aka ECAA3D
m0dest's Avatar
You can try an RF filter ring. Sucks that they aren't replacing it though.
Feb 14, 2013, 11:36 PM
Thumbs in training
ryyoungs's Avatar
Quote:
Originally Posted by ecaa3d View Post
You can try an RF filter ring. Sucks that they aren't replacing it though.
Thanks for the suggestion. I'll wait to see what kind of troubleshooting they run me through before I go trying things on my own. I'm hopeful in the end I will have a working servo.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Build Log Extreme Flight 70" Extra 300 EXP - build/fly/video hercdriver7777 3D Flying 2637 Oct 16, 2016 05:20 PM
Build Log Extreme Flight 60" Edge 540T EXP - Build/Fly/Video FlopGun 3D Flying 249 Apr 16, 2012 10:46 AM
Help! D-60 build thread Chronic DS'er Dynamic Soaring 3 Jun 23, 2011 10:04 PM
Sold Extreme Flight 58" Extra Ready To Fly (GA) traderdave2 Aircraft - Electric - Airplanes (FS/W) 11 Apr 26, 2011 05:33 PM
Video EXTREME FLIGHT RC EXTRA 300EXP in Action! EXTREME FLIGHT Electric Plane Talk 1 Jun 10, 2009 08:45 PM