Completely lost.. - RC Groups
Shop our Airplanes Products Drone Products Sales
Thread Tools
Jul 24, 2011, 06:18 PM
Registered User
AlexnderH's Avatar

Completely lost..

Just assembeled my multiwii tricopter exactly as the wiring diagram on

I've set my dx6i travel adjusts all to 125% and set it to acro (airplane)

components used:

Arduino pro mini 5v 16mhz
Orange RX
Turnigy plush 18
Original WM+
Programming with the sparkfun ftdi usb
Windows pc

I've loaded the multiwii software (1.7) 3 times to the arduino, each time it has loaded fine. (the board has also been tested with blink etc.)

The board will not arm. When i plug the flight battery in the green LED flashes very quickly once (maybe twice) and then stays OFF. I cannot arm the board. I've reversed the throttle and yaw and tried every combination of stick positions and cannot get that little green L.E.D to light up.

If i connect the arduino to the pc and run the multiwii config, i select the com port (theres only the one), and then click start and absoloutely nothing happens. I've tried reconnecting it with the flight battery connected and still no change.

Very frustrated and confused.

Any help much appreciated

Here is the configurable section of the code that i have uploaded. All i have changed is #define MINTHROTTLE 1300 as im using turnigys.

/* Set the minimum throttle command sent to the ESC (Electronic Speed Controller)
This is the minimum value that allow motors to run at a idle speed */
#define MINTHROTTLE 1300 // for Turnigy Plush ESCs 10A
//#define MINTHROTTLE 1120 // for Super Simple ESCs 10A
//#define MINTHROTTLE 1190

/* The type of multicopter */
//#define GIMBAL
//#define BI
#define TRI
//#define QUADP
//#define QUADX
//#define Y4
//#define Y6
//#define HEX6
//#define HEX6X
//#define FLYING_WING //experimental

#define YAW_DIRECTION 1 // if you want to reverse the yaw correction direction
//#define YAW_DIRECTION -1

#define I2C_SPEED 100000L //100kHz normal mode, this value must be used for a genuine WMP
//#define I2C_SPEED 400000L //400kHz fast mode, it works only with some WMP clones

#define PROMINI //Arduino type
//#define MEGA

//enable internal I2C pull ups

//****** advanced users settings *************

/* Failsave settings - added by MIS
Failsafe check pulse on THROTTLE channel. If the pulse is OFF (on only THROTTLE or on all channels) the failsafe procedure is initiated.
After FAILSAVE_DELAY time of pulse absence, the level mode is on (if ACC or nunchuk is avaliable), PITCH, ROLL and YAW is centered
and THROTTLE is set to FAILSAVE_THR0TTLE value. You must set this value to descending about 1m/s or so for best results.
This value is depended from your configuration, AUW and some other params.
Next, afrer FAILSAVE_OFF_DELAY the copter is disarmed, and motors is stopped.
If RC pulse coming back before reached FAILSAVE_OFF_DELAY time, after the small quard time the RC control is returned to normal.
If you use serial sum PPM, the sum converter must completly turn off the PPM SUM pusles for this FailSafe functionality.*/
#define FAILSAFE // Alex: comment this line if you want to deactivate the failsafe function
#define FAILSAVE_DELAY 10 // Guard time for failsafe activation after signal lost. 1 step = 0.1sec - 1sec in example
#define FAILSAVE_OFF_DELAY 200 // Time for Landing before motors stop in 0.1sec. 1 step = 0.1sec - 20sec in example
#define FAILSAVE_THR0TTLE (MINTHROTTLE + 200) // Throttle level used for landing - may be relative to MINTHROTTLE - as in this case

/* The following lines apply only for a pitch/roll tilt stabilization system
It is not compatible with Y6 or HEX6 or HEX6X
Uncomment the first line to activate it */
//#define SERVO_TILT
#define TILT_PITCH_MIN 1020 //servo travel min, don't set it below 1020
#define TILT_PITCH_MAX 2000 //servo travel max, max value=2000
#define TILT_PITCH_MIDDLE 1500 //servo neutral value
#define TILT_PITCH_PROP 10 //servo proportional (tied to angle) ; can be negative to invert movement
#define TILT_ROLL_MIN 1020
#define TILT_ROLL_MAX 2000
#define TILT_ROLL_MIDDLE 1500
#define TILT_ROLL_PROP 10

/* I2C gyroscope */
//#define ITG3200
//#define L3G4200D

/* I2C accelerometer */
//#define ADXL345
//#define BMA020
//#define BMA180
//#define NUNCHACK // if you want to use the nunckuk as a standalone I2C ACC without WMP

/* I2C barometer */
//#define BMP085

/* I2C magnetometer */
//#define HMC5843
//#define HMC5883

/* ADC accelerometer */ // for 5DOF from sparkfun, uses analog PIN A1/A2/A3
//#define ADCACC

/* The following lines apply only for specific receiver with only one PPM sum signal, on digital PIN 2
Select the right line depending on your radio brand. Feel free to modify the order in your PPM order is different */

/* interleaving delay in micro seconds between 2 readings WMP/NK in a WMP+NK config
if the ACC calibration time is very long (20 or 30s), try to increase this delay up to 4000
it is relevent only for a conf with NK */

/* for V BAT monitoring
after the resistor divisor we should get [0V;5V]->[0;1023] on analog V_BATPIN
with R1=33k and R2=51k
vbat = [0;1023]*16/VBATSCALE */
#define VBAT // comment this line to suppress the vbat code
#define VBATSCALE 131 // change this value if readed Battery voltage is different than real voltage
#define VBATLEVEL1_3S 107 // 10,7V
#define VBATLEVEL2_3S 103 // 10,3V
#define VBATLEVEL3_3S 99 // 9.9V

/* when there is an error on I2C bus, we neutralize the values during a short time. expressed in microseconds
it is relevent only for a conf with at least a WMP */
#define NEUTRALIZE_DELAY 100000

/* this is the value for the ESCs when thay are not armed
in some cases, this value must be lowered down to 900 for some specific ESCs */
#define MINCOMMAND 1000

/* this is the maximum value for the ESCs at full power
this value can be increased up to 2000 */
#define MAXTHROTTLE 1850

/* This is the speed of the serial interface. 115200 kbit/s is the best option for a USB connection.*/
#define SERIAL_COM_SPEED 115200

/* In order to save space, it's possibile to desactivate the LCD configuration functions
comment this line only if you don't plan to used a LCD */
#define LCD_CONF

/* to use Cat's whisker TEXTSTAR LCD, uncomment following line.
Pleae note this display needs a full 4 wire connection to (+5V, Gnd, RXD, TXD )
Configure display as follows: 115K baud, and TTL levels for RXD and TXD, terminal mode
NO rx / tx line reconfiguration, use natural pins */
//#define LCD_TEXTSTAR

/* motors will not spin when the throttle command is in low position
this is an alternative method to stop immediately the motors */
//#define MOTOR_STOP

/* some radios have not a neutral point centered on 1500. can be changed here */
#define MIDRC 1500

/* experimental
camera trigger function : activated via AUX1 UP, servo output=A2 */
//#define CAMTRIG
#define CAM_SERVO_HIGH 2000 // the position of HIGH state servo
#define CAM_SERVO_LOW 1020 // the position of LOW state servo
#define CAM_TIME_HIGH 1000 // the duration of HIGH state servo expressed in ms
#define CAM_TIME_LOW 1000 // the duration of LOW state servo expressed in ms

/* you can change the tricopter servo travel here */
#define TRI_YAW_MIDDLE 1500

//****** end of advanced users settings *************
Sign up now
to remove ads between posts
Jul 24, 2011, 07:22 PM
Registered User
AlexnderH's Avatar
I also just found that if i disconnect the WM+, the boards green LED flashes very fast continuousley and allows me to control the yaw servo, but still no motor control
Jul 24, 2011, 07:28 PM
Registered User
Did you read how to arm the motors? What you wrote does not express that you know how to arm the FC. It sounds like you think it arms once you plug the battery in. The motors do not arm when you plug in the battery. You have to manually arm the motors with the yaw stick and 0 throttle move the stick to the right and hold till the FC arms the motors. To disarm 0 throttle stick full left.
Jul 24, 2011, 07:31 PM
Registered User
AlexnderH's Avatar
That is what i have been doing. Every time i've tried to arm the motors i have been giving it 0% throttle and 100% yaw right. Nothing happens

Ive read all of the startup procedure guides too, havent found anything to help me
Jul 24, 2011, 07:50 PM
AMA 46133
Have you load the Java GUI and check the status?
Jul 24, 2011, 07:53 PM
Registered User
AlexnderH's Avatar
the GUI im using is the one i got when i downloaded the multiwii 1.7 folder. It was in a folder called multiwiiconf 1.7

the GUI selects com3 which is correct, but then clicking start does nothing.
Jul 24, 2011, 09:21 PM
AMA 46133
Originally Posted by AlexnderH
the GUI im using is the one i got when i downloaded the multiwii 1.7 folder. It was in a folder called multiwiiconf 1.7

the GUI selects com3 which is correct, but then clicking start does nothing.
What break out board are you using for the Arduino Pro Mini? You may need to provide 5V power to the board. I know you have to do that on the Paris V3.0 and BMA180 acc.

Are you using any accelerometers?

Some pictures will help.
Jul 25, 2011, 05:14 AM
Registered User
AlexnderH's Avatar
Im not using a breakout board/shield, i have the WMP and RX connected directly to the pro mini.

No acc used

The board is getting its 5v, the red power light is on.

Will try and get some pics up for you
Jul 25, 2011, 05:20 AM
OS Sponsor
kinderkram's Avatar
Do you have a proper GND between the Rx and the Pro Mini?
Jul 25, 2011, 05:44 AM
Registered User
AlexnderH's Avatar
The ESC that i have connected to pin 11 (top left motor of tri) supplys the board and rx. it is connected to the GND on the arduino pro mini. The setup is wired exactly as this picture
Jul 25, 2011, 06:18 AM
Registered User
AlexnderH's Avatar
if i disconnect the WM+ the green LED flashes fast and does not stop. Multiwiiconfig 1.7 also begins working if i disconnect the WM+.

Bad WM+? Still doesn't explain why my motors will not arm
Jul 25, 2011, 07:10 AM
Registered User
barok's Avatar
#define MINTHROTTLE 1300 // for Turnigy Plush ESCs 10A

lower the minthrottle..
. i have mine at 1020 on 18amp tunigy esc...

Jul 25, 2011, 07:25 AM
Registered User
Did you make sure that you soldered the connections right on the WM+? For me, I took all the original wires off and soldered my own on, but a lot of people use the original wires. Don't remember what color they were, so I'll go with what I did. The top most colors (lets say you have the WM+ sitting on a table with the curvy parts facing same as in that picture) will be the power. The bottom 2 will be the ground. And the SDA4 & SDA5 (I believe) will be the ones right below the power and right above the ground. If the GUI doesn't respond when the WM+ is plugged up, but starts up when it's not. It's most likely a short or wrong ports.

I had the same problem with mine, but it was a short between the V+ and the pin right below it. So I used a finer solder tip and bingo, the WiiConf started right up and runs normally at about 3200-3300 on the cycle timing. No nunchuck is plugged up, but might be adding one later.

P.S. If the first paragraph is confusing, just take a look at that picture. The middle most 2 is never used, the top next 2 is SDA whatever and power, and the bottom 2 is SDA whatever and ground. Also, make sure that the WM+ is facing the right way. Just check to make sure that that chip is right where its suppose to be and you not actually soldering it backwards (V+ to ground and vise versa).

Last edited by firepong; Jul 25, 2011 at 07:29 AM. Reason: Added P.S.
Jul 25, 2011, 07:57 AM
Registered User
AlexnderH's Avatar
I've set the minthrottle to 1020, motors still wont arm.

I've just double checked the WM+, and the connections are correct. there are no shorts.
I've just opened another WM+ that i know works, but this one has the two top pins, where the two top wire in that pic go bridged/shorted. ith then has the 6th and 7th pins down shorted/bridged also. Is that normal or do i have a wierd WM+ (it's an original)
Jul 25, 2011, 08:09 AM
Registered User
Originally Posted by AlexnderH
I've set the minthrottle to 1020, motors still wont arm.

I've just double checked the WM+, and the connections are correct. there are no shorts.
I've just opened another WM+ that i know works, but this one has the two top pins, where the two top wire in that pic go bridged/shorted. ith then has the 6th and 7th pins down shorted/bridged also. Is that normal or do i have a wierd WM+ (it's an original)
Yes, their suppose to be bridged, but not used I believe. That's what I meant about the top 2 being Voltage and the Bottom 2 being ground with the 2 middle ones being SDA4 & 5. Best Way I do it is like I stated. Go from the very most middle 2 pins and flare out. The top 2 above the 2 empties will be SDA whatever from the pic and Pin 12 while the bottom one will be SDA whatever and ground. Also, make sure you have the ground between the ESC and the WM+ spliced together and then plugged into the Pro Mini. Then that same ground will also go to the receiver for the ground there.

Same goes for the Power from ESC. Got to have the wire spliced into that pin and going straight to the power on the receiver.

Also want to make sure in you DX6I manual if you haven't already to make sure the channels are on the right channels on the Pro Mini. Like on my Futaba receiver, Throttle was channel 3 with all of the other channels being completely different as well.

And last but not least, what beeps are the ESC's giving when youy plug in the battery? It should go beep beep beeeeeeeep then last beep I believe, that meens it is ready to go and then all you have to do is arm it. If it doesn't do the special sequence, then somethings got to be up with your throttle expos.

Just need to plug your Pro Mini up to the computer with the battery plugged in and then go into your controller settings while looking at the GUI and set the EXPO's to land somewhere around 1000 when at the lowest point and around 1900-2000 on the highest point.

Quick Reply

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Question Completely New to RC remytampa Electric Plane Talk 35 Jul 31, 2011 11:24 AM
For Sale Sweet ProBoat 1:8 scale 26cc Hydro COMPLETELY CUSTOM!!! Ron Meloni Boats (FS/W) 3 Jun 30, 2011 11:59 PM
Discussion Completely lost - cellpro 4s, lipo's etc Knoxes Batteries and Chargers 22 Jan 06, 2008 02:34 PM
Discussion I'm completely lost.... Jacked637 Radios 4 Aug 22, 2006 02:21 AM
Have WES lost it completely? epilot Scratchbuilt Indoor and Micro Models 10 Dec 28, 2002 11:19 PM