Shop our Airplanes Products Drone Products Sales
Thread Tools
Jul 20, 2011, 11:41 AM
pattystacker
Discussion

blade 400 tail rotor


heilo guys. my first post on here.
k, i just bound and spooled up my new Blade 400 for the first time and all was working well except for the tail. as the bird became light on skids, the heli slowly rotated (counter-clockwize, i think) and my tail control couldn't seem to correct it. is there something i'm missing? could it be my tail rotor servo is not working? i'm using a Spektrum dx6i; do i need to adjust something in the program?
any advice greatly appreciated.
cheers
Sign up now
to remove ads between posts
Jul 20, 2011, 02:53 PM
Registered User
I would say just re-initialize it making sure that its level on the ground. Don't move it till you hear the tone. Another problem I had on my 400 was that the tail belt-drive wouldn't be tight. Just loosen the bolts holding the boom to the frame & pull the boom way from the frame, tightening the belt. Then just tighten the bolts back down. Hope this helps.
Jul 20, 2011, 03:20 PM
Registered User
sirs69's Avatar
You didn't mention gyro gain? Try that. raise it till it wags, then slowly back off
Jul 20, 2011, 04:05 PM
pattystacker
thanks guys. i'll consider both these issues. my rotor spins perfectly; it just doesn't change pitch. (so i'm not sure it's a belt issue)
should i be able to see a pitch change when moving the rotor control, before spooling up? (like i CAN see on the main rotor blades)
thanks for your responses.
Jul 20, 2011, 09:56 PM
Registered User
sirs69's Avatar
You should be able to, yes.
Jul 21, 2011, 09:40 AM
pattystacker
thanks sirs. i'll do a re-bind and try it again.
thx for your reply.
Jul 21, 2011, 09:41 AM
Registered User
Quote:
Originally Posted by pattystacker
heilo guys. my first post on here.
k, i just bound and spooled up my new Blade 400 for the first time and all was working well except for the tail. as the bird became light on skids, the heli slowly rotated (counter-clockwize, i think) and my tail control couldn't seem to correct it. is there something i'm missing? could it be my tail rotor servo is not working? i'm using a Spektrum dx6i; do i need to adjust something in the program?
any advice greatly appreciated.
cheers
Quote:
Originally Posted by pattystacker
thanks guys. i'll consider both these issues. my rotor spins perfectly; it just doesn't change pitch. (so i'm not sure it's a belt issue)
should i be able to see a pitch change when moving the rotor control, before spooling up? (like i CAN see on the main rotor blades)
thanks for your responses.
So just to be clear, you've got the rudder control all the way to the right and it still rotates?

Things to check: tail servo working? - when tail servo is centered, is the slider on the tail shaft centered? (you will have some pitch on the blades when it's centered) - Belt tightness (as already mentioned) - Gyro gain

Good luck


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
For Sale 450 size 5 blade head and 5 blade tail rotor drakonis Aircraft - Electric - Helis (FS/W) 4 Apr 16, 2014 09:29 PM
Discussion EXI Metal Head + Tail on Blade 400 avengedkevinfold Electric Heli Talk 3 Jul 08, 2011 04:41 PM
Wanted Blade SR Parts: head assy, tail boom, tail rotor assy TTRotary Aircraft - Electric - Helis (FS/W) 0 Apr 22, 2011 02:11 AM
Sold Blade 400 Cabon Fiber Main Rotor and Tail Rotor Blades Jose5x5 Aircraft - Electric - Helis (FS/W) 1 Apr 04, 2011 09:00 PM
Discussion s107 with 6020 tail boom and air hogs tail rotor blade jojo83 Coaxial Helicopters 4 Mar 11, 2011 07:41 AM