Thread Tools
Old Jul 17, 2011, 08:21 AM
rahlk is offline
Find More Posts by rahlk
Registered User
Discussion

ESC troubleshooting


I have the turnigy Basic 25A esc. When the connections are made(with the 1600Kv) brushless motor, the motor jerks couple of times every second. I am using a 6000maH 11.1V LiPO Batteries.
Sign up now
to remove ads between posts
Old Jul 17, 2011, 09:06 AM
eflightray is offline
Find More Posts by eflightray
An itch?. Scratch build.
eflightray's Avatar
Do you mean when the battery is connected but the receiver is not active ? (such as the transmitter is not switched on).

If so, then it does sometimes happen. The 'beep' sounds emanate from the motor windings, not from the ESC itself, and they are from pulses sent by the ESC to the motor. Those pulses are often enough to turn the motor slightly. Often more noticeable when a prop is attached as it easier to see.

Once the receiver is active, the ESC will go through its check routine and usually you will hear a number of 'beeps' to match the number of battery cells used. Then hopefully silence.

Sometimes if there is a motor fault, such as one winding open circuit, or a poor connector contact, then the 'beeping' will usually continue as a warning.
Old Jul 17, 2011, 10:04 AM
rahlk is offline
Find More Posts by rahlk
Registered User
@eflightray- The 'beep' sounds emanate from the motor windings, not from the ESC itself, and they are from pulses sent by the ESC to the motor.

Thats exactly whats happening, i hear beeps from the motor, But i bought 4 motors for my quad, apparently all of 'em have the same prob. Is there any compatibility issues between tunigy esc and a non-turnigy motor?
Old Jul 17, 2011, 10:25 AM
slipstick is offline
Find More Posts by slipstick
Registered User
Hearing beeps initially is NOT a problem. It's how the ESC tells you it's initialising. If it just carries on beeping and never stops that may be a problem.

So do you have the ESC connected to a receiver and the transmitter switched on ? If not then that's why. The ESC can't start up properly because it has no input signal.

Steve
Old Jul 17, 2011, 12:26 PM
rahlk is offline
Find More Posts by rahlk
Registered User
Great! It works.. Thanks a lot Guys.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion troubleshooting help with esc/motor chevronflyer Electric Plane Talk 23 Jul 10, 2011 07:36 AM
Need help troubleshooting CDRom motor and ESC The Don Power Systems 6 Sep 20, 2005 12:59 AM
ESC troubleshooting nose_first Power Systems 4 Sep 01, 2003 10:01 PM
Astro 010 and ESC troubleshooting...help!!! av8rOC Parkflyers 3 Mar 28, 2003 11:15 PM