OSD Pro firmware update problem - RC Groups
Thread Tools
Jun 24, 2011, 08:15 PM
Registered User

OSD Pro firmware update problem

I tried to update the firmware in my OSD pro and now I'm getting no telemetry on my eagle eyes tracker. I have the OSD installed in my plane and hooked to a ET data recorder. I plugged in the USB cable to the data recorder and updated the firmware in both the data recorder and the OSD, however, even though the firmware seemed to load ok, I keep getting a message that the firmware needs to be updated in the OSD. Apparently the data recorder updated ok. Am I doing this right? I left everything hooked up in the plane, camera, servos, etc, but left the planes receiver power off, so the data recorder and OSD were powered from the usb from the computer. I sure would appreciate some help. The weather is going to be great this weekend and I'm grounded if I can't get this straightened out.
Sign up now
to remove ads between posts
Jul 01, 2011, 01:25 PM
billpa's Avatar
Hi, I think you just need to update the telemetry on your EagleEyes also. I would recommend installing our 9.57 software from here, and updating your OSD and EagleEyes firmware all together.

Let me know if this does not resolve it for you!
Jul 03, 2011, 09:12 PM
Registered User
Hi Bill,
I found one of your posts that described a step by step process to up-date the firmware on the OSD Pro that worked for me. I did, afterwards, up-date the firmware on my Eagle eyes station. Everything is working fine now. Thanks

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Question OSD Pro, eLogger V3, GPS V4 problems updating firmware in OSD Pro jbfoamy Eagle Tree Systems 23 Jun 02, 2012 03:59 PM
Discussion OSD Pro Firmware update fail Mark taylor Eagle Tree Systems 11 Oct 18, 2011 03:31 PM
Help! Cannot Update OSD Firmware, unknown? jcgn2flyin Eagle Tree Systems 12 Sep 28, 2011 11:47 AM
Help! OSD Pro Update Problem S11D336B Eagle Tree Systems 4 Jun 15, 2010 09:08 AM