Thread Tools
This thread is privately moderated by demondriver, who may elect to delete unwanted replies.
Aug 28, 2011, 07:41 PM
Up-Out-&-Gone
demondriver's Avatar
Quote:
Originally Posted by Rookie2008 View Post
O ok. Hi Phill what state are you in ?
He's in New york Rookie.
Latest blog entry: It's 737 Time!
Sign up now
to remove ads between posts
Aug 29, 2011, 08:35 AM
Registered User
Rookie2008's Avatar
O yea ! What part ? I lived in New York for 28 yrs yep long time .
Aug 29, 2011, 08:45 AM
Registered User
im in NJ
Aug 30, 2011, 01:47 AM
Up-Out-&-Gone
demondriver's Avatar
Quote:
Originally Posted by phillipd View Post
im in NJ
Whoops Sorry Phillip!
Latest blog entry: It's 737 Time!
Aug 30, 2011, 01:54 AM
Up-Out-&-Gone
demondriver's Avatar
The finishing details, I almost forgot to add the unpainted aluminum bottom portion of the 737's fuselage seen here on these models & the real thing!
Latest blog entry: It's 737 Time!
Aug 30, 2011, 07:54 PM
Registered User
hey DD any new progress
Aug 30, 2011, 08:41 PM
Up-Out-&-Gone
demondriver's Avatar
Quote:
Originally Posted by phillipd View Post
hey DD any new progress
Yes indeed Phillip I'm hoping for a edf power test sometime tonight with video as well!
Latest blog entry: It's 737 Time!
Aug 31, 2011, 03:52 AM
Registered User
Rookie2008's Avatar
DD excellent job on attention to detail. What power setup are you using Phill?
Aug 31, 2011, 04:05 AM
Up-Out-&-Gone
demondriver's Avatar
Quote:
Originally Posted by Rookie2008 View Post
DD excellent job on attention to detail. What power setup are you using Phill?
Thanks Rookie! He's gong with the Scorpion 45A ESC, scorpion 3600kv motor setup, I'm just going nuts trying to get this Hi-tech radio & speed controllers working right, I'm gonna post the EDF power-up video soon!
Latest blog entry: It's 737 Time!
Aug 31, 2011, 06:37 PM
Up-Out-&-Gone
demondriver's Avatar
Well I have both Motors installed & both ECS's wired up and when I hook the batteries up the speed controllers just beep, beep, beep! I start with my throttle at 50% then the ESC's beep then I go to full throttle to arm the speed controllers & nothing happens, any ideas guys?

WHen I get them running I'll do a video!
Latest blog entry: It's 737 Time!
Aug 31, 2011, 07:01 PM
Registered User
Rookie2008's Avatar
Try 0% throttle than when its beeps raise to 100% throttle then when it beeps twice put it back at 0%. Then unplug batteries and plug them back again and see if they arm themselfs
Aug 31, 2011, 07:04 PM
Registered User
Rookie2008's Avatar
DD If that doesn't work contact Spyro. He is very knowledgeable with electronics.
Aug 31, 2011, 07:04 PM
Registered User
sdjb's Avatar
demondriver, Hey what ESC's are ya using?

sdjb
Aug 31, 2011, 07:13 PM
Registered User
sdjb's Avatar
demondriver, Tx on thorttle at 100%, Plug the batts to the ESC, as soon as ya hear them
beep close the thorttle and unplug the batts, and give that a try. usually works on most ESC's that I have worked with.

sdjb
Aug 31, 2011, 07:16 PM
Registered User
sdjb's Avatar
Oh demondriver, sometimes when running twin ESC's ya may have to disconnect one of the signal wires from one of the ESC's I meant to say that in the last post. Sorry

sdjb

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Found Windrider 737/787 teha99 Aircraft - Electric - Jets (FS/W) 2 Jun 24, 2011 12:23 PM
Sold Windrider 737 ARF Flexserve Aircraft - Electric - Jets (FS/W) 17 May 10, 2011 07:58 PM
Discussion Windrider 737 donation to Japan earthquake Ming Foamy EDFs 27 Apr 22, 2011 07:38 AM
Video Windrider 737 Transavia.com livery Fotor Electric Plane Talk 2 Mar 24, 2011 04:54 PM