Improved firmware for the KK multicopter, also the HK KK. - Page 53 - RC Groups
Thread Tools
Nov 28, 2011, 04:28 PM
Pilot not Drone Operator
hallstudio's Avatar
i had the same problem and it ended up being an inproper flash of the firmware. i had somhing set wrong on lazy zero flash. reflashed and was good to go.
Sign up now
to remove ads between posts
Nov 28, 2011, 04:50 PM
Registered User
Quote:
Originally Posted by hallstudio
i had the same problem and it ended up being an inproper flash of the firmware. i had somhing set wrong on lazy zero flash. reflashed and was good to go.
Is it possible to 'brick' (or ruin) a KK board when the flash procedure goes wrong?

I also have the goodluckbuy.com KK 5.5 v2.2 blackboard and tried to flash it with a chinese program (which does work with the supplied kk flash tool incompatible programmer). The messages were all in chinese so I cannot tell if the flashing was successful but it does not seem to work.
Nov 28, 2011, 05:03 PM
R/C CRASHER
tkoguy's Avatar
Are you using the usb tool that came with the combo from Goodlucky KK board and it does not work?
I just ordered one, what is the default on the board +? i want to reflash it to the X mode and update the firmware.
Nov 28, 2011, 05:10 PM
Registered User
Quote:
Originally Posted by tkoguy
Are you using the usb tool that came with the combo from Goodlucky KK board and it does not work?
I just ordered one, what is the default on the board +? i want to reflash it to the X mode and update the firmware.
Correct, the programmer I got does not work with the KK flash tool of lazy zero (but some people have reported that they did receive another type of programmer which is working so you just have to wait and see what's in the package).

I did not check the original mode because I wanted to upgrade to the KK 4.7 X firmware.
Nov 28, 2011, 05:48 PM
Master of Flash
LazyZero's Avatar
You can brick with the chinese tool, when you change the fuses. Some of them can damage the board, e.g. processor clock can be set there.

The goodluck boards come with Quad+ firmware, 2.1 or 2.2.

Christian
Nov 28, 2011, 07:04 PM
Registered User
antennahead's Avatar
Here's something wild!! I just installed a Good luck buy blackboard. (I didn't get a programer as I already have a avrisp mk II). I flashed 4.7 X with scalestick4 for all axis and the first test flights have been very promising compared to my HK KK V1. I tested the blackboard in the yard, just to do basic trimming then took it to the field to get it dialed in. I left it out in the cold to let the gyros aclimate to the outside temp which was 40 degrees F, when I plugged in the battery, the motors would just beep as if they weren't getting a signal. I could arm/disarm the board as normal, but no reaction from the board at all, no throttle, nothing, except the motors beeping. I took it into the clubhouse and let it warm up, and it was fine through the whole pack. thinking this was a fluke, I left it out in the cold again while recharging the battery, and again, it wouldn't arm until it warmed up. I repeated this a few times, and no matter what, I can't get this board to arm when it's cold...........anyone ever experience this before??
Nov 28, 2011, 10:20 PM
Not a six pack
rocketscience's Avatar
Quote:
Originally Posted by antennahead
I repeated this a few times, and no matter what, I can't get this board to arm when it's cold...........anyone ever experience this before??
I've had that issue with various ESCs over the years. The cold makes the ESC lose its throttle range for some reason. I bet if you redo the throttle range (yaw pot to 0, radio on, max throttle, etc etc) AT the field, or when it's coldest, then you won't have problems. When it warms up you MIGHT have to do it again.
Nov 28, 2011, 11:13 PM
Registered User
antennahead's Avatar
Quote:
Originally Posted by rocketscience
I've had that issue with various ESCs over the years. The cold makes the ESC lose its throttle range for some reason. I bet if you redo the throttle range (yaw pot to 0, radio on, max throttle, etc etc) AT the field, or when it's coldest, then you won't have problems. When it warms up you MIGHT have to do it again.
Thanks!! I'll give that a try. I have never experienced this before. I was going to recalibrate them at the field, but decided not too to see if it was in fact being cold causing the problem.
Nov 29, 2011, 04:32 AM
DXL Team Pilot FuriusP
panos2408's Avatar
Quote:
Originally Posted by Kaptenklister
I need some help, I installed this FW on my HK V2 board, now when I plug it in the esc:s play their usuall short series of beeps (turnigy plush 25) after that they all continue to beep constantly around 2-3 beeps per second.

The led light up when I move throttle to bottom right and it goes out when I move throttle to bottom left.

Any help is appreciated
I had this problem with the another FW. (all motors beeping 3-4 times a second and board led was flashing rapidly) It is an ESC issue. Basically the signal received by your esc is not low enough to be considered as a dead throttle so the esc's will not arm. You board in this case seems to be acting perfectly. You can try:

0) Make sure you have done the throttle calibrating Yaw pitch to 0 and stick to the full throttle position. Remove props for this process either wise if they start you ll be in a very bad situation.
1) Trim your throttle lower.
2) Subtrim your throttle stick to the lowest. (Futaba TX usually is + subtrim since it's reversed.)
3) Change the code within the FW which is a not an easy thing if you don't know how to do it and i can't help on that.
4) Try another FW
5) Change esc's o check whether there is a throttle configuration if they are programmable.

Hope it helps.
Nov 29, 2011, 11:41 AM
R/C CRASHER
tkoguy's Avatar
Can someone point me in the right direction, on the flash screen which controller do I choose for the (goodlucky KK 5.5 board)? and also I like to run the X config I dont see a 4.7 X config.
Nov 29, 2011, 12:30 PM
Master of Flash
LazyZero's Avatar
Hi, select the blackboard with 168P/PA then you can filter the available firmwares for XCopter.

Christian
Nov 29, 2011, 12:48 PM
R/C CRASHER
tkoguy's Avatar
Ok got to the firmware which version, I see two versions one is ACRo and the other one I have no ideal...I see two 4.7 version Thanks
Nov 29, 2011, 12:53 PM
Master of Flash
LazyZero's Avatar
The one with no addition is the original one - best for all purpuses. Acro is as the name says for acro flying (flips, etc) - only experienced pilots.

Christian
Nov 29, 2011, 01:01 PM
R/C CRASHER
tkoguy's Avatar
Ok I guess its the first one on the list then..one more question sorry, the rotation of the blades do I just follow the KK board directions?
Nov 29, 2011, 01:16 PM
DXL Team Pilot FuriusP
panos2408's Avatar
Quote:
Originally Posted by tkoguy
Ok I guess its the first one on the list then..one more question sorry, the rotation of the blades do I just follow the KK board directions?

Motor 1 Clock wise then the opposite motor i think no3 in this FW also has to be clockwise. The 2 remaining counter clock wise.
If you are asking how to connect motors on the board i think on this FW is kinda like this:

(1)(3)
(2)(4)

In any case prior frst flight do this:

Give enough throttle so the blades are spinning but the quad is still on ground. And check all the directions to make sure you are on the right track. If anything weird happens get back here


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion NEW KK Multicopter Core Board V5.5 Quadcopter and firmware loader terriwang Multirotor Drone Talk 1 Apr 05, 2016 05:21 AM
Sold KK Multicopter Core Board V5.5 Quadcopter and firmware loader $95 Shipped terriwang Aircraft - Electric - Multirotor (FS/W) 20 Jun 06, 2011 12:34 AM
Cool KK Multicopter Core Board V5.5 Quadcopter and firmware loader $95 Shipped terriwang Hot Online Deals 0 May 26, 2011 01:28 AM
Sold Quadcopter KK Multicopter RR or RTF w/Turnigy 9X -- Trades welcome KKUSA Aircraft - Electric - Helis (FS/W) 12 Mar 04, 2011 05:29 PM
For Sale SOLD, THANKS - COMPLETE KK QUAD RTF Kapteinkuk multicopter for sale bob.titus FPV Equipment (FS/W) 0 Nov 12, 2010 08:23 AM