Improved firmware for the KK multicopter, also the HK KK. - Page 47 - RC Groups
Shop our Airplanes Products Drone Products Sales
Thread Tools
Nov 13, 2011, 10:00 PM
Suspended Account
SUCCESS!!!!!!!! It was a broken wire............geez...........Anyways, it took I was able to flash my KK Ver 5.5 to X mode and went onto my HK KK and flashed it with 4.7. I'm a flashin fool now
Last edited by randall1959; Nov 14, 2011 at 01:05 AM.
Sign up now
to remove ads between posts
Nov 14, 2011, 01:28 AM
Master of Flash
LazyZero's Avatar
Congratulations. Yes the last image with the error message suggests that the programer itselfs worked but has no connection. That may be the board or teh cable. But you got the solution already.

Christian
Nov 14, 2011, 07:16 AM
Suspended Account
The fellow I got the programmer from had not soldered the wires onto the wires coming from the adapter plug. Probably pulled one apart while unfastening it from a board. Everything is soldered and shrink wrapped now.
Once I figured the problem out it all fell into place. I knew it had to be a hardware issue of some sort. I only took the wires apart as a last resort. Your "beer money" will be forthcoming Zero
Nov 14, 2011, 08:28 AM
Master of Flash
LazyZero's Avatar
Quote:
Originally Posted by randall1959
The fellow I got the programmer from had not soldered the wires onto the wires coming from the adapter plug. Probably pulled one apart while unfastening it from a board. Everything is soldered and shrink wrapped now.
Once I figured the problem out it all fell into place. I knew it had to be a hardware issue of some sort. I only took the wires apart as a last resort. Your "beer money" will be forthcoming Zero
I will add a FAQ for the error message with the hint to check the connection.
Beer is welcome. I have to go to a big trade fair in Düsseldorf, Germany this week. Problem is that the people in Düsseldorf are not able to brew good beer

Christian
Nov 14, 2011, 09:23 AM
Registered User
So did your device manager show that your USB dongle is working properly?
When I checked mine it was not and I had to get a driver.

Nov 14, 2011, 05:26 PM
Suspended Account
Quote:
Originally Posted by Kydave
So did your device manager show that your USB dongle is working properly?
When I checked mine it was not and I had to get a driver.

That was the first thing I ran into and solved pretty quickly. The "fuse" error message came later.
Lazy Zero, is there any way to check a board to tell which firmware it has on it allready? A friend asked me this and I didn't know the answer. I told him to just write the firmware he wanted onto the board and he'd know for sure then.
Nov 14, 2011, 07:32 PM
Suspended Account
Quote:
Originally Posted by LazyZero
I will add a FAQ for the error message with the hint to check the connection.
Christian
Do you also have in the FAQ not to reflash the board while still in the quad? I reflashed one last night and today it would not fly. I tried a different rx and then it hit me that I had left everything hooked up.
So I unhooked all the leads, reflashed it, and it works perfectly now. I didn't get a long flight in but enough to tell it does fly differently and comes down from a long way up quite a bit smoother. It also stops better without a pitch up.
Nov 14, 2011, 07:49 PM
Not a six pack
rocketscience's Avatar
Hmm I was able to flash mine all hooked up still in the frame. Did you have a battery hooked up?
Nov 14, 2011, 09:15 PM
Suspended Account
No I didn't but I kept hearing a faint beeping like it was coming from an esc. Anyways, I reflashed it unhooked and all is well I do have one last question. How do you set the throttle range on the esc's? If it's unarmed until you throw the rudder over, how do you set them? Hook them up one at a time to the rx?
Edit: Instead of posting again, I went back and reset each esc directly to my rx and did the epa's. Now the quad hovers hands off. No trim needed. I can allready tell that this board flies better than either my old FY90Q or my GU344 at 1/5 the price.
Last edited by randall1959; Nov 14, 2011 at 09:36 PM.
Nov 15, 2011, 12:44 AM
Master of Flash
LazyZero's Avatar
I am currently trying to find an easy way to determin the firmware and version by reading Out the content of the flash. But the files differ a bit. But this feature will find its way to the tool.

Christian
Nov 15, 2011, 03:47 AM
manuLRK
Hi Christian,

I used the "repository" firmware upload, and i don't find it easy to know if the program is still doing something or not. Is it possible to have some sort of progress bar of the overall upload (fuses, download, upload...)

The program seems doing nothing, but in fact it does! There is a big time gap between the fuses and the firmware.

And i always get an verification error after firmware upload...

Thanks,
manu

Code:
Flashing firmware from file.: X:\@RC\tricopter\kkmulticopterflashtool\tmp\xx15d_QUADX_M168_SF_EN.hex

C:\WinAVR-20100110\bin\avrdude.exe -C C:\WinAVR-20100110\bin\avrdude.conf -p m168 -P COM4 -c avrispv2 -D -F -B 8 -U flash:w:X:\@RC\tricopter\kkmulticopterflashtool\tmp\xx15d_QUADX_M168_SF_EN.hex:i 

avrdude.exe: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.02s

avrdude.exe: Device signature = 0x1e940b
avrdude.exe: Expected signature for ATMEGA168 is 1E 94 06
avrdude.exe: reading input file "X:\@RC\tricopter\kkmulticopterflashtool\tmp\xx15d_QUADX_M168_SF_EN.hex"
avrdude.exe: writing flash (15216 bytes):

Writing | ################################################## | 100% 30.20s

avrdude.exe: 15216 bytes of flash written
avrdude.exe: verifying flash memory against X:\@RC\tricopter\kkmulticopterflashtool\tmp\xx15d_QUADX_M168_SF_EN.hex:
avrdude.exe: load data flash data from input file X:\@RC\tricopter\kkmulticopterflashtool\tmp\xx15d_QUADX_M168_SF_EN.hex:
avrdude.exe: input file X:\@RC\tricopter\kkmulticopterflashtool\tmp\xx15d_QUADX_M168_SF_EN.hex contains 15216 bytes
avrdude.exe: reading on-chip flash data:

Reading | ################################################## | 100% 28.42s

avrdude.exe: verifying ...
avrdude.exe: verification error, first mismatch at byte 0x0002
             0x98 != 0x10
avrdude.exe: verification error; content mismatch

avrdude.exe done.  Thank you.

Error during writing flash.
Nov 16, 2011, 05:37 AM
Registered User
I formerly used the 1.7 firmware, but want to upgrade to 4.7 due to the positive comments here.

Can someone explain the terminology mentioned by kapitan kuk?

"Added I-term on yaw axis

Added I-term anti wind-up, all axis

Changed potmeter usage:
Roll pot now controls P-term gain on roll/pitch axis.
Pitch pot now controls I-term gain on roll/pitch axis.
Yaw pot controls P-term on yaw axis as before. Yaw axis I-term is fixed at 0.2"


What is I-term and P-term about? I was used to setting the pots to in/decrease gyro compensation.
Nov 16, 2011, 02:52 PM
manuLRK
Quote:
Originally Posted by Dr.Gonzo
I formerly used the 1.7 firmware, but want to upgrade to 4.7 due to the positive comments here.

Can someone explain the terminology mentioned by kapitan kuk?

"Added I-term on yaw axis

Added I-term anti wind-up, all axis

Changed potmeter usage:
Roll pot now controls P-term gain on roll/pitch axis.
Pitch pot now controls I-term gain on roll/pitch axis.
Yaw pot controls P-term on yaw axis as before. Yaw axis I-term is fixed at 0.2"


What is I-term and P-term about? I was used to setting the pots to in/decrease gyro compensation.
https://www.rcgroups.com/forums/show...postcount=1590

manuLRK
Nov 16, 2011, 03:19 PM
Registered User
Success ! after flying the KK board as a quad, i thought i would try the X factor (no pun intended) and i being a noob thought it would be the same config. So i spent 3 days pulling my hair out until i read this post and found out that the motor order has changed..doh.
So i quickly re-arranged the leads, set every pot to default, and it just poped up in the air, as if to say what kept you so long ??
I was gob smacked, on how stable it is, and so little Tx trim i had to give it.. the pot values were good, and so far i can't wait to fly it outside to see how it behaves..
Thanks to KaptainK for all his work.. :-)
Nov 16, 2011, 03:33 PM
Not a six pack
rocketscience's Avatar
Quote:
Originally Posted by apache64
I was gob smacked, on how stable it is, and so little Tx trim i had to give it.. the pot values were good, and so far i can't wait to fly it outside to see how it behaves..
Thanks to KaptainK for all his work.. :-)
I know.. I keep mine in the car now so I can fly it whenever. Not too many planes or helis have a permanent spot in my trunk.

I use 100% rates with 30% expo on ail/ele but I find rudder needs 120% for my tastes. Simply a little slower compared to a heli with an actual tail rotor.

It banks and yanks with the best of them.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion NEW KK Multicopter Core Board V5.5 Quadcopter and firmware loader terriwang Multirotor Drone Talk 1 Apr 05, 2016 05:21 AM
Sold KK Multicopter Core Board V5.5 Quadcopter and firmware loader $95 Shipped terriwang Aircraft - Electric - Multirotor (FS/W) 20 Jun 06, 2011 12:34 AM
Cool KK Multicopter Core Board V5.5 Quadcopter and firmware loader $95 Shipped terriwang Hot Online Deals 0 May 26, 2011 01:28 AM
Sold Quadcopter KK Multicopter RR or RTF w/Turnigy 9X -- Trades welcome KKUSA Aircraft - Electric - Helis (FS/W) 12 Mar 04, 2011 05:29 PM
For Sale SOLD, THANKS - COMPLETE KK QUAD RTF Kapteinkuk multicopter for sale bob.titus FPV Equipment (FS/W) 0 Nov 12, 2010 08:23 AM