GA250 Coax Gyromixer: The Ultimative Boardless Brushless Conversion? - Page 14 - RC Groups
Thread Tools
Nov 04, 2011, 05:51 PM
Professional heli wrecker
Luvmyhelis's Avatar
I know. I am diagnosing and eliminating issues here. What I do think happened is my TTL adapter failed. I just went back and tried to do a simple connect with the AVRootloader on the gyro that took the vs 21 and it showed the same no device found. Let me ask a question again. Absolutely which baudrate should this be transmitting on? All the wires are solid as I tore every single Gyromixer down and doublechecked everything.
When I push the power up button on the ttl adapter harness the gyromixer lights up so I know a connection is being made. I am just not getting a signal through the TTL adapter anymore.

Btw: can you go back and correct post # 67. You list both A and B as upper rotor. Lol.
Last edited by Luvmyhelis; Nov 04, 2011 at 06:20 PM.
Sign up now
to remove ads between posts
Nov 04, 2011, 06:37 PM
the bootloader is detecting the baudrate automatically, so the baudrate should actually not matter at all, as long as it is within reasonable range (I guess 115000 would be too fast). Both 19200 and 57600 should work perfectly fine, only that 19200 is slower...

All the cables of the push-button assembly are OK? (with your multimeter tthere shoudl be this beep-test thing)
Do the lights on the TTL adapter do what they are supposed to do?

That's really sad.

Maybe its just the usb cable. They tend to be very cheap and not very reliable nowadays. I had once an issue and puzzled around for a while, and at the end it was just that the usb vcable was broken...

I change the post
Nov 04, 2011, 07:07 PM
Professional heli wrecker
Luvmyhelis's Avatar
Good point! I will try another cable. I also discovered my 1811 turnigy 2900ma motor is still chattering. It must have an internal short. I went to HK yesterday and ordered new escs, when I paid they had lots in stock. Suddenly they backordered me. Aarrgh! Now I need to add some motors to the mix. Even the turnigy 10a escs are gone. Man, when problems hit it seems they all hit at the same bloody time.
I am tearing down my fbl heli and stealing one of the motors off of it for now. What is really odd is that it spun up perfectly with the other esc numerous times.
Last edited by Luvmyhelis; Nov 04, 2011 at 07:13 PM.
Nov 04, 2011, 07:29 PM
Professional heli wrecker
Luvmyhelis's Avatar
Got that part taken care of. Both motors spin up. And no the usb cord isn't the issue. It continually tells me I have no connection. Device not found.

Now a new fun issue. When I raise the throttle I can get both motors spinning. But only if the gymbal is off center towards L or R. And then even at half throttle only the motor that the gymbal is leaning towards will spin. In center gymbal only the motor that the gymbal got spinning is engaged. Move the gymbal the other way and the motor starts spinning, but the first motor that was running now stops. Isn't this fun?
I am positive this is a gain issue of some sort.
Time for another gyromixer to see if it is doing the same thing. Plus the mixer that did take the olliw vs21 still engages during RobbeBox control.
Using a different gyro it does spool both up and with the gyro free I can see instant changes by turning the gyro left or right as expected.

Also time for a few quick questions.
In the RobbeBox. When I get it to say Save to eeprom. How actually do I get it to save?
Next, I have it tabbed to rate. How does it actually enter rate? All I see is the word rate and I can turn it into hh or off. But in Rate it simply just says Gyro, with Rate underneath it and no actual number settings. No rate anywhere.
And where are the rate settings? All I can get is just pid gain.
And I have full throttle to the lower blades but only limited throttle to the upper blades. In essence all it wants to do is spin to the left. If I am say at half throttle and turn the gymbal to the left, I now have a screaming lower blade set. Do the same thing moving the gymbal to the right and there is no increase over the base throttle in the upper blade set.

I know, I know. I am the problem child. Happens with every stinking thing I do. Even my Sk720 fbl units had issues that mystified the owner of the company.
Last edited by Luvmyhelis; Nov 04, 2011 at 08:46 PM.
Nov 04, 2011, 11:31 PM
"when problems hit it seems they all hit at the same bloody time."
yes, there seems to be a curse on this here... but I kind of admire your presistence...

I am not sure I can interpret your gimbal behavior.
What do your THRO MIN VALUE and THRO MAX VALUE say?
Your are sure that both besc have been trained? What happens if you just exchange the two bescs but have everything else the same?

BTW: how have you set up your transmitter? No mixers, swash, etc:?

AHHH, what comes to my mind, maybe you should set the frame rate to higher than 4ms, set it to 18ms at first. I have the (old) tunrigy 6A, and they work perfectly with the 4 ms setting, nut I lost overview what besc you are actually using now... maybe they can't handle 4ms...

The other qustions can be answered:

"When I get it to say Save to eeprom. How actually do I get it to save?"
good question. With "+" and "-" pressed shortly you change the query on the display between yes and no. Set it to yes. Then press on the "+" and hold it until something happens on the display... i.e., you need to press the "+" for about 2 sec or so...

"I have it tabbed to rate. How does it actually enter rate?"
that's it, you tab it to rate... and it is in rate mode

"no actual number settings. No rate anywhere. And where are the rate settings? All I can get is just pid gain."
There are these three paramters I have mentioned in the above. Rate Gain, PID Gain and PID I.
Now, Rate Gain sets your Gain in rate mode. The other two parameters are ineffective in rate mode. PID Gain sets your gain in hh mode, and PID I sets your "heding hold capability" in hh mode. The Rate Gain parameter is ineffective in hh mode.

Arghhhh, damed, I forgot, this is valid only for v0.21 but not v0.20
In v0.20 the parameter PID Gain is the gain value for both the rate and hh modes... in v0.20 there is no way to set different gains for these two modes... hence no extra Rate Gain.

PS: I am not sure you have tried AvrConfig already, but AvrConfig would NOT work for v0.20! Actually, more precisely, it in fact would seem to work, at the first read it maybe would just present strange values, but it actually would scramble your paramters into nonsense... so, use it ONLY for v0.21! I guess I have to implement a version checking...
Nov 05, 2011, 12:52 AM
Professional heli wrecker
Luvmyhelis's Avatar
Yes, I set the throttle min and max values. Twice, and traded escs doing it. I traded Gyros also. I am going to give it another shot later when I have sat on it for a short while and cleared my mind a little. I also ran through everything with a circuit tester to verify the solidity of all the connections and wires involved.

I have no real clue as to why the AvRootloader doesn't connect. And if the TTL adapter isn't performing even having the program running directly from the laptop to the gyro wouldn't help. Tomorrow, maybe later tonight I might get my second wind and give this another shot.
Nov 05, 2011, 01:07 AM
What do your THRO MIN VALUE and THRO MAX VALUE say?

What do your lights on the USB-TTL adapter say?
Nov 05, 2011, 07:20 AM
Professional heli wrecker
Luvmyhelis's Avatar
Got it. I finally have a pair of operating Turnigy motors and one set of operating esc's out of the 6 I started with. Every single one had a problem with the board. Even the last set I just soldered up at 4am worked for just a moment. One of them immediately died. I sat there stunned! I tore off the shrink wrap again as I had just soldered on brand new servo plugs all the way around just to find out one of them was bloody defective and had pulled apart inside the wire!! Another 10 minutes heating up the iron, new plug installed and I have even thrust on both sides with..............oh yeah........ beautiful tail wag!!!!!

I played with the freq and bumped it to 14 from .04, made no difference earlier. And low throttle is 1116 and high is 1610.
What I encountered was every conceivable bad board, each acting up in different ways, and one bad motor that is running slower than the other? Never, ever have I seen or heard of a new brushless motor ever doing that?????? Thank you Turnigy for making my freaking life miserable for the last few days.

I should have this up and going this weekend, but I am picking up my kids in a few hours so it is catnap time and I will get at this again this afternoon when I get some time. I changed the electrics over to my dual swash platform, so I am going to tear the swash assembly off and put a different head system back in place. I want this simple for the first setup. I already tore off the Sk360, and started on the shafts and custom grips. I should have an extended upper shaft, skytec swash, center hub, outer shaft, and adj collar in place within short order. I am still going to use my own flybar assembly and head I designed. I also removed the lighting system. I want this one simple. And for now I may even run this on 2s just for the initial setup.

As far as the lights on the Usb-Ttl adapter the red (rx) diode on the left side flashes when I connect the usb to the usb port as well as the green (tx) diode on the other side for a second or two. I probably tried several different combinations of techniques trying to get the code loaded, along with different cables and leads.
Nov 05, 2011, 07:45 AM
glad to hear that things make progress (my GA250 CP gyro project made also progress today )

"And low throttle is 1116 and high is 1610."
If there isn't a typo, then this doesn't sound correct at all... I mean, the values should be roughly centered around 1520 and should go from something like 1100 to 1900... I suggest that you check the settings of your Tx... if there is some mixer, dual rate, range limit, or whatever...

"Usb-Ttl adapter"
very strange... I am running out of ideas... does the usb port work for other usb devices? I mean, I would not be surprised if it finally would turn out that your lappi-wents-black issues are somehow related to the fact that the usb connection doesn't seem to work anymore...
Nov 06, 2011, 12:18 AM
Professional heli wrecker
Luvmyhelis's Avatar
The values are exactly 1117 low and 1912 high with the again new esc package and motors. And strangely the new setup still has the exact same issue with the weak upper rotor performance. Just like before. I do get some very minor tail wag (gain set at 2) so I know the gyro is trying. But at anything over half throttle the heli starts spinning to the left. Even at full right gymbal I still have a hard left pull. But when the heli is at a lower throttle setting the heli acts appropriately when I manually turn it to the left or right with the correct blades speeding up and slowing down.

My Skookum 720 system uses the same port 13 and runs perfectly. Tomorrow I am switching Usb programming ports just to see if there is any difference in how the system downloads. I do know all the correct responses to code input happened before the final OlliW vs.20 was input. Now I am wondering if it properly downloaded even though I saw the correct AvRootloader operation. There are lots of variables, so I am systematically eliminating them one by one.
So far I have ran the system with different esc's different motors, different heli platforms, different gyromixers, and every combination inbetween that I normally use to isolate an issue. I find it highly unlikely that two different Turnigy motors on separate helis would exhibit the same behavior. When I do get some more time I will tear it down again and once again check any and everything mechanically involved.
I also bound it to my DX6i just to see if it was TX related. Same problem.
Last edited by Luvmyhelis; Nov 06, 2011 at 01:28 AM.
Nov 06, 2011, 04:25 AM
"The values are exactly 1117 low and 1912 high"
this looks correct

I think you need to get the possibility to flash frimware running again... I do see only two things which could be wrong here... (1) the usb-ttl adapter itself died, (2) the bootloader got somehow corrupted

The latter, (2), would be however unlikely to have happend for all gyromixers. With AVRootloader.exe, can you establish a connection with the robbe box (i.e. pretend to flash a new frimware onto it). If yes, your bootloaders on the gyromixer are the problem, if no, I guess the usb-ttl adapter is the problem.

As regards the gymbal thing I am really puzzled, and don't have any good idea.
You indicate that the gyro is working properly, but the behaviour reminds me very much of what you get if the gyro action is opposite to what it should be, I hence like'd you to check that more thoroughly:

(i) How is the gyromixer installed, upside up or upside down?
(ii) Your Heli has really exactly the same spinning configuration as a Lama V4 and Big Lama (top CCW, bottom CW)?
(iii) The gymbal problem is present in rate mode, hh mode, or in both modes?
(iv) Do you get the same behavior also with gyro OFF? That is, set gyro to off, ensure that Rudd Sense is a small value, e.g., about 0.10, and throttle up

Please answer in particular the point (iv). This should be a very good test.

Could you connect a servo first to the thro of your reciever and check how much it can move by moving the thro stick, and then connect the servo first to motor A and then to motor B (with gyro off) and look again how much it does move? I'd like to confirm that the gyromixer outputs go from ca. 1100 to ca. 1900...

Is this the same reciever you were using in the previous test flights, where the gyromixer seem to have worked, at least for some time.
Nov 06, 2011, 02:00 PM
Professional heli wrecker
Luvmyhelis's Avatar
Fabulous! Good stuff. Now I actually have a way to test the components that makes sense. I understand what you are trying to see here. I was just logging on to say I was going to do the same test once more with a completely different gyromixer. If all three do it then it is a corrupted information install or I have wondered if it was possible that the brand new gyromixers could have had a different base program from Assan, however I realized that we erased those base programs to an extent and replaced the vital ones with your new programming so this would hardly have been the issue. By the end of today if I have a chance I will go through all the steps you laid out above and give precise answers to in order. Thanks Olli W. !!!

Actually I did it right now since I had a moment.

And a quick answer to 1 and 2. , gyro is installed right side up, on the forward pad with the wires facing the forward direction. Plus I have no rate since I am running vs .20. And yes the blade config or direction is identical to the L V4.
Now for iv or point 4.
Gryro off, Rudd sense at .10 ( which was the default setting) and as far as throttle issues it acts exactly the same.
Nov 06, 2011, 02:11 PM
(i) thanks
(ii) thanks
(iii) you do have rate also in v0.20, go to the menu "gyro" and switch with + and/or -, it should offer you off, rate, hh.
(iv) thanks... that's strange though

considering the result of (iv) the replace-motor-by-servo test would be important
Nov 06, 2011, 06:00 PM
Professional heli wrecker
Luvmyhelis's Avatar
No need, I spent the entire day going through just about everything. I am up, it is flying, and we are go for liftoff Houston:

I already had my first banking error and forgot how badly these are prone to death dives. It is the reason I developed a dual swash system, but it isn't on this one. Lucky I have about 50 sets of spare blades. And with 3s I added a set of step up gears with the extra torque. This thing rips, just rips.
The system is working.
Nov 07, 2011, 02:25 AM
"The system is working. "

would you mind to share what the solution was?

"system is working" refers to the gyromixers, I guess, but not flashing new firmware?

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Lama V4 Brushless Boardless Conversion Parts List mountainsax Coaxial Helicopters 44 May 31, 2011 09:45 AM
Discussion Coax 370 brushless conversion Fly-a-kite Coaxial Helicopters 6 Dec 11, 2009 07:24 AM
Build Log brushless conversion of walkera 53-1 into an AP coax HyperHelis Coaxial Helicopters 16 Dec 12, 2008 06:51 PM