Thread Tools
May 29, 2011, 01:55 AM
Justin
Thread OP
Help!

RC18T and Castle Mamba 25 problems


Hi,

I've got an RC18T with the stock transmitter (27 MHZ AM) and a Castle Creations Mamba 25 brushless system. I'm running 7.4V 2200mAh Li-po's with 40C discharge. I had trouble with it "cogging" I think I've heard it called, so I updated the firmware using the Castle Link.

Now I have no throttle at all. The steering servo works (in the throttle channel as well, if I put the ESC into the steering channel) but no throttle. After the ESC boots up, an orange LED comes on - steering works, throttle does nothing.

I tried to run through the Calibrating Throttle instructions - but I can't seem to be albe to initiate the process. No matter what I do, (even reinstalling the old firmware) all I get is an orange LED on the ESC and no throttle!

Castle does not answer emails and I live overseas so a phone call isn't the easiest (or cheapest) thing to do.

Any ideas?
Sign up now
to remove ads between posts
May 29, 2011, 06:55 PM
Registered User
Yes, this is usually the firmware update - start rolling it back until you find a version that works again.

These updates a 'beta' versions and I never use them until they are like 6months old and any bugs are identified.....
May 30, 2011, 03:23 PM
Justin
Thread OP
Thanks for the tip. I tried loading all the firmwares my CastleLink software has - no change (in this case back to 1.16 non-beta).

Then I chose the "Restore Defaults" option. Now I can at least get to the throttle calibration phase.

My trouble now is the ESC accepts my full throttle input, but does not accept the full brake input - just sits there beeping a red LED. I'm following Castle's instructions exactly (as it seems to me), but can't seem to get past the reverse portion on the calibration. I'm using the stock radio.
May 30, 2011, 08:22 PM
Registered User
This is what that flashing red led and beeping are supposed to mean - "Flashing Green OR Red while beeping = indicates speed control is looking for full throttle (green) or full throttle (red). If it continues for more than ~ 8 seconds, indicates speed control is seeing partial throttle (green) or reverse (red), increase endpoints on transmitter so speed control sees full throttle/reverse."


Try increasing your throttle endpoint....


Sounds like you're almost there.
May 30, 2011, 10:47 PM
Justin
Thread OP
You're a genious! You just saved a little RC18 from certain destruction!

Had to turn every nob on the transmitter to the full position (dual rate nob and both "th. atv" hi and low) - then the calibration process could go through. Works fine now.

Thanks a lot!
May 31, 2011, 09:13 PM
Registered User
Glad you got it calibrated - these can seem impossible at times, but knowing the codes sure helps zero in on the exact prob.

Now go and have some fun!


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Sold RC18t Mamba Micro Pro DG40 Cars - Trucks and Parts (FS/W) 0 May 03, 2011 10:28 AM
Sold castle mamba max pro esc with 7700kv motor chuck e cheese Cars - Cars and Parts (FS/W) 4 Mar 03, 2011 12:06 PM
For Sale RC18T w/Mamba 25 Drivinfast247 Cars - Trucks and Parts (FS/W) 0 Sep 30, 2009 01:26 PM
Off Site rc18t mamba-25 aluminum everything RC-PARTS Cars - Cars and Parts (FS/W) 0 Oct 10, 2005 10:34 PM
rc18t w mamba 8000, mini t ,w mamba 6800 lithium chevy1269 Cars - Cars and Parts (FS/W) 2 Mar 30, 2005 09:08 PM