My motor isn't working but my servos are! Please help! - RC Groups
Shop our Airplanes Products Drone Products Sales
Thread Tools
May 21, 2011, 01:08 AM
B to the O to the B
Ecibob's Avatar
Help!

My motor isn't working but my servos are! Please help!


Hey everyone,

I'm using an e-flite 60 amp ESC with a scorpion 1040kv motor to power my up and coming skywalker.

When I turn on the radio (idle power) the motor beeps four times. Then stops and when you move the throttle there is no motor movement.

Everything seems to be connected right and the servos work fine. I'm thinking maybe my batteries voltage is too low? All the cells are 3.8 v and the total is 11.5 for a 3s 2450 mah battery. I also have a turnigy 5000mah 4s battery that I plan on using for the plane itself, but right now it needs an xt-60 plug soldered onto it instead of what it came with. (a long red connection).

Thanks for helping!
Sign up now
to remove ads between posts
May 21, 2011, 01:14 AM
Foam flogger
4 beeps sounds like it's default set up is for a 4S battery. Either switch batteries or read you programing guide for your esc
May 21, 2011, 01:27 AM
B to the O to the B
Ecibob's Avatar
well the manual for the esc actually says that there is one pitch beep at the beginning and then the number of cells beep a different tone. So my 3s battery is indicated by the 3 beeps after the first.
May 21, 2011, 01:32 AM
Registered User
What radio are you using? If Futaba, have you reversed the throttle channel?
May 21, 2011, 01:43 AM
B to the O to the B
Ecibob's Avatar
It's not reversed. Should it be?
May 21, 2011, 01:57 AM
Registered User
On a Futaba transmitter and all esc:s I am familiar with, Yes, the throttle channel must be reversed.
May 21, 2011, 02:15 AM
B to the O to the B
Ecibob's Avatar
Got it to work! Thanks!!


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! My Hobbyzone Champ's Elevator isn't working. HELLLLPPPPP!! Chapflyer Micro Ready-to-Fly 19 Jan 04, 2013 07:56 PM
Discussion One side of my beloved Hyperion DUO isn't working... Mike_Then Batteries and Chargers 2 May 02, 2011 01:00 PM
Help! My Hobbyzone Champ's Elevator isn't working. HELLLLPPPPP!! Chapflyer Parkflyers 3 Apr 01, 2011 04:54 PM
Discussion Please help me with my quadcopter's propeller and motor selection shadow511 Electric Motor Design and Construction 2 Mar 10, 2011 09:49 PM
Why isn't my new toy working? AirVenture Life, The Universe, and Politics 6 Jan 19, 2003 07:18 PM