Thread Tools
Old Aug 04, 2011, 04:24 PM
rob38 is offline
Find More Posts by rob38
Registered User
rob38's Avatar
hi guys

I send a beta mask to volto
I hope it,s arrive next week

Rob
Sign up now
to remove ads between posts
Old Aug 04, 2011, 05:52 PM
Franck is offline
Find More Posts by Franck
-plancks only-
Franck's Avatar
I bought one of these too from ebay a couple of weeks ago (75 bucks). Indeed with defect battery. Changed the batterly last night with a 500mA cell from an old flying pack. My old battery was totally dead (1V). Works nice now. No bluescreens, quite responsive on loss/restore of signal.

Its a nice set, clear picture, only got it with Iphone connector so I need to make a new one for the FTP video reciever.

There is a bad connection from remote to glasses, these connectors are sooo fragile. Will probably make the connection permanent.

One thing I noticed, this is a half / see through goggle, to make sure you are not totally blocked from outside..that is disturbing for FPV i guess, other thing is that there are reflections around the LCD (on all sides) Its probably a good thing when the inside of the goggles are painted matte black or so. Will think about that some more. Also, to put the remote+electronics separate in a flimsy remote is not good for FPV, too fragile for "in the field".
Will fix that too.

manual is found here :

http://www.meijer.com/assets/product...0EN_manual.pdf
Last edited by Franck; Aug 04, 2011 at 06:00 PM.
Old Aug 04, 2011, 11:09 PM
pdiddyg40 is offline
Find More Posts by pdiddyg40
Flying low is expensive.
pdiddyg40's Avatar
Where are you guys finding these? Haha. So far I've only ever seen a Myvu Crystal, not the Crystal EV
Old Aug 05, 2011, 12:34 AM
volto is offline
Find More Posts by volto
Navigator
volto's Avatar
Sounds like maybe your cable is dirty or has a bad connection. Try cleaning it (the flat connector) with alcohol, and maybe blow it out with an air compressor.

Quote:
Originally Posted by doggit View Post
ok guys, anyone having trouble with their goggles, mine keeps loosing picture in the left screen, and also yesterday i was out and while flying my goggles were black and white, i checked my camera in my tv and it was full colour, so maybe my goggles have a fault
carl
Old Aug 05, 2011, 12:37 AM
volto is offline
Find More Posts by volto
Navigator
volto's Avatar
Quote:
Originally Posted by pdiddyg40 View Post
Where are you guys finding these? Haha. So far I've only ever seen a Myvu Crystal, not the Crystal EV
Just search ebay for "myvu crystal", there are always a few on there.
Old Aug 05, 2011, 06:09 AM
Franck is offline
Find More Posts by Franck
-plancks only-
Franck's Avatar
http://cgi.ebay.com/ws/eBayISAPI.dll...=STRK:MEWNX:IT

This is where I bought mine.

@doggit : i have the sameproblem, it is indeed the connector to the glasses...they are too fraginge for this purpose, let alone FPV. Im going to make it a permanent connection. HAve to fugure out how to open the connector on the glasses cable.
Old Aug 05, 2011, 11:28 AM
volto is offline
Find More Posts by volto
Navigator
volto's Avatar
There are a lot of small wires in there, must be an LVDS connection. Soldering those strait to the main board would be a pretty difficult soldering job.
Old Aug 13, 2011, 06:39 PM
beaverlover is offline
Find More Posts by beaverlover
Registered User
Anyone have issues with the screen in either lens turning white or washing out badly? Things to check? Voltage it at 4 volts so it isn't the battery.
Old Aug 14, 2011, 04:41 AM
thnilsen is offline
Find More Posts by thnilsen
Registered User
thnilsen's Avatar
Quote:
Originally Posted by beaverlover View Post
Anyone have issues with the screen in either lens turning white or washing out badly? Things to check? Voltage it at 4 volts so it isn't the battery.
Yes. Mine gets a white'ish look after a few minutes of use. Haven't found any way of preventing it from happening. Could be that the electronic get's heated up too much.

- Thomas
Old Aug 14, 2011, 03:06 PM
volto is offline
Find More Posts by volto
Navigator
volto's Avatar
Yes mine wash out badly too. I ordered this adjustable video amplifier to hopefully sort it out. I think the reason this is happening is because the myvu expects a very specific video signal (probably based on what the ipod outputs) and if it's slightly off-spec then it looks messed up. So hopefully I will be able to adjust the gain so it looks correct regardless of how off-spec the source video signal is. Can probably get the same effect from putting a resistor on the video input but I haven't tried.
Old Aug 14, 2011, 03:51 PM
rob38 is offline
Find More Posts by rob38
Registered User
rob38's Avatar
Quote:
Originally Posted by volto View Post
Yes mine wash out badly too. I ordered this adjustable video amplifier to hopefully sort it out. I think the reason this is happening is because the myvu expects a very specific video signal (probably based on what the ipod outputs) and if it's slightly off-spec then it looks messed up. So hopefully I will be able to adjust the gain so it looks correct regardless of how off-spec the source video signal is. Can probably get the same effect from putting a resistor on the video input but I haven't tried.
that video amplifier works fine
but when you plug in and out the video a lot
you can have problems

https://www.rcgroups.com/forums/show...&postcount=575

rob
Old Aug 14, 2011, 04:31 PM
beaverlover is offline
Find More Posts by beaverlover
Registered User
The guy offered to refund me on ebay....going to go another route. Don't feel like messing with them.
Old Aug 14, 2011, 06:32 PM
volto is offline
Find More Posts by volto
Navigator
volto's Avatar
Thanks for the tip Rob. I will use an extension on it so I don't have to plug/unplug from the device itself.

I know how you feel beaver, sometimes I just want to get something that will work consistently with no extra work on my part. I am sticking with mine because they have awesome image quality. I have tried fatsharks and like the myvus better. The viewing angle is narrower but the picture is better IMO.

Maybe later when my budget allows for a convenient grab-and-go-fly solution I will get fatsharks or the foxtech AIO.
Old Oct 02, 2011, 05:18 PM
thnilsen is offline
Find More Posts by thnilsen
Registered User
thnilsen's Avatar
Quote:
Originally Posted by volto View Post
Yes mine wash out badly too. I ordered this adjustable video amplifier to hopefully sort it out. I think the reason this is happening is because the myvu expects a very specific video signal (probably based on what the ipod outputs) and if it's slightly off-spec then it looks messed up. So hopefully I will be able to adjust the gain so it looks correct regardless of how off-spec the source video signal is. Can probably get the same effect from putting a resistor on the video input but I haven't tried.
Did you ever get this tested? I've more or less lost faith in the muvy glasses now since the white fade is such a nuisance. It happens both when doing flight video and when playing of a DVD player or similar. Takes a few minutes on my unit before it occurs, and if I leave the goggles turned off for a while they return to normal for a period. So I'm thinking it has something to do with components getting to warm or something. But it would be handy to know if the video amplifier helped or not.

- Thomas
Old Oct 02, 2011, 05:46 PM
Parity is offline
Find More Posts by Parity
Registered User
Parity's Avatar
I have exactly the same behavior. White washed out image on the left eye. Interesting thing is, that sometimes it does not occur for like 20 minutes. And sometimes it washes out after a couple of minutes.
If I swich off and immediatly on again it will work for like another minute. Same if I pull the connector and reconnect it. Bit will only help for very short time.
If I switch them off and keep them off for 10 minutes it will work very much longer.
I do not know, if "it" is in the remote or in the glasses itself.

Parity


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Question myvu crystal can't see video rx! Ingo FPV Talk 3 Oct 02, 2011 11:33 PM
Discussion .myvu solo plus ev fo fpv barok FPV Talk 5 Feb 25, 2010 12:42 AM
Sold MyVu Shades for AP FPV beeker_12 Aircraft - General - Miscellaneous (FS/W) 3 Feb 06, 2010 07:05 PM
Alert Solo Plus Personal Media Viewer-$59.95 Big Gunz 45 Hot Online Deals 0 Apr 24, 2009 04:02 PM
Discussion Myvu Crystal for ipod - only ipod? Brian_ FPV Talk 7 Mar 22, 2009 12:53 PM