New Products Flash Sale
Thread Tools
Old Aug 11, 2003, 06:28 PM
iflyelectric is offline
Find More Posts by iflyelectric
Registered User

Please Help! Slow Stick Problem with JR radios


Anyone else experience a problem with the motor cutting out when using a JR radio?
Setup:
JR Quatro Lite with an MPI 8A ESC, and 7C 720MaH pack
The motor cuts out, like the ESC is kicking in. If I remove all the equipment from the plane, the motor run time is normal. I've replaced all components, including another Quattro Lite, and an older JR radio, a 7C 500MaH nicad, a GWS 15A, and Castle Creations 35A ESC, all resulting in the motor cuts out if the setup is installed in the plane. Take it off the plane, run time is normal.
Setup #2:
Hitec Laser 4 with the same MPI ESC and 720MaH pack
Motor run time is normal.
QUESTION? Can the metal tube of the Slow Stick be interferring with the negative shift of the JR Radio?
Or, any other ideas?
Sign up now
to remove ads between posts
Old Aug 11, 2003, 07:17 PM
AirWarriorBelgy is offline
Find More Posts by AirWarriorBelgy
Captain Carnage says......
AirWarriorBelgy's Avatar
okay first off JR is positive shift as is GWS and airtronics

futaba and hitec are neg.

i have an SS and quattro lite that i fly all the time with no problem


8 amp esc is a little low (actually minimum) for the SS motor and 10 amp would be better.

but if you have the same problem with the gws 400 esc....you may have a faulty/ funny RX. or your trying to run a neg shift rx with a pos shift tx


Chuck
Old Aug 11, 2003, 08:30 PM
isvana is offline
Find More Posts by isvana
Random Flier
Sounds like the proverbial "loose connection".

Quote:
The motor cuts out, like the ESC is kicking in
When? Randomly? At full throttle? On the ground or in flight?
Quote:
If I remove all the equipment from the plane, the motor run time is normal.
What "equipment"? Receiver? ESC? Battery? Wings?
Quote:
I've replaced all components, including another (TX), (ESC), all resulting in the motor cuts out if the setup is installed in the plane
So the receiver works to your satisfaction and is not overloading the ESC? If you wire up the flight pack to your work surface, motor in a vise/vice etc, it all works OK there? If so, it could be some kind of interference problem...

FWIW: I use JR radio (TX + RX) on a Slowstick very happily. Its probably one of those annoying-but-simple problems - I have those often!
Old Aug 12, 2003, 09:32 AM
lascelles is offline
Find More Posts by lascelles
Registered User
I had the same problem with my Slow Stick. Changed ESC, swapped out radio, batteries also but no luck. Then while I was duplicating the problem on the bench I noticed that if I touched the metal fuselage of the SS the servo jittering and cutouts stopped. After some experimenting I think I have a fix. I soldered a small piece of wire to the motor case and then soldered (I used a small screw to secure) to the fuselage.

The problem seems to be fixed!

I'm not sure what's going here but this seems to point at the noisy (RF speaking) stock motor and the metal fuselage somehow generate or amplify inteference. Anyway give it a try and see. Good Luck


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion very odd problem with Jr Voyager E, please help b3guyRC10 Electric Heli Talk 16 Aug 17, 2006 10:30 AM
Dear Friends, please help me. I have a Problem with Mamba Link Schmitto Castle Creations 2 Nov 04, 2005 02:25 AM
Question HELP!! Slow Stick with PICO BB Servos... Will it work? tdavis Parkflyers 9 Mar 30, 2004 05:35 PM
slow stick problem roguewolf Beginner Training Area (Aircraft-Electric) 5 Oct 19, 2002 01:31 PM
Tx crystal swapping with JR radios K.C. Electric Heli Talk 7 Aug 03, 2002 08:34 AM