Problem with FrSky V8HT DIY module in Futaba tx - RC Groups
Thread Tools
Mar 25, 2011, 09:54 PM
Registered User

Problem with FrSky V8HT DIY module in Futaba tx

I recently purchased a FrSky V8HT DIY module and 2 V8FR receivers. Basically my problem is that the tx module only works in low power (ie range test) mode.

I installed the module in my Futaba 8UAPS tx (choosing the "hack" module so I could locate the antenna in the usual position). I soldered the +V lead to pin 2 of the connector for the original clip-in module, and the PPM input to pin 2 of the din trainer socket. The earth wire was soldered to an appropriate part of the circuit board which mounts the trainer plug and the connector to the clip-in module. The small board and antenna of the hack module were suitably mounted and all was ready for testing.

On turning on the tx the led lit (orange colour) - turning it on with the switch depressed made the led flash orange. The rx was powered up and the bind switch depressed resulting in the red led flashing as required to indicate binding was successful. The tx and the rx were again powered up, but any stick movement gave no response to the servos. With the tx off, the rx's red led flashed, but as soon as the tx was turned on it stopped flashing and remained lit, presumably indicating that the tx and rx were bound. Setting the failsafe was as it should be (green led flashing twice). Repeating everything with the second rx gave the same results!

I thought the problem must be the PPM input. The trainer port ran my FMS simulator perfectly, so clearly the PPM output there was fine and checking the web I found several sources agreeing that pin 2 was the output. Incidentally, the voltage there showed about 4.0V, but the diode should drop this to a suitable level. The PPM input to the original module was only around 20mV so I thought the trainer port was the way to go.

Quite by chance I put the tx into low power mode (by depressing the switch for a few seconds - led turns green with fast flash) while the rx was still on, and to my surprise everything then worked. Restoring full power made it "dead" again. I thought that maybe I was too close, overloading the rx, but moving some distance away made no difference!

I have checked everything many times- the only slightly strange thing is the voltage to the hack module is 10.08V in low power mode and 9.98V in normal mode (battery voltage was 10.13V). Clearly there is some resistance between the battery and the place where I picked up the switched +V, but I cant see how 0.1V would make a difference. (And voltages are well within the 6 - 13V specs.)

Has anyone had this problem (and know a fix) or is it just a faulty module?
Last edited by RobEm; Mar 29, 2011 at 03:09 AM. Reason: Make it easier to understand.
Sign up now
to remove ads between posts
Mar 26, 2011, 02:04 PM
Suspended Account
I ordered a FrSky DIY module for use in JR378; expect to arrive in a week.

I hope I don't get in trouble like you. If I do, I will post it here.
Mar 29, 2011, 03:07 AM
Registered User

Problem solved!

Taking the PPM feed from pin one of the male socket for the original Futaba rf module resulted in everything working as it should. Note that the voltage on this pin is only about 20mV without a module connected (which is why I chose the trainer port in the first place), but after the FrSky module was connected it rose to about 500mV.

I would like to know the reason for the previous behaviour. I have only a fairly basic understanding of electronics, and all I can think of is there is some rf feedback superimposed on the PPM signal, and reducing the power level reduced it to an "acceptable" level. There are some components (for filtering of the signal?) between the trainer port and the original module connector, and maybe this also reduces the rf feedback sufficiently.
Mar 29, 2011, 05:06 AM
Registered User
PPM output for the RF module in Futaba transmitters have a transistor with open collector
Mar 29, 2011, 12:11 PM
Suspended Account
Originally Posted by RobEm
Taking the PPM feed from pin one of the male socket for the original Futaba rf module resulted in everything working as it should. .
So, PPM feed should be taken from board RF out , not from trainer port?

With JR378, I need not worry about this problem. JR378 has internal RF module with 3 wire terminal for PPM and power supply.
Last edited by John Kim; Mar 30, 2011 at 12:21 PM.
Mar 31, 2011, 12:21 AM
Registered User
Originally Posted by John Kim
So, PPM feed should be taken from board RF out , not from trainer port?
For a Futaba tx it would seem that the PPM feed should be taken from the PPM input to the rf module (not the output).

It would appear that that it will be very straightforward to fit the FrSky module into your JR.

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Build Log Adding FRSKY diy hack module to my worn out dx7 Jabird Radios 5 Sep 06, 2016 08:46 PM
Discussion Frsky DIY hack module into Hitec Flash 5? rotagen Radios 24 Feb 14, 2012 02:52 AM
Discussion FrSky V8HT 2.4G + Hitec Neon SS _shadow_ Radios 28 Nov 18, 2011 02:35 PM
Question Ol' Futaba Conquest PCM and FrSky V8HT Wedding orsi bruno Radios 16 Apr 16, 2011 07:53 PM
Discussion FrSky DIY module in a Futaba 3PM radio Beau0090_99 Radios 2 Jul 08, 2010 02:05 PM