Thread Tools
Old Mar 19, 2011, 08:22 PM
Mark taylor is offline
Find More Posts by Mark taylor
Registered User
Discussion

OSD Pro Firmware update fail


Just got a new OSD Pro and went to do the firmware update. Downloaded the latest from the website, updated the Eagleeyes and the elogger4. They did good. The OSD Pro not so good...... It says firmware needs updating, update it, and no luck. Multiple attempts, including downloading latest from ETS.
Any help out there?

Mark Taylor
Team JR/Horizon
Sign up now
to remove ads between posts
Old Mar 19, 2011, 09:10 PM
garand is offline
Find More Posts by garand
Registered User
I had encountered this exact same scenario. It seemed to be a power issue. I found a USB cable with dual connectors on one end, one for power and the other for power + data. This is what eventually worked for me. Below you will find a link to something similar to my cable.

http://www.amazon.com/Cables-Go-2810...583355&sr=8-15
Old Mar 20, 2011, 10:49 AM
Mark taylor is offline
Find More Posts by Mark taylor
Registered User
Thanks for the reply! Will powering it with the flight battery do the same thing?
Old Mar 20, 2011, 11:16 PM
billpa is offline
Find More Posts by billpa
billpa's Avatar
Mark, is it possible that you are not clicking "OK" on the OSD Configuration page that comes up shortly after the firmware update? THis is required to complete the update process.

In a few days, we'll be posting a new software version that delays the "Firmware Update Complete" message until AFTER you've clicked "OK" on the configuration page, which should make this confusion go away.
Site Sponsor
Old Mar 21, 2011, 09:49 AM
Mark taylor is offline
Find More Posts by Mark taylor
Registered User
Yes, I was doing all the steps by the numbers. I completely started from scratch, erased the program and reloaded it on the laptop. Reconfigured the hardware and did the firmware update, this time successfully!
Don't ask me why, but the elogger and eagleeyes took the update the first time, not the OSD pro. Go fish.........
Thanks for your help!

MT
Old Mar 21, 2011, 08:36 PM
garand is offline
Find More Posts by garand
Registered User
I don't actually know as I did not have the battery connected to mine while I was configuring the unit.

Quote:
Originally Posted by Mark taylor View Post
Thanks for the reply! Will powering it with the flight battery do the same thing?
Old Mar 24, 2011, 01:09 AM
billpa is offline
Find More Posts by billpa
billpa's Avatar
Hi Mark, that is strange. My best hypothesis is that there was an issue with USB. We get reports occasionally of USB incompatibility with some PCs, but they are few and far between, and often intermittent. :S
Site Sponsor
Old Mar 24, 2011, 07:39 AM
garand is offline
Find More Posts by garand
Registered User
I also use a USB 1.0 cable in a USB 1.0 port. Sometimes external hard drives, etc. will install USB boost software. I would suggest shutting that off as well.
Old Mar 24, 2011, 11:33 AM
Mark taylor is offline
Find More Posts by Mark taylor
Registered User
Everything seems to be working as advertised, at least I didn't release the magic smoke!
Old Oct 16, 2011, 06:50 AM
Telefisch is offline
Find More Posts by Telefisch
Registered User
Hello I just tried to update my recorder after connecting my new guardian.
Result:
eLogger V3 FW is 5,93 but the software prompts me to update to 5,93.
OSD-Pro FW is unknown and Update fails with error. (without any specification)
Guardian also is unknown and also fails.
What can I do now?
Old Oct 18, 2011, 07:12 AM
camship is offline
Find More Posts by camship
Resistance is Futile
camship's Avatar
Quote:
Originally Posted by Telefisch View Post
Hello I just tried to update my recorder after connecting my new guardian.
Result:
eLogger V3 FW is 5,93 but the software prompts me to update to 5,93.
OSD-Pro FW is unknown and Update fails with error. (without any specification)
Guardian also is unknown and also fails.
What can I do now?
Are you providing power to the ET system other than the USB? If not you may need to power up your system and then connect the USB with it powerd on and try to update.

Sometimes it is a current issue with USB ports and just to make matters worse Windows does a really poor job of power management on the USB ports and will turn it off at very inopportune times.

You can manually set the USB ports in the system to NOT ALLOW the computer to turn them off to save power.

Good Luck!

Rob
Old Oct 18, 2011, 03:31 PM
Telefisch is offline
Find More Posts by Telefisch
Registered User
Hello, I tried both...
with and without external power.
Somone told me to try the older Softwareversion (10.4).
I'll try asap but I'm on Holyday. So this will last a few days.
So thanks for answer so far...


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Question OSD Pro, eLogger V3, GPS V4 problems updating firmware in OSD Pro jbfoamy Eagle Tree Systems 23 Jun 02, 2012 03:59 PM
Alert GoPro Hero HD firmware update released!!! _Sibi_ FPV Talk 106 Feb 15, 2011 09:28 AM
Discussion The GoPro HD firmware update is finally here! jab FPV Talk 2 Oct 02, 2010 07:34 AM
Help! OSD Pro Update Problem S11D336B Eagle Tree Systems 4 Jun 15, 2010 09:08 AM