Thread Tools
Jun 04, 2011, 02:01 PM
DJI Support
Tahoe Ed's Avatar
Paul thanks to you, Berkely and Oleg for getting these diagrams out to everyone. It is much appreciated.
Latest blog entry: M200 FAQ's
Sign up now
to remove ads between posts
Jun 04, 2011, 02:12 PM
Registered User
M4d_D's Avatar
hi, would anyone please post a picture on which i can see every cable ? the schematics dont tell me very much and i really dnt want to fry anything here .

i use the flyduino , the sensor bob and jussis ff imu ....

on this picture the arrow goes the other way than on my flydusense 1.1 , which one is wrong now ? or did someone change it in the code ?


cheers
Jun 04, 2011, 02:52 PM
OS Sponsor
kinderkram's Avatar
Quote:
Originally Posted by M4d_D
hi, would anyone please post a picture on which i can see every cable ? the schematics dont tell me very much and i really dnt want to fry anything here .

i use the flyduino , the sensor bob and jussis ff imu ....

on this picture the arrow goes the other way than on my flydusense 1.1 , which one is wrong now ? or did someone change it in the code ?

cheers
It's been said before:
- the big arrow on v1 is pointing to the right. The X-arrow is pointing to the real front (left on this image) and the pins of the FFIMU should point to the back. It's been corrected on v1.1
- the sensor board/shield has to be either powered by 5V or 3,3V, not both
- you can connect the FFIMU 1.22L directly to the 5V pin in the I2C connectors row

Since Paul wanted to create a shield that fits the needs of different MultiWii, AeroQuad and MegaPirate sensors you'll find more connections than usually needed.
Jun 04, 2011, 02:56 PM
Registered User
M4d_D's Avatar
Quote:
Originally Posted by kinderkram
It's been said before:
- the big arrow on v1 is pointing to the right. The X-arrow is pointing to the front and the pins of the FFIMU point to the back. It's been corrected on v1.1
- the sensor board/shield has to be either powered by 5V or 3,3V, not both
- you can connect the FFIMU 1.22L directly to the 5V pin in the I2C connectors row

Since Paul wanted to create a shield that fits the needs of different MultiWii, AeroQuad and MegaPirate sensors you'll find more connections than usually needed.
on the picture 3.3 and 5v are connected , why ? does it make any difference ? does it damage anything if both are connected ?
Jun 04, 2011, 03:24 PM
Registered User
M4d_D's Avatar
i just connected 5v now and connected it to the pc . leds are working

the multiwii software on the other hand isnt. lcd cant be defined in the dev version
Code:
MultiWii_dev20110529.cpp: In function 'void LCDprint(uint8_t)':
LCD:11: error: 'PORTE' was not declared in this scope
MultiWii_dev20110529.cpp: In function 'void configureReceiver()':
RX:25: error: 'DDRK' was not declared in this scope
RX:26: error: 'PORTK' was not declared in this scope
MultiWii_dev20110529.cpp: In function 'void __vector_5()':
RX:51: error: 'PINK' was not declared in this scope
Jun 04, 2011, 04:00 PM
Registered User
Goofy23's Avatar
i only connected it to take a regular 3 pin connector, you dont need the 3.3V, sorry, but they dont disturb.
Jun 04, 2011, 04:53 PM
Registered User
M4d_D's Avatar
Quote:
Originally Posted by Goofy23
i only connected it to take a regular 3 pin connector, you dont need the 3.3V, sorry, but they dont disturb.
okay , it seems to power up when connected to pc , i was able to upload the multiwii software and the gyros dont seem to work , at least they dont work in the gui , any idea there ?
Jun 04, 2011, 05:39 PM
Hovership
3rdeyepro's Avatar
You need power from an ESC in addition to having the FTDI power. The sensors won't read proper in the gui without power from an ESC.
Jun 04, 2011, 06:31 PM
Registered User
Gaza07's Avatar
I read on another thread for a different board that if you power the board with 5v from an external source than you should not connect the 5v rail from the FTDI,
I made a little adapter with the 5v rail removed there are pictures below altho it says 3v3 on the FTDI it is the 5v version,
Is this the case with the Flyduino board is it better to remove the 5v rail from the FTDI when powering from another source, can it damage the FTDI if you do connect both,
I have always used my little adapter to be safe rather than sorry
Jun 04, 2011, 06:59 PM
Registered MisUser
whiteturbo's Avatar
My Bad
Last edited by whiteturbo; Jun 04, 2011 at 07:08 PM.
Jun 04, 2011, 07:06 PM
Registered MisUser
whiteturbo's Avatar
Quote:
Originally Posted by 3rdeyepro
You need power from an ESC in addition to having the FTDI power. The sensors won't read proper in the gui without power from an ESC.
Thats True of Jussi's Shield but the Flyduino Displays as it should in the Gui with just the USB/FTDI and doesnt need any additional power
Jun 04, 2011, 08:24 PM
Hovership
3rdeyepro's Avatar
Oops sorry.
Jun 05, 2011, 05:07 AM
Registered User
hubibubi's Avatar
Quote:
Originally Posted by M4d_D
okay , it seems to power up when connected to pc , i was able to upload the multiwii software and the gyros dont seem to work , at least they dont work in the gui , any idea there ?
have you enabled these lines in the sketch?

/* I2C gyroscope */
#define ITG3200
//#define L3G4200D

/* I2C accelerometer */
//#define ADXL345
//#define BMA020
#define BMA180
//#define NUNCHACK // if you want to use the nunckuk as a standalone I2C ACC without WMP

/* I2C barometer */
#define BMP085

/* I2C magnetometer */
//#define HMC5843
#define HMC5883

hubibubi
Jun 05, 2011, 08:45 AM
Registered User
M4d_D's Avatar
Quote:
Originally Posted by hubibubi
have you enabled these lines in the sketch?

/* I2C gyroscope */
#define ITG3200
//#define L3G4200D

/* I2C accelerometer */
//#define ADXL345
//#define BMA020
#define BMA180
//#define NUNCHACK // if you want to use the nunckuk as a standalone I2C ACC without WMP

/* I2C barometer */
#define BMP085

/* I2C magnetometer */
//#define HMC5843
#define HMC5883

hubibubi
yes i have enabled these
Jun 05, 2011, 09:29 AM
Registered User
EnryCorser's Avatar
finally it flew


Thank you all !!!!
(waiting for jussy IMU and then i'll try Megapirate's code)....




Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product Please let me introduce myself jimaquo Dock Talk 7 Oct 27, 2010 02:27 AM
Let me introduce the DEMON!!!! (Transparent covering and eliptical wing!!!) modest-master Sport Planes 7 Aug 25, 2002 11:46 PM
Let me introduce Angelis 280/400, Benjamin, Zombi (ARFs) modest-master Parkflyers 17 Mar 14, 2002 01:20 PM
Let me introduce the "NIKE" modest-master Electric Sailplanes 3 Mar 07, 2002 05:20 AM