Nine Eagles Solo/BravoIII/Draco FAQ (also for rebranded ones like Revell ProtoCX etc) - Page 7 - RC Groups
Shop our Airplanes Products Drone Products Sales
Thread Tools
This thread is privately moderated by SoloProFan, who may elect to delete unwanted replies.
Feb 27, 2011, 03:52 PM
Registered User
ben je trouwens nederlands?
Sign up now
to remove ads between posts
Feb 27, 2011, 04:04 PM
Fan of just about anything RC
SoloProFan's Avatar
Quote:
Originally Posted by GuusBots
SoloPro, you are right, they are both broken, thanks very much for the help. You are the best!
Quote:
Originally Posted by GuusBots
ben je trouwens nederlands?

Glad to be able to help, and that you found the cause of your problem. I added one of your pictures to the FAQ, to show how broken blade pivots might look like. I trust you don't mind using that pic, right?


En ik ben inderdaad nederlands.

(translation, GuusBots asked if I was Dutch, and I confirmed that)
Last edited by SoloProFan; Feb 27, 2011 at 04:10 PM.
Feb 27, 2011, 04:43 PM
Registered User
No problem mate, thanks for the help!
Mar 01, 2011, 05:44 AM
Registered User
great mini heli, i think this nine eagles model is resemble with the hughes heli
Mar 01, 2011, 07:03 AM
Fan of just about anything RC
SoloProFan's Avatar
Quote:
Originally Posted by rcairplanes
great mini heli, i think this nine eagles model is resemble with the hughes heli
The Bravo III has a Hughes 500 fuselage, if that is what you mean...
Mar 02, 2011, 12:06 PM
Registered User
Hey SoloPro,

As you might remember i had 2 broken blade pivots for the lower blades of my Bravo III. I replaced the thing on the axel which has the pivots on it. Now i have the same problem as before, i can get it to hover steady without much trim but now it hardly goes forward and hardly banks left. Flying backwards goes fine and rotating goes fine and banking to the right goes fine. But flying forward and banking left is problematic. Do you have some tips for me on how to fix this?
Mar 02, 2011, 01:55 PM
Fan of just about anything RC
SoloProFan's Avatar
Quote:
Originally Posted by GuusBots
Hey SoloPro,

As you might remember i had 2 broken blade pivots for the lower blades of my Bravo III. I replaced the thing on the axel which has the pivots on it. Now i have the same problem as before, i can get it to hover steady without much trim but now it hardly goes forward and hardly banks left. Flying backwards goes fine and rotating goes fine and banking to the right goes fine. But flying forward and banking left is problematic. Do you have some tips for me on how to fix this?
Trims are centered when in steady hover? If not, try to get them to center by using subtrim. Also observe if the servos move an equal amount in both direction and what happens when you give forward elevator or left bank/roll when the heli is on the ground.
Mar 02, 2011, 03:13 PM
Registered User
Yeah, i trimmed the helicopter in subtrim mode (i find that easier) and made some little adjustments in normal mode. The weird thing is that the servos seem to move an equal amount when the helicopter is idle. I really have no idea why it is behaving so strange..
Mar 02, 2011, 03:55 PM
Fan of just about anything RC
SoloProFan's Avatar
Quote:
Originally Posted by GuusBots
Yeah, i trimmed the helicopter in subtrim mode (i find that easier) and made some little adjustments in normal mode. The weird thing is that the servos seem to move an equal amount when the helicopter is idle. I really have no idea why it is behaving so strange..
Sure there is not too much play on the bottom shaft? There is a small plastic collar that holds the shaft in place, but it's very easy to over tighten the screw in that collar, and cause it to split near the screw hole. The collar then can slide a little on the shaft, and the shaft itself as well. Banking left and forward elevator will pull down on the swash plate. When there is too much play on the shaft, in the air the shaft will slide up a little, and when you then apply forward elevator, the first part of the servo travel will be used to slide the shaft down, leaving little travel left to move the blades.
Last edited by SoloProFan; Mar 02, 2011 at 04:17 PM.
Mar 03, 2011, 07:50 AM
Registered User
Quote:
Originally Posted by SoloPro
Sure there is not too much play on the bottom shaft? There is a small plastic collar that holds the shaft in place, but it's very easy to over tighten the screw in that collar, and cause it to split near the screw hole. The collar then can slide a little on the shaft, and the shaft itself as well. Banking left and forward elevator will pull down on the swash plate. When there is too much play on the shaft, in the air the shaft will slide up a little, and when you then apply forward elevator, the first part of the servo travel will be used to slide the shaft down, leaving little travel left to move the blades.
I'm pretty sure that the collar is screwed on in the right way, i checked for play with the inner and outer shaft and i can't find any play on them. I trimmed it again in subtrim mode, holding the helicopter in my hand and applying throttle and looking at the swash plate and trimming until that was horizontal. Then it flew like it should do, until i crashed and now it is back to flying weird..
Mar 03, 2011, 10:54 AM
Fan of just about anything RC
SoloProFan's Avatar
I'd say, post a couple of pictures again, maybe we can spot what is wrong for the second time.
Mar 05, 2011, 03:29 AM
Brosol
Brosol's Avatar

Upgrading 210A with 312A Bravo III motors


Is it possible to upgrade 210A motors with 312A Bravo III motors?
Mar 06, 2011, 01:27 PM
Registered User
Quote:
Originally Posted by GuusBots
I'm pretty sure that the collar is screwed on in the right way, i checked for play with the inner and outer shaft and i can't find any play on them. I trimmed it again in subtrim mode, holding the helicopter in my hand and applying throttle and looking at the swash plate and trimming until that was horizontal. Then it flew like it should do, until i crashed and now it is back to flying weird..
I know this is a basic question, but do you have the tx in standard mode or advanced? In standard mode, mine will barely move forward but will go backwards pretty fast, like you said yours is doing. Switching to advanced mode solves that for me.
Mar 06, 2011, 05:54 PM
Brosol
Brosol's Avatar

210A Elevator servo problem


My 210A will get stuck in forward flight and I can't get it to return back to a hover or fly backwards.

The elevator servo will move for forward input but won't return back to its middle position or move for backward input.

There are no physical jams or binding. I tried sub trim, end of point adj for backward endpoint, mode 2, mode1.

Nothing seems to work. Is there a way to reset the trims and EPA to factory defaults?
Last edited by Brosol; Mar 06, 2011 at 06:00 PM.
Mar 08, 2011, 12:37 PM
Registered User
Quote:
Originally Posted by laarj
I've logged 20 flights or so on my Bravo III and have a couple of questions.

After addressing the obvious issues, I checked out the controls and all seemed to work ok. I then ran up the throttle and noticed that the inner shaft gear was out of round by a large margin. On low throttle, there was a very noticeable vibration. Prior to taking the Bravo III apart, I noticed a tail vibration when hovering. This was there from day one so it wasn't from my landing skills. I took the gear and inner shaft out and found that the gear/locking collar assembly was out of round. Has anyone seen this?
Update on gear issue...

Received a replacement inner shaft gear and collar. The original gear was definitely out of round. The collar was fine. The vibration is gone and the Bravo III flys great.

Kudos to ClubHeli for their fast service....


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
FAQ Nine Eagles Solo Pro I/II/V1/V2/270/Bravo SX FAQ (FAQ part in the first 3 postings!) SoloProFan Micro Helis 2138 May 11, 2016 02:24 PM
Discussion Revell Proto cx and Nine Eagles Solo Free Spirit EFEX ED Coaxial Helicopters 7 Feb 10, 2013 11:20 AM
New Product Nine Eagles Soar - Replacement for Solo Pro? zadaw Micro Helis 1 Dec 30, 2010 03:15 AM
Discussion Revell Proto MAX RTF/Nine Eagles Solo Pro RTF $69.99 at Tower Hobbies Firehawk989 Hot Online Deals 1 Sep 29, 2010 01:16 AM
Wanted MCX, Nine Eagles Solo, Proto CX RTF k5beason Aircraft - Electric - Helis (FS/W) 0 Apr 18, 2010 09:02 PM