CRRCSim for Linux - Page 3 - RC Groups
Thread Tools
Mar 25, 2007, 03:14 PM
Got shenpa?
flieslikeabeagle's Avatar
Well, that turned out to be easier than I thought (on SabayonLinux, which is a Gentoo Linux derivative). After a little Googling I found portaudio version 18.1-r6 was available in the Gentoo packages, so all I had to do was remove the installed version 19 and then install version 18.1-r6:

emerge --unmerge portaudio <---remove old version of portaudio
emerge -v =media-libs/portaudio.18.1-r6 <--- and install version 18.1-r6

CRRCSIM 0.9.8 then compiled and linked without a murmur.

Sign up now
to remove ads between posts
Mar 28, 2007, 11:32 PM
Got shenpa?
flieslikeabeagle's Avatar

"Sport2" aerobatic electric foamie for CRRCSIM 0.9.8

There are not a whole lot of powered models in CRRCSIM yet, and only one which is "sporty. Unsurprisingly, that one is called "sport" and is a model of a glow-powered sport plane.

As I mentioned earlier in this thread, each time I install a new version of CRRCSIM I go into the config file for this model and hack it with a text editor until the model flies more like an aerobatic foamie and less like a heavy glow or gas powered sport plane. I lower the mass and moments of inertia, move the CG backwards a bit, take out the wing incidence angle built into the model (so it flies the same right side up or inverted), and modify the powerplant to simulate an electric motor better. I also modify the thrust and pitch speed to better simulate a typical electric parkflyer powerplant. Most of this is done by trial and error as I can find almost no documentation on these config files.

In case anyone wants to mess with my hacked version of the "sport" model, I'm attaching a zip file. Unzip it and you will get a folder called "sport2_files". Inside that folder you will find three files: sport2.xml,, and sport2_tex.rgb.

These three files need to be copied into the "models", "objects", and "textures" folders respectively inside whatever folder you installed CRRCSIM to. On a Linux box, CRRCSIM should be in the folder /usr/local/share/games/crrcsim/ , and you will find the "models", "objects", and "textures" files inside it. I have no idea what happens on Windows, since I no longer use it, but presumably once you find the main CRRCSIM folder you will find these three subfolders inside it.

Now restart CRRCSIM, and you should see a new model called "sport2" in the list. If you don't want to hunt through all the installed models, you can use the pick-list to look only at electric-powered models: start CRRCSIM -> hit Esc key t bring up menu -> Actions -> Airplanes -> Select category -> Electric. You should see Sport2 in the list.

Let me know if you have any feedback on how this model flies. I've left it heavy enough so it will still tipstall if you slow it down far enough, but light enough to "float" like a good foamie. My goal was to make it fly like a well built GWS Formosa.

One day I hopefully I will figure out how to make substantial changes to the appearance, for now "sport2" looks exactly like "sport".

Mar 30, 2007, 02:44 PM
You sabotaged my plane.
eliworm's Avatar
Originally Posted by flieslikeabeagl
Eliworm, thanks for the tip about Dreamlinux (which I was not familiar with). The only thing is, CRRCSIM needs OpenGL enabled - and only a few live-CD's enable OpenGL automatically. Ones I know of include Kororaa, SabayonLinux, and any others that automatically enable the fancy new accelerated desktops (wobbly windows, etc). Unfortunately life has been busy and I have put zero time or energy into the idea of a CRRCSIM live-CD since my last post on the subject.

Thanks for posting your latest on your use of CRRCIM.

Dreamlinux, at least on my computer, enable OpenGL by default. As well as Knoppix. I know depending on hardware others may have different results. I ended up loading DreamLinux to the desktop as I am a fan of xfce. I reloaded Slackware on my laptop the other day after not using it for awhile. I forgot what it was like not having everything handed to you.

Mar 31, 2007, 11:18 PM
Got shenpa?
flieslikeabeagle's Avatar
Jim, I guess I'll have to download and try out DreamLinux now!

I did a bit more tweaking on the "sport" model in CRRCSIM. The version I have now is pale yellow, partially translucent, and has a green stripe along the underside of the leading edge of the wing.

It is slow going, as there is no documentation I can find, and I'm trying to guess what all the numbers in the "" file mean.

Apr 14, 2007, 12:20 AM
tailStrike's Avatar
It's good to see some Linux users on here - I was searching around for a Linux RC sim and stumbled on this thread. I have been going back and forth between doze and linux for a number of years and just installed openSuSE 10.2 last night and think I have finally found the best distro for me. If I can find a good sim, I won't have any reason to boot window$ any more. I've had the best luck with this install - I haven't hit a snag yet and I only needed to open the terminal a few times to get everything configured (and probably could have gotten away without it). The only reason I have to boot windows right now is RF 3.5. I'm stoked!
Apr 14, 2007, 05:43 AM
Registered User
Hi fellas,

PCLinuxOS live CD also enables OpenGL by default, with vist@ like desktop (and is the only distro that would install itself onto the hidden partition on my IBM T41 *and* automatically configure wpasupplicant to connect to my router)

I have CRRCSim running on XP at the moment but I'll be trying it out on Linux as well.


May 07, 2007, 04:34 PM
Got shenpa?
flieslikeabeagle's Avatar
tailStrike, good luck with Suse, and please let us know if you get CRRCSIM working on it! I tried OpenSUSE last year, it was pretty and very solidly integrated together, but it was also unacceptably slow on my hardware, so off it came.

If you hit snags with OpenSUSE, you might give Mepis Linux a try (it's an installable Live CD, so you can try without installing). I found it very solid and trouble-free, also very good at autoconfiguring everything out of the box.

Kim, same thing - please let us know if you get CRRCSIM to work on PCLOS. I did see an RPM package for CRRCSIM 0.9.8 on the Sourceforge site, but I don't know if that particular RPM will work on PCLOS or not.

At one time I used Mandrake, but I found RPM's that would only work on one distro - and that too only one version of that distro - very frustrating, which drove me to Gentoo after trying several alternatives (from Slackware to Debian), and I've been there since (most recently with Sabayon, a Gentoo derivative).

May 14, 2007, 12:26 AM
Registered User
Got it working with my DX-6 on fedora core 5.
as I stated in my previous post, I installed the nvidia driver and got the video. CRRCSIM now exists as an rpm for fedora, so I installed that. Couldn't get the audio interface with the tx to work. Turns out portaudio needs oss audio installed, so I got the most recent version of that and installed. You need the kernel-devel package to install the kernel headers. I had to delete some file in the /usr/lib/oss directory, starting.log or some such. Then start it by hand once. If you restart x then, the alsa libs should be emulated by the oss libs

As usual, I should have kept notes, but failed. Hopefully this help get some people started.
Aug 27, 2013, 09:41 PM
Powerbud's Avatar

Setup notes for crrcsim-0.9.9 and crrcsim-0.9.12 on Linux Mint 13

This seems the best place to put these setup notes without starting a new thread.

Once I gave up looking for someone elses solution and started looking at error messages, modifying the system to compile crrcsim was a direct and fairly quick process. I just took it one step at a time, installing each library as needed and testing that it fixed a reported error before going on to the next reported error. I didn't have to look at a single line of code, so that bodes well for someone else using these notes as a guideline to setting up these or other versions of CRRCSim on Linux Mint or other verions of Linux.

These notes are for installing two versions of crrcsim on Linux Mint 13. If you use a different distibution the changes shown may give you some idea of what to look for while setting crrcsim up to work in it. To figure it out for myself I kept running ./ and looking at error messages and then when that was working, ./configure and doing the same. If I remember correctly, even make threw an error message for crrcsim-0.9.12 that one of the following changes corrected.

The source for both versions was tar.gz files from SourceForge - lots of good links there - and both were installed in a newly created /bin folder in my /home/username directory. All the package changes were done in the Synaptic package manager.

A Nvidia card is installed in my computer for 3D graphics - which one shouldn't make any difference - and the control box is a GWFSM003. The control box, with built in cable, costs about thirty bucks. Even though it plugs into a USB port, the input method selected is joystick and the device is Gam Gam. Input method and device selected are the same in Linux and Windows.

I had to use spoilers instead of flaps. They feel much the same in the simulator's Supra model as flaps on a real Supra, but on a Crossfire model don't seem to do much - can't speak for other models.

The simulator's mixes make up for the GWFSM003's which are non-existent.

I think Portaudio is just along for the ride in my system since I use the USB port, but I don't feel like removing it and recompiling just to be certain. You might try leaving it out initially.

Icons, for creating a "desktop configuration file", are in /packages/icons.

This simulator's Supra model has the feel of flying a real Supra, so it's perfect for getting tuned up before heading off to the flying field.


crrcsim setup:

install libsdl1.2-dev development package: libsdl1.2dev

install libplib-dev

install libjpeg-dev

install Portaudio-dev Note: removed libjack-jackd2-0


Using Portaudio V19 is not recommended by the CRRCsim team. If
you experience frequent crashes when using the audio
interface, please install Portaudio V18 and recompile CRRCsim."

install libcgal-dev

uninstall automake 1:1.11.3-1ubuntu2

install automake 1:1.10.3-1ubuntu1

I had to change the boost library for crrcsim-0.9.12 to libboost1.46-dev. Crrcsim-0.9.9 compiles and runs with version 1.46 or 1.48.

uninstall libboost 1.48 stuff

install libboost1.46-dev




Try to ignore all the warnings when compiling. There's so many of them that all I can think is it looks like inept, uncaring or plain old lazy programming. In defense of programmers everywhere, this is quite often the result of managerial time constraints and pressure to get it working and move off to something else.

At this point crrcsim can be run from the directory it compiled in:

Haven't tried this yet: don't have any need to:

sudo make install
Last edited by Powerbud; Aug 31, 2013 at 07:15 AM.
Sep 10, 2013, 03:56 PM
AMA 79169
rdstarwalt's Avatar
I am running Debian and cannot get the package manager to recognize or find the crrcsim package in my download section.

Don't hold your breath and try to find a 'how to' on installing this on Debian.

Any ideas? I will admit to not being a guru, but can find my way around the file structure. No wonder this software is rare to be found running on any system.
Sep 11, 2013, 09:36 PM
You sabotaged my plane.
eliworm's Avatar
Someone somewhere most likely has a .deb for CRRCsim but finding it could be an issue. The best solution is to just compile the software yourself. I'm currently running Linux Mint and would love to get the sim working again if I can ever find the time.


Thread Tools