Thread Tools
Old Apr 23, 2013, 07:24 AM
flipy is offline
Find More Posts by flipy
Registered User
Anyone with a rev 2.4 board can share the installation instructions?
Is it different from v2.2 onwards?
Sign up now
to remove ads between posts
Old Apr 23, 2013, 10:20 AM
s_mack is offline
Find More Posts by s_mack
Registered Loser
Device signature really has nothing to do with what program software you're using. Did you install the white 6-wire jumper cable?
Old Apr 23, 2013, 07:05 PM
R3volut3ion is offline
Find More Posts by R3volut3ion
Flip-n- GO!
R3volut3ion's Avatar
Yeah I had all jumpers in place. I had tried it with the telemetrEZ hooked up and not installed. Program is the latest eepe. Er9x frsky latest build. Ended up using Extreme burner AVR to flash the eprom. Updated the telemetrEZ with the latest build using t1634 programmer through the 2.4 smartieparts board. I know the eepe version i have works as I have used it to flash a v2.3 plus it reads the eprom. Just wont flash. The odd thing is I can change my model configs through eepe. I'm sure its just a setting or method i missed. Just not sure what.
Last edited by R3volut3ion; Apr 23, 2013 at 07:07 PM. Reason: missed text
Old Apr 23, 2013, 07:12 PM
s_mack is offline
Find More Posts by s_mack
Registered Loser
In eepe under the Burn menu you'll see something like "additional configuration". In there, enter this and tell me if it then works consistently:
Code:
-B 11
Old Apr 23, 2013, 07:16 PM
s_mack is offline
Find More Posts by s_mack
Registered Loser
Quote:
Originally Posted by flipy View Post
Anyone with a rev 2.4 board can share the installation instructions?
Is it different from v2.2 onwards?
Sorry I missed this post earlier. Also sorry I haven't gotten the 2.4 instructions up yet! My computer crashed last week and I only just got the replacement motherboard today. I'm way behind

Its mostly the same. There's a physical difference and now it only uses 3 screws/spacers instead of 4. The top right hole instead uses the included nylon standoff. Should be fairly obvious. Beyond that, you'll notice there are three 6-pin connectors instead of two. The one on the left is used with the new 6-wire harness that has the 5 white wires and 1 black one. You can completely ignore this if you don't have a TelemetrEZ. If you do, then plug in the cable and the black connector on it goes into the TelemetrEZ's ISP header with the black wire corresponding to the tiny arrow or circle (can't remember which I used!) that's printed on the TelemetrEZ board. That cable is used to update the TelemetrEZ firmware without need for a 3rd party programmer. To program the 9x, the 9x power must be on (as always since Rev 2.2) and to program the TelemetrEZ the 9x power must be off.

other than that, no significant differences. Drivers are the same. Usage is the same.
Old Apr 23, 2013, 07:23 PM
Tahuyeh is offline
Find More Posts by Tahuyeh
Helis & Floatplanes
Tahuyeh's Avatar

Rev 2.4 Programmer


@R3volut3ion - I have just installed the Rev 2.4 programmer board as well. I flashed my 9X to er9x r789 using Companion9x without a hitch. I did some playing around with the latest version of eepe, and had it give me that device signature error the first time I tried to (re)flash the firmware. I turned the er9x off and back on again and haven't had any problems since.

@All - The Rev 2.4 programmer board is a work of art. Flashing firmware was new to me, but sounded like it would really make the Turnigy 9x a fine radio. I glanced through the online installation instruction for version 2.2 and newer just to get an idea of what to do. Then went about installing the board and HK backlight. Everything needed (and more) was available. The installation went very well, and then firmware upgrade was a snap using Companion9x.

The SP board is worth every penny! The Turnigy er9x is now even a greater value, with flexibility beyond belief.
Old Apr 23, 2013, 07:38 PM
R3volut3ion is offline
Find More Posts by R3volut3ion
Flip-n- GO!
R3volut3ion's Avatar
Ok the -B 11 in eepe extra arguments works. Just a little slower flashing obviously but in my experience with jtag faster is not better lol.

@Tahuyeh
haven't tried that yet as i wasnt sure how to set it up and run it yet. Thanks for the heads up though! And you are right. The 2.4 is a work of art with the telemetrEZ board installed. Flashing it without having to open the radio is bliss!
Old Apr 23, 2013, 09:13 PM
Tahuyeh is offline
Find More Posts by Tahuyeh
Helis & Floatplanes
Tahuyeh's Avatar

Companion9x


@R3volut3ion - Companion9x installs just like eepe... actually, it is a glorified version of eepe. It also is a front end for avrdude. It just handles OpenTX firmware as well as er9x. Also, the simulator is a little spiffier. I've included my preferences screen to show you what's working for me.

BTW - Was just down in the San Tan Valley area visiting friends. Really enoy that Phoenix weather!
Ray
Old Apr 23, 2013, 09:33 PM
R3volut3ion is offline
Find More Posts by R3volut3ion
Flip-n- GO!
R3volut3ion's Avatar
I'll definitely check it out. Still learning all the possibilities of er9x as I come from the land of Deviation. I do wonder if anyone else has ran into this issue. Thus far some results have been made and all help appreciated! Thanks guys!

Phoenix weather is the best for flying lol!
Old Apr 24, 2013, 01:44 AM
s_mack is offline
Find More Posts by s_mack
Registered Loser
Quote:
Originally Posted by R3volut3ion View Post
Ok the -B 11 in eepe extra arguments works. Just a little slower flashing obviously but in my experience with jtag faster is not better lol.
"11" is a very safe figure to try. Now try 10. Keep lowering the number until you get a balance of stability and speed that you're happy with. I suspect there's something up with your USB system that's not playing nice with the usbasp drivers. I run mine with "0.1" and never have a hitch. Your issue isn't unique... I've seen it before (that's how I knew what to suggest)... but rare.
Old Apr 24, 2013, 07:25 AM
Grantham Kid is online now
Find More Posts by Grantham Kid
Chasin' that Neon Rainbow
Grantham Kid's Avatar
Got my battery, all installed, all good. thanks for the help.
RCG Plus Member
Latest blog entry: A bit about me
Old Apr 24, 2013, 02:16 PM
R3volut3ion is offline
Find More Posts by R3volut3ion
Flip-n- GO!
R3volut3ion's Avatar
That makes sense (new components and all). I'll give that a run till I get the right combination. That'll leave all options open. Thanks again Steve!
Old Apr 25, 2013, 05:14 AM
flipy is offline
Find More Posts by flipy
Registered User
Quote:
Originally Posted by s_mack View Post
Sorry I missed this post earlier. Also sorry I haven't gotten the 2.4 instructions up yet! My computer crashed last week and I only just got the replacement motherboard today. I'm way behind

Its mostly the same. There's a physical difference and now it only uses 3 screws/spacers instead of 4. The top right hole instead uses the included nylon standoff. Should be fairly obvious. Beyond that, you'll notice there are three 6-pin connectors instead of two. The one on the left is used with the new 6-wire harness that has the 5 white wires and 1 black one. You can completely ignore this if you don't have a TelemetrEZ. If you do, then plug in the cable and the black connector on it goes into the TelemetrEZ's ISP header with the black wire corresponding to the tiny arrow or circle (can't remember which I used!) that's printed on the TelemetrEZ board. That cable is used to update the TelemetrEZ firmware without need for a 3rd party programmer. To program the 9x, the 9x power must be on (as always since Rev 2.2) and to program the TelemetrEZ the 9x power must be off.

other than that, no significant differences. Drivers are the same. Usage is the same.
Thanks.
I finally took a look at the board and saw that it was pretty similar to rev 2.2.
Old May 09, 2013, 05:53 PM
danpos is offline
Find More Posts by danpos
Registered User
danpos's Avatar
I have 2.4 board and telemetrEZ board installed with the hobbyking backlight.
It's running fine except the backlit runs opposite. On when it should be off.
Any ideas how to fix this?
Got it. I put a check mark in the sp22 box on companion9x.

I stayed up most the night playing around with the OpenTX software, new telemetrEZ board, 9x Solderless Programmer Board Rev 2.4, and surfing through the "Open RC forums".

I also did the firmware update on the telemetrEZ board. That was so easy it was difficult. ha ha

Now that I have a decent grasp on the software features I will be using I'm totally impressed with my 9x remote!
GREAT WORK on developing these add on boards! Great product support too. Any time I got stumped I quickly found my answers in the forums within a few minutes.
What a bargain the 9x remote with these boards and OpenTX software is! I'm tempted to buy another set of the boards for my backup 9x remote.

And I'll send a some paypal money to the guys who are developing the OpenTx software too.
Can't forget to support them for their efforts.

Now to look into the voice options.
I wish you would build a sound board too? After reading all of the praises in this and other threads you should reconsider building one.
Would you consider building a limited amount as a trial on pre-orders?
Last edited by danpos; May 10, 2013 at 09:14 AM.
Old May 11, 2013, 11:30 PM
MJB9 is offline
Find More Posts by MJB9
ARMY ATC (93C)
MJB9's Avatar
I purchased a used/new v2.1 board and it's missing the usb board. sigh. I probably could mikey mouse my own connector but I just cut a random usb cable and all the wires are the same color. manual online warns not to reverse the wires. Any ideas what I can do?

Also, I purchased turnigy 9x from same person. Are there mode 1, mode2, etc programable? It boots showing mode 1 and throttle is on right (at least when I go into display menu). If I go into stick options and select mode 2, and exit, it's still showing mode 1. I'm a dx8 guy so totally lost. Is this radio not a mode 2?


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Download RCDeskpilot Add-on Planes In Post #1 UPDATED MARCH 7 2011 Wilfor Simulators 207 Nov 27, 2015 01:21 AM
Sold RealFlight G3.5 With Controller and Vol. 3 Add-On Rob02Aggie Aircraft - General - Miscellaneous (FS/W) 3 Nov 13, 2010 03:13 PM
Question Searching RC Car with transmitter having the pots NOT soldered directly on the board Nase Electric Power Cars 0 Nov 07, 2010 09:46 AM
Discussion Built-in-Balancer: Replace a 14.4 nihm pack with 5S LiFE leveraging original charger? coreyfro DIY Electronics 0 Nov 05, 2010 10:33 AM